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Notice

The material contained in this document is provided “as is”, and is subject to being changed, without
notice, in future editions.

Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either
express or implied with regard to this manual and to any of the Agilent products to which it
pertains, including but not limited to the implied warranties of merchantability and fitness for a
particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or any of the Agilent products
to which it pertains. Should Agilent have a written contract with the User and should any of the
contract terms conflict with these terms, the contract terms shall control.
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1 Signal Generator Overview

NOTE

For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

MXG ATE blank front panel models, N5161A and N5162A signal generators, are part of the
MXG instrument family and unless otherwise indicated, all references to the MXG are
inclusive of the MXG ATE instruments.

LXI Class B Compliance Disclaimer

As of this product firmware release in June 2008, LXI Class B Compliance Tests, using the
new IEEE 1588-2008 Precision Time Protocol (PTP), were not available. This product
provides the features of an LXI Class B instrument by adding LAN Triggering and Time
Synchronization to its LXI Class C compliance. References to LXI Class B in the document
and in the instrument menus and web pages do not insure LXI Class B compliance. This
product will apply for LXI Class B Compliance when the LXI Consortium has approved its
specification changes and can provide certified testing. Refer to
hitp.//www.lxistandard.org/home.

LXI-B is only available on instruments with serial prefixes >US/MY/SG4818.

e Signal Generator Features on page 2

* Modes of Operation on page 4

* Front Panel Overview - MXG N5181A/82A on page 5

*  Front Panel Overview - MXG ATE N5161A/62A on page 9

* Front Panel Display - MXG N5181A/82A/83A on page 11

* Blank Front Panel Display - MXG ATE N5161A/62A on page 13
* Rear Panel Overview - MXG N5161A/62A1/81A/82A on page 15
* Rear Panel Overview - MXG N5183A on page 21
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Signal Generator Overview
Signal Generator Features

Signal Generator Features

« N5161A1/N5181A, RF analog models: 100 kHz to 12, 3, or 6 GHz (Options 5012, 503, and 506
respectively)

N5162A1/N5182A, RF vector models: 100 kHz to 3 or 6 GHz (Options 503, and 506 respectively)

N5183A, Microwave analog model: 100 kHz to 20, 31.8, or 40 GHz (Options 520, 532, and 540
respectively)

¢ electronic attenuator (N6161A/62A/81A/82A only)

* mechanical attenuator (N5183A with Option 1E1 only)

* step & list sweep of frequency, power, or frequency and power
¢ vector models can include waveforms in list sweep

¢ adjustable pulse delay (Option UNU)

* analog differential I/Q outputs (vector models, Option 1EL)

¢ analog modulation: AM, FM, and ®M (Option UNT)

e arbitrary I/Q waveform playback up to 125 MSa/s (vector models, Option 654)
¢ automatic leveling control (ALC); power calibration

* bandwidth control (ALC)

¢ deep amplitude modulation providing greater dynamic range

* enhanced assembly replacement

* external AM, FM, and ®M inputs (Option UNT)

* external analog I/Q inputs (vector models)

¢ flexible reference input, 1 - 50 MHz (Option 1ER)

e GPIB, USB 2.0, and 100Base-T LAN interfaces

* improved signal to noise ratio

¢ LO In/Out (Option 012)

e LXI is supported

* manual power search (ALC off) (Option 099 and or instruments starting with serial numbers
4818 and greater)

* multiple baseband generator synchronization when using multiple signal generators (master/slave
setup)

¢ narrow pulse modulation (Option UNW)
* phase noise interference (vector models, Option 432)
¢ SCPI and IVI-COM driver

IThe N5161A/62A - Automated Test Equipment (ATE) have a blank front panel (i.e. no front panel display,
hardkeys or softkeys).

2Optiom 501 is not applicable to the N5161A.
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* user flatness correction

¢ user settable maximum power limit

* two channel power meter display

e 10 MHz reference oscillator with external output
* 8648/ESG code compatible

e with Signal Studio Software, vector models can generate 802.11 WLAN, W-CDMA, cdma2000,
1xEV-DO, GSM, EDGE, and more

For more details on hardware, firmware, software, and documentation features and options, refer to
the data sheet shipped with the signal generator and available from the Agilent Technologies website.

1. Open: http:;//www.agilent.com/find/mxg
2. Select the desired model number.

3. In the options and price list section, click price list.
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Modes of Operation

Depending on the model and installed options, the Agilent MXG signal generator provides up to four
basic modes of operation: continuous wave (CW), swept signal, analog modulation, and digital
modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to
a single frequency and power level. Both the N5161A/81A and N5162A/82A can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the
N5161A/81A and N5162A/82A provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog
modulation types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used together.

NOTE The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT
installed.

Refer to 14. Mod On/Off and LED.

Options UNU and UNW provide standard and narrow pulse modulation capability, respectively.

Digital Modulation (N5162A/82A with Options 651, 652, or 654 Only)

NOTE The internal baseband generator speed upgrade Options 670, 671, and 672 are option
upgrades that require Option 651 and 652 to have been loaded at the factory (refer to the
Data Sheet for more information). Any references to 651, 6562, or 654 are inclusive of 671,
672, and 674.

In this mode, the signal generator modulates a CW signal with a arbitrary I/Q waveform. I/Q
modulation is only available on the N5162A/82A. An internal baseband generator (Option 651, 652, or
654) adds the following digital modulation formats:

e Custom Arb Waveform Generator mode can produce a single-modulated carrier or
multiple- modulated carriers. Each modulated carrier waveform must be calculated and generated
before it can be output; this signal generation occurs on the internal baseband generator. Once a
waveform has been created, it can be stored and recalled, which enables repeatable playback of
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 227.

*  Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode,
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer
to “Creating a Custom Multitone Waveform” on page 251.

*  Two-tone mode produces two separate continuous wave signals (or tones). The frequency spacing
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between the signals and the amplitudes are adjustable. To learn more, refer to “Creating a Custom
Two-Tone Waveform” on page 251.

e Dual ARB mode is used to control the playback sequence of waveform segments that have been
written into the ARB memory located on the internal baseband generator. These waveforms can
be generated by the internal baseband generator using the Custom Arb Waveform Generator
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer
to“Dual ARB Player” on page 128.

Front Panel Overview - MXG N5181A/82A

5. Arrows and Select 8.Trigger
7.MENUS 11. Preset
4.Numeric 9. Local and and User
1. HostUSB 2. Display 3. Softkeys Keypad Cancel/(Esc) 10. Help Preset
‘ 6. Page Up
[ o £ Agllemt . L NS 1l
f e OO0 E O - EE
- = DOUEEGE - kE G
=) QIE)C 0= - &
=] & =@ —
(1] () 5| ¥ ?,
» T 18.Knob 16. | Input | 12. RF
[* l’\lJt,pllf
t 21. More and LED J 15.p b 17. Q Input
. Page Down
22. Power Switch and LEDs 20.Return 19. Incr Set 14. Mod On/Off and LED
13. RF On/Off and LED
1. Host USB

Connector Type A
USB Protocol 2.0

Use this universal serial bus (USB) to connect a memory stick for data transfer. You can connect or
disconnect a USB device without shutting down or restarting the signal generator. The instrument
also has a rear-panel device USB connector (see page 17) used to remotely control the instrument.

2. Display

The LCD screen provides information on the current function. Information can include status
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located
on the right-hand side of the display. See also, “Front Panel Display - MXG N5181A/82A/83A” on
page 11.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.
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4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 41.

5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing.
See “Entering and Editing Numbers and Text” on page 41.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on
page 42. When text does not fit on one page in the display area, use this key in conjunction with the
Page Down key (page 7) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access
information.

See page 127 See page 73

Reserved for See page 60
future use.

See page 43 | i Moda ] { AN ﬂ File ] [Ermr } See page 72
Aux Fy Save Litilit

See page 43“ . {m j ( [ F%See page 25
o Pulse ) [Racall !

See page 46“ [ { ﬁ-‘ [ H—See page 40

See page 117 See page 67

Active only on
vector models.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control,
cancels an active function entry, and cancels long operations (such an IQ calibration).
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10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on
page 40.

11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user-defined). See “Presetting
the Signal Generator” on page 40.

12. RF Output

Connector Standard: female Type-N
Option 1EM: Rear panel female Type-N
Impedance: 50Q

Damage Levels 50Vdc, 2W maximum RF power

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/Off LED lights when RF output is enabled.

14. Mod On/O0ff and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation
format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on
page 58).

The MOD ON/OFF LED lights when modulation of the output is enabled.

NOTE The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT
installed.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on
page 42. When text does not fit on one page in the display area, use this key in conjunction with the
Page Up key (page 6) to scroll text.

16. I Input (vector models only)

Connector Type: female BNC Impedance: 500
Signal An externally supplied analog, in-phase component of I/Q modulation.

The signal level is /2 QT 0.5 Vs for a calibrated output level.

Damage Levels 1V,

See also, “I/Q Modulation” on page 183.
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17. Q Input (vector models only)

Connector Type: female BNC Impedance: 50Q
Signal An externally supplied analog, quadrature-phase component of I/Q modulation.

The signal level is /2 QT 0.5 Vs for a calibrated output level.

Damage Levels 1V,

See also, “I/Q Modulation” on page 183.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit,
character, or item in a list. See also, “Front Panel Knob Resolution” on page 27.

19. Incr Set

This hardkey enables you to set the increment value of the currently active function. The increment
value also affects how much each turn of the knob changes an active function’s value, according to
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 27).

20. Return

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED
lights and all signal generator functions deactivate. The signal generator remains connected to the
line power, and some power is consumed by some internal circuits. In the on position, the green LED
lights and the signal generator functions activate.
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Front Panel Overview - MXG ATE N5161A/62A

1.HostUSB
i : B
.- Agilent Technologies MXG ATE Vector Signal Generator B ]
i WS 100 kHs-3 GHz - TTITTTEE—
L
LAN 15EE ERRDA )
[“R]
6. LAN Reset
22. Power Switch and LEDs 3.LAN 5. ERROR
4.1588

MXG ATE N5161A/62A Front Panel Functions

The MXG ATE is identical to an MXG with a front panel display, except that the front panel,
hardkeys and softkeys functionality are only available via SCPI commands or through the
Web-Enabled MXG. Refer to the Installation Guide, the Programming Guide and SCPI Command
Reference for information on Web- Enabled MXG ATE.

Functions unique to the MXG ATE:
e LAN LED (page 9).

e 1588 LED (page 10).

* ERROR LED (page 10).

* LAN Reset Hardkey (page 10).

For more information, refer to the Service Guide.

3. LAN LED

The LAN LED is used to indicate the LAN status.

e If the LED is off, the LAN is down.

e If the LED is blinking, the LAN is being configured (1.2 second duty cycle).

* A 400ms duty cycle indicates the instrument has been placed into LAN Identify mode. (Refer to
:INPut : LAN[:SET] : IDENtifier command).

e If the LED is solidly lit, the LAN is up and functional.
e If the LED fails to function, refer to the Service Guide.

Agilent N51614/ 624/ 814/ 824/ 83A MXG Signal Generators User's Guide 9



Signal Generator Overview
Front Panel Overview - MXG ATE N5161A/62A

4. 1588 LED

The 1588 LED indicates when the instrument is locked to an external 1588 clock.

e If the 1588 green LED is on, a 1588 signal has been detected on the TRIG OUT BNC on the rear
panel.

e If the 1588 green LED is off, no 1588 signal is detected on the TRIG OUT BNC on the rear panel.
If the LED fails to function, refer to the Service Guide.

5. ERROR LED

The ERROR LED indicates when there are unread errors in the error queue.
e If Auto reboot is disabled, the LED will blink when an exception occurs during power up.

e If the LED fails to function, refer to the Service Guide.

6. LAN Reset Hardkey

NOTE This hardkey is enabled for fail-safe and diagnostic mode and should rarely be used.

The LAN Reset is used to access the diagnostics mode during power up.
¢ Refer to the SCPI Command Reference for equivalent remote commands.

e If the LAN Reset fails to function, refer to the Service Guide.

7. Host USB

Connector Type A
USB Protocol 2.0
Use this universal serial bus (USB) to connect a memory stick for data transfer. You can connect or

disconnect a USB device without shutting down or restarting the signal generator. The instrument
also has a rear-panel device USB connector (see page 17) used to remotely control the instrument.

8. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/Off LED lights when RF output is enabled.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED
lights and all signal generator functions deactivate. The signal generator remains connected to the
line power, and some power is consumed by some internal circuits. In the on position, the green LED
lights and the signal generator functions activate.

10 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Signal Generator Overview
Front Panel Display - MXG N5181A/82A/83A

Front Panel Display - MXG N5181A/82A/83A

1. Active Function Area 2. Frequency Area 3. Annunciators 4. Amplitude Area

FREQUERCY 6.000 000 000 00 &x= ““P_Liwa']z.oo dbn

Scroll Bar

If there is more
text than can be
displayed on one
screen, a scroll
bar appears here.
Use the Page Up
and Page Down
keys to scroll
through the text.

5. Error Message Area 6. Text Area 7. Softkey Label Area

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the
current frequency setting appears. If the currently active function has an increment value associated
with it, that value also appears.

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one annunciator; in this case, only
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

M Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ®M.

ARB The ARB generator is on.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off.

Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator
(see UNLOCK, below).
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This annunciator appears when...

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at
temperature.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of
the error messages or clear the error queue (see “Reading Error Messages” on page 72).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ®M annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or
VXI-11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 106).

OFFS An output offset is set (see “Setting an Output Offset” on page 104).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 105).

RF OFF The signal generator’s RF Output is not enabled.

IS The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-11/Sockets (LAN)
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of

instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF,
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the
error messages (see “Reading Error Messages” on page 72).

WINIT The signal generator is waiting for you to initiate a single sweep.

4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed
out).

b. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent
message remains displayed. See “Reading Error Messages” on page 72.
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6. Text Area
This area displays signal generator status information, such as the modulation status, and other

information such as sweep lists and file catalogs. This area also enables you to perform functions
such as managing information (entering information, and displaying or deleting files).

1. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of
the display. Softkey labels change, depending on the function selected.

Blank Front Panel Display - MXG ATE N5161A/62A

MXG ATE N5161A/62A - Web Enabled Display

The MXG ATE only has display information available via a LAN connection to the Web Server
(“11. LAN” on page 17). For more information on the Web-Enabled signal generator refer to
Programming Guide.

Annunciators

NOTE On the N5161A/62A, the following listing of annunciators are only displayed and visible via
the Web-Enabled MXG. Refer to Programming Guide, “Using the Web Browser”.

Annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one annunciator; in this case, only
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

dM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ®M.

ARB The ARB generator is on.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off.

Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator
(see UNLOCK, below).

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at
temperature.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of

the error messages or clear the error queue (see “Reading Error Messages” on page 72).

EXTREF An external frequency reference is applied.
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This annunciator appears when...

FM Frequency modulation is on. If you turn phase modulation on, the ®M annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or
VXI-11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 106).

OFFS An output offset is set (see “Setting an Output Offset” on page 104).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 105).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-11/Sockets (LAN)
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of

instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF,
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the
error messages (see “Reading Error Messages” on page 72).

WINIT The signal generator is waiting for you to initiate a single sweep.
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Rear Panel Overview - MXG N5161A"/62A1/81A/82A

Digital Modulation Connectors (Vector Models Only) on page 18 1. AC Power Receptacle

Option 1EM 7.TRIGOUT
only . 6.TRIG IN
See page 7
2. SWEEP OUT 5.PULSE 8.REFIN 12. Device USB

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, see the
Installation Guide.

2. SWEEP OUT
Connector female BNC Impedance <1Q
Can drive 2 kQ.

Signal Voltage range: 0 to +10V, regardless of sweep width
In swept mode: beginning of sweep = 0V; end of sweep = +10V
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 48 and 117.

3. AM
Connector female BNC Impedance nominally 50€Q
Signal An externally supplied £1V, signal that produces the indicated depth.

Damage Levels 5V,  and 10V,

IThe N5161A and N5162A are only available with Option 1EM.
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4. FM
Connector female BNC Impedance nominally 50Q
Signal An externally supplied £1V, signal that produces the indicated deviation

Damage Levels 5V, and 10V,

5. PULSE
Connector female BNC Impedance nominally 50Q
Signal Externally supplied: +1V = on; 0V = off

Damage Levels 5V, and 10V,

6. TRIG IN
Connector female BNC Impedance high Z
Signal An externally supplied TTL or CMOS signal for triggering operations, such as

point- to- point in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels <-0.5V and >+5.5V

7. TRIG OUT

Connector female BNC Impedance nominally 50

Signal A TTL signal that is high at the start of a dwell sequence, or when waiting for the point
trigger in manual sweep mode.
It is low when the dwell is over, or when the point trigger is received.
The logic polarity can be reversed.

This is a multiple use connector. For signal routing selections, see pages 48 and 117.

8. REFIN

Connector female BNC Impedance nominally 50

Signal An externally supplied —3.5 to +20 dBm signal from a timebase reference that is
within *1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this connector
and automatically switch from internal to external reference operation. See “Presetting the Signal
Generator” on page 40. With Option 1ER (flexible reference input), you must explicitly tell the signal
generator the external reference frequency you wish to use; enter the information through the front
panel or over the remote interface.
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9. 10 MHz OUT

Connector female BNC Impedance nominally 50
Signal A nominal signal level greater than 4 dBm.
10. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 11. LAN and
12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector,
which enables a LAN-connected computer to remotely program the signal generator. The LAN

interface supports LXI; it does not support auto—-MDIX. The signal generator is limited to 100 meters
on a single cable (100Base-T). For more information on the LAN, refer to the Programming Guide.

12. Device USB

Connector Mini- B
USB Protocol Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.
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Digital Modulation Connectors (Vector Models Only)

1 0UT, @ OUT, | OUT, Q OUT

Connector Type: female BNC Impedance: 50Q
DC- coupled
Signal
I OUT The analog, in-phase component of I/Q modulation from the internal baseband generator.
Q OuT The analog, quadrature-phase component of I/Q modulation from the internal baseband
generator.
1 OUT Used in conjunction with the I OUT connector to provide a balanced® baseband stimulus.
Q OUT Used in conjunction with the Q OUT connector to provide a balanced?® baseband stimulus.
Damage Levels > 1 Vrms DC Origin Offset typically <10 mV

Output Signal Levels into a 50Q Load
* 0.5Vy, typical, corresponds to one unit length of the I/Q vector
*  0.69Vy, (2.84 dB), typical, maximum crest factor for peaks for m/4 DQPSK, alpha = 0.5
*  0.71Vpy (3.08 dB), typical, maximum crest factor for peaks for /4 DQPSK, alpha = 0.35
* Typically 1V}, ;, maximum

@Balanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity
(180 degrees out of phase).

EXT CLK
Connector female BNC Impedance nominally 50Q
Signal An externally supplied TTL or CMOS bit clock signal where the rising edge aligns with the

beginning data bit.
The falling edge is used to clock external signals.
This signal is used with digital modulation applications.

Damage Levels > +8 and < -4V Maximum Clock Rate 50 MHz
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EVENT 1

Connector
Signal

Damage Levels

PAT TRIG

Connector
Signal

Damage Levels

Signal Generatqr Overview
Rear Panel Overview - MXG N5161A/62A'/81A/82A

female BNC Impedance: nominally 50Q

A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.
Adjustable to * one timeslot; resolution = one bit

Markers

Each Arb-based waveform point has a marker on/off condition associated with it.

Marker 1 level = +3.3V CMOS high (positive polarity selected); —-3.3V CMOS low (negative
polarity selected).

Output on this connector occurs whenever Marker 1 is on in an Arb-based waveform (see
“Using Waveform Markers” on page 142).

>+8 and <-4V

female BNC Impedance: nominally 50Q

A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.
The input to this connector triggers the internal digital modulation pattern generator to start
a single pattern output or to stop and re-synchronize a pattern that is being continuously
output. To synchronize the trigger with the data bit clock, the trigger edge is latched, then
sampled during the falling edge of the internal data bit clock.

This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse (high or low) = 100 ns
Width

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods
> +8 and < -4V

DIGITALBUS 1/0

This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not
operational for general purpose use. Signals are present only when a signal creation software option
is installed (for details, refer to http://www.agilent.com/find/signalcreation).
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Signal Generator Overview
Rear Panel Overview - MXG N5161A/62A1/81A/82A

AUX 1/0

Pin1=Event1
Pin 2 = Event 2
Pin 3 = Event 3
Pin 4 = Event 4
25 1 Pin 5 = Sample Rate Clock Out

View looking into rear panel female 50-pin connector Pin 6 = Patt Trig 2

50 26 Pins 7-25 = Reserved*

Pins 26-50 = Ground
The AUX I/O connector is a shielded .050 series board mount connector.

Event 1, 2, 3, and 4 (pins 1 — 4)
A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.
Adjustable to * one timeslot; resolution = one bit

*Future Capability

Markers

Each Arb-based waveform point has a marker on/off condition associated with it.

Marker level = +3.3V CMOS high (positive polarity selected); -3.3V CMOS low (negative polarity
selected).

Sample Rate Clock Out (pin 5)
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data.
Damage levels: > +5.5 and < —-0.5V.

Patt Trig 2 (pin 6)

A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.

The input to this connector triggers the internal digital modulation pattern generator to start a single pattern output or to stop and
re-synchronize a pattern that is being continuously output.

To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled during the falling edge of the internal data bit
clock.

This is an external trigger for all ARB waveform generator triggers. Minimum pulse width = 100 ns. Damage levels: > +5.5 and < -0.5V.
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Signal Generator Overview
Rear Panel Overview - MXG N5183A

Rear Panel Overview - MXG N5183A

13. Z AXIS OUTPUT
14. ALC INPUT

1. AC Power Receptacle

Option 1EM 4.FM 7.TRIG OUT 10.GPIB
only 3.AM 6. TRIGIN 9.10 MHz OUT 11. LAN
See page 7
2. SWEEP OUT 5. PULSE 8.REFIN 12. Device USB

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, see the
Installation Guide.

2. SWEEP OUT
Connector female BNC Impedance <1Q
Can drive 2 kQ.
Signal Voltage range: 0 to +10V, regardless of sweep width

In swept mode: beginning of sweep = 0V; end of sweep = +10V
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 48 and 117.

3. AM
Connector female BNC Impedance nominally 50
Signal An externally supplied ile signal that produces the indicated depth.

Damage Levels 5V, and 10V,
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Rear Panel Overview - MXG N5183A

4. FM
Connector female BNC Impedance nominally 50Q
Signal An externally supplied 1V, signal that produces the indicated deviation

Damage Levels 5V,  and 10V,

b. PULSE
Connector female BNC Impedance nominally 50Q
Signal Externally supplied: +1V = on; 0V = off

Damage Levels 5V,  and 10V,

6. TRIG IN
Connector female BNC Impedance high Z
Signal An externally supplied TTL or CMOS signal for triggering operations, such as

point- to- point in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels <-0.5V and >+5.5V

1. TRIG OUT

Connector female BNC Impedance nominally 50

Signal A TTL signal that is high at the start of a dwell sequence, or when waiting for the point
trigger in manual sweep mode.
It is low when the dwell is over, or when the point trigger is received.
The logic polarity can be reversed.

This is a multiple use connector. For signal routing selections, see pages 48 and 117.

8. REFIN

Connector female BNC Impedance nominally 50

Signal An externally supplied —3.5 to +20 dBm signal from a timebase reference that is
within *1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this connector
and automatically switch from internal to external reference operation. See “Presetting the Signal
Generator” on page 40. With Option 1ER (flexible reference input), you must explicitly tell the signal
generator the external reference frequency you wish to use; enter the information through the front
panel or over the remote interface.
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Rear Panel Overview - MXG N5183A

9. 10 MHz OUT

Connector female BNC Impedance nominally 50
Signal A nominal signal level greater than 4 dBm.
10. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 11. LAN and
12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector,
which enables a LAN-connected computer to remotely program the signal generator. The LAN

interface supports LXI; it does not support auto—-MDIX. The signal generator is limited to 100 meters
on a single cable (100Base-T). For more information on the LAN, refer to the Programming Guide.

12. Device USB

Connector Mini- B
USB Protocol Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.

13. Z AXIS OUTPUT

This female BNC connector supplies a +5 V (nominal) level during retrace and band-switch intervals
of a step or list sweep. During step or list sweep, this female BNC connector supplies a -5 V
(nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on.
This signal is derived from an operational amplifier output so the load impedance should be greater
than or equal to 5 kohms.

14. ALC INPUT

This female BNC input connector is used for negative external detector leveling. This connector
accepts an input of -0.2 mV to —-0.5 V. The nominal input impedance is 100 kohms; the nominal
damage levels are +1 V and -12 V.
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2 Setting Preferences & Enabling Options

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

The Utility menu provides access to both user and remote operation preferences, and to the menus in
which you can enable instrument options.

Remote Operation

GPIB Address and Remote Language on page 29

[Utilitv : Configuring the LAN Interface on page 30
; Enabling LAN Services: “Browser,” “Sockets,” “VXI-11" and “LXI-B” on page 31
* Configuring the Remote Languages on page 32
ULility 7

I/0 Configm
User Preferences

St Front Panel Knob Resoluti 27
Justment.s \ ront Panel Knob Resolution on page
DisplauM {Setting Time and Date on page 28
Poner 0n/)| Display Settings on page 26
Preset

Power On and Preset on page 27
Instrument InfoM

/]

lore 1 of 2 Enabling an Option on page 36

Upgrading Firmware on page 28

Utility 7
L¥T-EM Setting the LAN Extensions for Instrumentation (LXI). on page 111
carvice——Hardware Assembly Installation and Removal Softkeys on page 38

e
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Setting Preferences & Enabling Options

User Preferences

User Preferences

From the Utility menu, you can set the following user preferences:

¢ Display Settings, below

e Power On and Preset on page 27

¢ Front Panel Knob Resolution on page 27

Display Settings

Utility > Display

DisElag ?

Erightness -
100

See also, Using the Secure Display (Option 006 Only) on page

Range: 0—100
/ g

Contrast”]
LS

/Range: 35—55

Screen Saver
| Of + Ju]

Screen Saver
ode
(Light Onlu)

Screen

Saver
Delau: 1 hr

Light Only: turns the display light off, leaving the text visible at a low intensity.

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to
prevent the text from burning the display.

fMore 1 of 2

Display &
Select EDlEr

Range: 1—12 hours, in 1 hour increments

Palette Select
Dark text on a light

Bright Color §— background.

ale
(Bright Color)

\J

Update in Remote
| OF Q]

_L—"the remote control bus update the signal

When on, commands executed through ____Lighttext on a dark

Dark Color
ark Lolor background.

generator display accordingly.

Activate
Secure Display

Monochrome +—— Bright without color

\page 268

Activate
Restricted
Display

m

e

For details on each key, use key help
as described on page 40.

NOTE With both brightness and contrast set to minimum, the display may be too dark to see the
softkeys. If this happens, use the figure above to locate the brightness and contrast softkeys
and adjust their values so that you can see the display.
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Power On and Preset

Utility > Power On/Preset >

Restores persistent settings
(those unaffected by a power
cycle, preset, or recall)

to their factory defaults.

Note

Setting Preferences & Enabling Options

User Preferences

Pouerup Type .~
Pouerup Preset s Last
Fouer Dn' >
(et Preset
Preset Language |
(SCPI) User

Restore Sustem

Sett
Default Values

ings tow

Select the GPIB language desired after a preset.
See also, the Programming Guide and the SCPI Reference.

Available only when 8648 is either the selected preset language or
the selected remote language (see page 29).

Y

Restore System

Confirm Restore
Sus Settings to
Default Values

\4“-*N‘-‘--

To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.

Front Panel Knob Resolution
:I:t' —— Makes the increment value of the current function the active entry.
Utility > The increment value and the step/knob ratio determine how much each

Instrument Adjustments >

Adjustments .~

Time/Date

Lnas st g, s, |

For details on each key, use key help

as described on page 40.

Step/Knob Ratio >
o071

turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the
step/knob ratio is 50 to 1, each turn of the knob changes the active
function by 0.2 dB (1/50th of 10 dB).

To change the amount for each turn of the knob, modify the increment
value, the step/knob ratio, or both.
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Upgrading Firmware

Setting Time and Date A T
- Time/Date
- - Utility > Off
CAUTION Changing the time or date can Instrument Adjustments > Ll 4
adversely affect the signal e ——— DaFDEﬁet
generator’s ability to use time—based 5041

licenses, even if a time—based . et Time
license is not installed. ime/Dater—®

Set Date

The signal generator’s firmware tracks the ———

time and date, and uses the latest time ‘\'\A\/\‘

and date as its time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time-based licenses,
and that you are resetting the signal generator’s time/date reference point. When you set a new time
or date that is later than the signal generator’s current reference point, that date becomes the new
reference point. If you then set the date back, you run the risk described in the next section.

Original time/date reference point New time/date reference point

® —>

Time

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the
reference point. If you set the time back more a few hours, you disable the signal generator’s ability
to use time-based licenses, even if there is no license installed at the time that you set the time back.
In this case, you can reenable the signal generator’s ability to use time-based licenses by moving the
clock forward to the original time or simply waiting that length of time.

Upgrading Firmware

For information on new firmware releases, go to http:/www.agilent.com/find/upgradeassistant.
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Remote Operation Preferences

Setting Preferences & Enabling Options
Remote Operation Preferences

For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

Utility

GPTE Setup

GPIB Address
19

I1/0 Config

I/0 ConfigM——-:m

Instrument
Ad justments® LAN Setupk
i LAM Services
Displauk et
Poner 0n/, Remote Language'
Preset (5CRI)

Instrument Infow

Hore 1 of 2 %

NOTES

USB is also available. It is not shown in the menu because it requires no configuration.

M

GPIE Setups —»L’M

page 30

page 31

Select the desired language.

This setting is not persistent and is cleared by performing a
instrument Preset. In most cases, it is best to use Utility >
Power On/Preset > Language for a permanent language

change. See page 32.

For details on using the instrument remotely, see the Programming Guide.

For details on each key, use key help as described on page 40.
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Remote Operation Preferences

Configuring the LAN Interface

Utility > 1/0 Config »1_LAH Confi 4 fanual Settings
. Auto
e e B
T/ Conis Hostams
I1/0 Confi MAGT py——
ubnet._Mas|
GPIB Setupw DL 0.0.0.0
Config Tupe
e Default. Gat
- 2 faL ateEy
LAN Setups Auto-1P 11,121,851
Manual Config
ettings”| e
LAM Services I fManual L
Setup*f  Below 255,255, 255, 255
Aduanced,
Settings N o N s ONS Seryer
Remote Language, - Ouertide
(SCPI) Proceed With Off
Reconf iourat ion
\ Haming Services /
Adv Settings Dunamic OMNS .
\ ) Na% TCP Keep Alive
Apply Setlings 7 M= (EE DFf TCP Keep Alive
E?Hth_r'm Ehanﬁ FFC NE;E}ES aff
ethork Wi :
FEStATE) ggﬁgggr&;gn oFf il TCP Kesp ALive
0.0 sec
Ly btitn,, gttt Dunamic Hostname,
Services
NOTES
Use a 100Base-T LAN TCP Keep Rliue'
cable to connect the signal generator to the LAN. Setup §
Confirm
Use a crossover cable to connect the signal DHEgzgigeggié fAdu Seliings 7
generator directly to a PC. ) Fiestora LA
fore 1 of 2 > Settings toM L Confirm Restore

Default Values AN Settings to
Default Values

For details on using the instrument remotely,
refer to the Programming Guide and to Listed in the )
www.agilent.com and search on FAQs: Hardware Programming Guide —

Configurations and Installation for the Agilent w

MXG.

For details on each key, use key help as described on page 40.
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Setting Preferences & Enabling Options

Enabling LAN Services: “Browser,” “Sockets,” “VXI-11" and “LXI-B"1

Utility > 1/0 Config

I/0 Config

GPIE Setups

LA Setups

FTP Serwer
Off

LAH Services 7

Heb Servicesw

Enable remote (browser) access to

the instrument’s file

leb Services

Heb Serwer
aOff

LAN Services
Setup”]

Remote Language
(SCPT Y

Y

SCPI SerwvicesM

LKXI-B Enabled
0ff N

__page 11

~4-\4,‘~,;4“*"\‘.

Proceed Hith
Reconf iourat ion

For details on each key, use key help

as described on page 40.

:

>

y

SCPI Services 7

Sockets SCRI
aOff

WHI-11 SCPI
0ff N

Remote Operation Preferences

Use a browser to control the
signal generator.

License Manager
Serwer
Off

License Manager Server (On)
allows updates of the

e

instrument licenses, disable for
additional instrument security.

Apply Settings .~
Confirm Chanoe

\/

(Instrument
Will Reboot)

N i A LA,

I1.XI-B is only available on instruments with serial prefixes >US/MY/SG4818.
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Remote Operation Preferences

Configuring the Remote Languages

Figure 2-1 N5161A/62A/81A/82A

Utility > 1/0 Config

IEI] Conf iE 7

GPIE Setups

LAN Setupw

LAM Services
Setup®

Femote Language
(5C

PIY

M

Select the desired Remote language.

Remote | anguage
SCPT

Remote | anguage

Remote | anguage

Remote | anguage

ELL23C ,ELL38C

EB2570,E8267D
ESBEZE

EB2L7C ,EB257C
ES267C

E22L 1A ,E82LLA
EB251A,EB250A

fore 1 of 3 3

For details on each key, use key help

as described on page 40.

Hore 2 of 3~

Refer to the SCPI Command Reference.

ELL2xB ,ELL3xE Fohde & Schuarzm > SHETEEBSE
S serorlent
R S
SHL

Sy

Remote | anguage

— 2410 Series
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Setting Preferences & Enabling Options
Remote Operation Preferences

Figure 2-2 N5183A

Utility > 1/0 Config >

IEI] Conf iE 7

GPIE Setups Select the desired Remote language.

LAN Setupw

LAM Services
Setup®

Femote L >
Bmnte Langiet > femote Language 7 Remote Language 7 femote Language 7 Remote Language 7
: EE62A
M SCPI 8360 Series (GPIE onlu) StR
EE63A
ELLZEC ,ELL3EC 837118 ,837128 (GPIE onla)
s «'/ "
EBES?D,EEEE;E 53731B,837328 Rohde & Schdarzw -
EBEWC,EEEE;E 837518 ,837526 Anritsu MG3E3xEM— [Remote Language
MGIEI1E
ESZ41A ,EZ24LA 2340883418 (GPIE only)
ESZ51A,ES25LA (GPIB only)
~Tore L of 3 ° MGIEI2E
fore 1 of 3 [_Hore 2 of 3 [_Hore 3 of 3 (GPIB onlg)
MGIEI3E
(GPIE only}
HMGIEILE
(GPIE only}
For details on each key, use key help Refer to the SCPI Command Reference.

as described on page 40.
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Remote Operation Preferences

Configuring the Preset Languages

Figure 2-3 N5161A/62A/81A/82A

Utility> Power On/Preset Select the desired Remote language.
Pouer_On/Preset Preset Language # Preset_lLanguage # Preset_lLanguage # j Preset_lLanguage #
Pover I SCPT ELL2x8 ELL3E Fonde & Schuarz] R onco
IArE=EE e \ ELLZ2E0 ,ELL3aC e Eéﬂ? Acrof Lexk SHJ100A
ES2570,EE2670 8E56E ,8657A /B
\ ESEE3E (GPIE onlu) SMIO
Festore Sustem \
q ES2L7C ,EB257C
Settings toM B SHL
Default Walue: \ E8267C
\ \ ESZL1A,EG24LA P
ES251A,E325LA
\\ Hore 1 of 3 fore 2 of 3
)
page 27
|_p|Preset Language
2410 Series
For details on each key, use key help Refer to the SCPI Command Reference.
as described on page 40.
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Figure 2-4 N5183A

Utility > Power On/Preset

Pouer_On/Preset

Paver Onll _page 27

(Preset.)
Preset. Language,
(SEPLY f——Preset Lanouage 7
/ ScPI

RESET .SHSW@ ELLZAC ,ELL3E0

ettings to
Default Values/|

EB2570,E8267D
ESBEZE

EB2L7C ,EB257C
ES267C

E22L 1A ,E82LLA
EB251A,EB250A

Hore 1 of 3 %

For details on each key, use key help
as described on page 40.

Setting Preferences & Enabling Options
Remote Operation Preferences

Select the desired Remote language.

Preset_lLanguage #

8360 Series

Preset_lLanguage #

8bb2A
(GPIE onlu)

Preset_lLanguage #
SHR

837118 ,83712E

8bE3A
(GPIE onlu)

837318 ,83732E

Fohde & Schuarzm

837518 ,83752E

i
L

Preset_lLanguage

Anritsu MG3E9xEr

S3L0E ,8341B
(GPIB onlu)

fore 3 of 3

Refer to the SCPI Command Reference.

MG3E316
(GPIE onlu)

MG3E32E
(GPIE onlu)

MG3E95E
(GPIE onlu)

MG3E34E
(GPIE onlu)
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Enabling an Option

Enabling an Option

There are two ways to enable an option:

¢ Use the License Manager software utility:
1. Run the utility and follow the prompts.

2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files
from an external USB memory drive.

* Use SCPI commands, as described in the Programming Guide.

Viewing Options and Licenses

Utility > Tnstrument Info Options Tnfo
Instrument Info Instrument,

Dimgnostic Infom Opt ions*

q > Auxiliary >
UFETETS Mntery Software Options"| Aux Softuare Licenses

Self Teste E?gg;gggr
Tretallod NP Service Software Licenses
Board Info” appear here.

Front. Panel Testse

Haveform Licenses | —
Have ID Days Left Description

Waveform licenses from some

Instrument options appear Signal Studio applications appear here.
here. A check mark means that
an option is enabled.

\

Instrument Options

Option Expiratiqgn Description

[AE] ermanent [Oigitgl Out

0o& permanent. + Instrument security

019 permanent. + Increase baseband generator memory to BLHS
1EL permanent. + Differential IO outputs

1EQ permanent. ¥ Lol Power (<-110 dBm? ||
1ER permanent. Flexible reference input (1-50 MHz)

Lo3 permanent. + Calibrated AHGN

S0& permanent. ¥ b GHz freguency ranoe

B5L permanent. ¥ Internal baseband oenerator (125 MSa/s)
LINH permanent. + Standard front panel outputs

For details on each key, use key help
as described on page 40.
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Service Menu

There are two ways to

enable an option:

¢ Use the License Manager software utility:

1. Run the utility and follow the prompts.

Setting Preferences & Enabling Options

Service Menu

2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files
from an external USB memory drive.

¢ Use SCPI commands, as described in the Programming Guide.

Viewing Options and Licenses

Utility >
Instrument Info

Instrument Info

Options Info

Board Info®

Instrument options appear

Front. Panel Testse

Haveform Licenses

Dimgnostic Infom InSBE%EERg:
q > Auxiliary >
UFETETS Mntery Software Options"| Aux Softuare Licenses
Self Teste E?gg;gggr
NPTy Service Software Licenses
Installed

appear here.

Have ID Days Left Description

Waveform licenses from some
Signal Studio applications appear here.

here. A check mark means that

an option is enabled.

\
\

Instrument Options

Option Expiratiqgn

003 Ermanent

0o& permanent. B
019 permanent. B
1EL permanent. B
1EQ permanent. o
1ER permanent.

Lo3 permanent. B
S0& permanent. B
ESL permanent. B
LInM permanent. b

Description

[Oigitgl Out
Instrument security

Increase baseband generator memord to BLMS

Differential I0 outputs

Low Power (<-110 dBm)

Flexible reference input (1-50 MHz)
Calibrated AWGM

& GHz freguency range

Internal baseband generator (125 MSa/s)
Standard front panel outputs

For details on each key, use key help
as described on page 40.
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Setting Preferences & Enabling Options
Service Menu

Hardware Assembly Installation and Removal Softkeys

Utility > More 2 of 2 > Service For details on each key, use key help
as described on page 40.

- Remove Assy .~
Service Prepare .
CPU Assembly
REWEYS) (BT For Removal N5162A/82A only
Confirm Removal
=R ﬂpreﬁgfie Prepare of CPU Assembly
SSE
Install Assemblusfl FDr‘F!erroua% ngrﬂﬁgﬁgﬁéf Ahort.
01
( ‘\ Whether a softkey is available \ Hemuaﬁ)
" A depends on the model of MXG. Prepare S—
VN MH Assembly
For Remowal
N5183A only
Note: When pressed, a Confirm Removal menu (similar to the
one shown here for the CPU assembly) is opened for the RF,
BBG, and MW assemblies too.
Note: When pressed, a Confirm Install menu (similar to the one
shown here for the CPU assembly) is opened for the RF, BBG,
and MW assemblies too.
\i
__Install Ass gonfirm Install X
Finalize - g
CPU Asbemblo N5162A/82A only Installation
Linstaitlatuon) of CPU Assembly
: : Finalize !
FF honotban ¢ Pataliorion et
Installation o Installation Installati
<] Whether a softkey is available ]
( depends on the model of MXG. - -
> Finalize
M Assembly
Installation /AAA-/ .
/“
N5183A only
Note:

Each Remove Assembly softkey (CPU/RF/BBG/MW) when enabled will display a message in the lower left quadrant of display indicating
assembly prepared for removal or removal has been aborted.

Each Install Assembly softkey, when enabled will display a message in the lower left quadrant of display indicating assembly prepared for
installation or installation has been aborted.

Refer also, to the Service Guide.
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3 Basic Operation

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

This chapter introduces fundamental front panel operation. For information on remote operation,
refer to the Programming Guide.

* Presetting the Signal Generator on page 40

* Viewing Key Descriptions on page 40

* Entering and Editing Numbers and Text on page 41

e Setting Frequency and Power (Amplitude) on page 43
e Setting ALC Bandwidth Control on page 45

* Configuring a Swept Output on page 46

* Modulating the Carrier Signal on page 58

* Working with Files on page 60

* Reading Error Messages on page 72
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Basic Operation
Presetting the Signal Generator

Presetting the Signal Generator

TPraset”
|
——To return the signal generator to a known state, press either Preset or User Preset.
g::s'm ——1  Preset is the factory preset; User Preset is a custom preset* (see also, page 27).

To reset persistent settings (those unaffected by preset, user preset, or power cycle),
press: Utility > Power On/Preset > Restore System Defaults.

*You can create more than one user preset by giving each saved state file a different name (see Figure 3-11 on page 70).

Viewing Key Descriptions

g The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key.
The help displays and the key's normal function does not execute.
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Basic Operation
Entering and Editing Numbers and Text

Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Use the number keys and decimal point to enter numeric data.

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

Local
ancel/

)

EIEIEIS

00000
BlEIS
319

90

For details on each key, see page 40.

Entering Alpha Characters

Data entry softkeys appear in
various menus. If their meaning
is not clear in context, use the
help key (described on page 40)
to display an explanation. Use
the softkey next to the alpha
table for help on the table.

Selecting data that accepts
alpha characters, displays one of
the menus shown at right.

Use the arrow keys or knob to
highlight the desired letter, then
press the Select hardkey (or the
softkey next to the alpha table).
To correct errors, use Bk Sp or
Clear Text.

=) (0

-+ —

Use the Select hardkey to choose part of an entry, as when entering alpha
Incr
=t

To specify a negative value, enter the
negative sign either before or after

the numeric value (this key is a toggle).
Backspace moves the cursor to the left,
deleting characters as it goes.

zaue Page up/down keys move tables of data up and down within the display area.

Left/right arrow keys move the cursor horizontally.

o

Page characters. In some menus, the Select key also acts as a terminator, and is
Zavn equivalent to the Enter softkey.

Note: Rotating the knob increases or

decreases a numeric value, changes a

highlighted digit or character, or steps
s through lists or items in a row.

See also, Front Panel Knob Resolution on page 19

Note: File names are limited to 25 characters.

Text Entry 7 Text Entry Table Edit
Enter Enter
Clear Text Editing kKeussf—9 Clear Text
Displaded Case Editing Mode

Editing Mode
Ml Feplace

Lower

Feplace

L,-.Aw-

to move the cursor

Show ﬂlpla\ac Table Show Alpha Table

within the active value =
off IEl
¢ rather than within the =
alpha table, turn the FBCOEFGHIJKLH
ﬁgg"ﬁg?ﬂﬁﬂgbg alpha table off. HOPORSTUULXYZ
o L 388+ O [1(}%
0 #+L[1 T @*® -~

Add/edit comments for saved
instrument state files (see page 67).

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the
letters A through F (use the numeric keypad for other values).
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Basic Operation
Entering and Editing Numbers and Text

Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.
2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.
Active Function Area Cursor

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable)
item, either press Select, or simply enter the desired value.

FREQUEHC PLLTUDE List Table
6.000 000 000 00 &+ 44.00 cen / Isert. Ao
_ Oalete Roud
List Hode Ualues
(1/1) Frequency  Pouer Haveform
1 100000000000 GHz|-135.00| WFN1:RAMP_TEST_HFH =)
g L+ /00000000000 GHz|-135.00|  (vector models only) 4< Insert Item
\ \ Oelete Item
\ Goto Roqe
| / / { Tore 1 of 2 )
Table Editor Name Table ltems Table Editor Softkeys

Indicates that
another menu
is available; to

Table items are also Used to load, navigate, modify, and
called data fields. store table item values. For details

Current / Total Number of Pages on each key, use the key help:

display the
;rezs the gIEIp hardkey and then second menu,
€ desired key. press More.

Highlight the desired item: use the arrow keys or the knob to move the cursor.
4. (Optional) Display the selected item in the active function area: Press Select.
Modify the value:

o If the value is displayed in the active function area, use the knob, arrow keys, or numeric
keypad to modify the value.

e If the value is not displayed in the active function area, use the numeric keypad to enter the
desired value (which then appears in the active function area).

6. Terminate the entry:

o If available, press the desired units.
e If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.
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Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

'

Freguency
Freq Ref Set
0.00 Hz

Freg Ref
On =

—page 10

Freq Offset
0.00 Hz

Freg Multiplier
1.000 =

Freq ChannelsM

fore 1 of 2 §

For details on each key, use key help

as described on page 40.

To display the next menu, press More.

Refer to the SCPI Command

Reference.

Freq Channels .~

Freg Channels
[Tl On

Channel Nunhei

Basic Operation

Setting Frequency and Power (Amplitude)

Device
M3

Channel Band
(P-GSH Base)®

\/\‘M

Freguency

Fhase Ref Set

Adjust Phase
0.000 rad

Reference, |
Oscillator

Hore 2 of 2

L page 44

q Amplitude
Amptd Ref Set
0.00 dBm
fmptd Ref
Amplitude o h IEEI on
pensthe
Atten/ALC
Eontmlv—Atten/ALC Amptd Offset
Control 0.00 dB
e menu.
aff User Flatness¥—Page 86
Output. Blankin
B on R
__Tore 2 of 3__°
This softkey sets
a user
fiore 1 of 3 ™| determined
A maximum power
Amplitude level on the
User Power Mawx [ instrument that
0.00 dBm is persistent.
HserEPoﬁr‘_ Enables the
E'Dne User Power
Max softkey.
ALC BW

(AULO ) "~_Page 45

OPtimize S/M
on

fore 3 of 3 ™

Enables the optimize signal-to-noise ratio state (Optimize S/N) on or off.

The optimize signal-to-noise softkey optimizes the attenuator and alc setting to provide optimal
signal-to-noise performance; it does not change the RF output power.

Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation
type. A settings conflict error will be generated if attentuator hold or any modulation is activated
when optimize signal-to-noise is active (On).

Example: Configuring a 700 MHz, —20 dBm Continuous Wave Output

1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the
front panel display areas are shown on page 11).
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Basic Operation

Setting Frequency and Power (Amplitude)

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz.
The signal generator displays 700 MHz in both the FREQUENCY area of the display and the active

entry area.

3. Set the amplitude to —20 dBm: Press Amptd > -20 > dBm.

The display changes to —20 dBm in the AMPLITUDE area of the display, and the amplitude value
becomes the active entry. Amplitude remains the active function until you press another function

key.

4. Turn on the RF Output: Press RF On/O0ff.
The RF Output LED lights, and a 700 MHz, —20 dBm CW signal is available at the RF OUTPUT

connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

Freq > More

Freguency

Fhase Ref Set

Adjust Phase
0.000 rad

Feference

Oscillataor’]

Hore 2 of 2

\i

Ref Oscillator

Fef Oscillator
SourceM
(AULO)

Int. [——Uuses the signal generator’s internal reference oscillator.
uses the REF IN connector to get it's Frequency Reference. Note: An

Ewt, f——error screen is displayed if the reference is not connected or is tuned
to the wrong frequency.
uses the signal generator’s internal reference unless a signal is

Auto [——present at the rear panel REF IN connector. If an external signal is
present, that signal is used as the reference.
PRV Sy N

Fef Oscillator
Ext.

wt Freq
10.0000000 MHz

Fef Oscillator
Ext Bandlidth
Narron

\Eange: 1-50 MHz
or guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth,

operation using frequencies below 2 MHz is not guaranteed.

IS el

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the
external reference you are using is noisy or spurious, use the narrow bandwidth mode.

With Wide bandwidth selected, If you select a frequency less than 2 MHz, the signal
generator displays a warning message.

For details on each key, use key help as described on page 40.

a4
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Figure 3-2 Using an External Reference Oscillator

Setting ALC

Basic Operation
Bandwidth Control

MXG Close In Phase Noise @ 1 GHz
-4.00E+01 T
-4 50E+01 bt
o
smoesar LY MM
5 50E+1 i \
-B.00E+01 V"‘ -} natrow bandwidth mode, H——F—————H
E.E0E+01 \|L w‘\m external reference |1 | | | ]|
7. 00E+01 P\w - M\M wide bandwidth mode, ||| | 11|
external reference
7 50E+01 e
-5.00E+01 WMW
0.50E+01 SR
& -9.00E01 e
3 -9.50E+01 )N
= 1.00E+02 ea
-1.05E+12
-1 10E+12 WM\
-1 15E+12
-1 20E+12 i
-1.25E402
-1 30E+02
-1 356402
-1 40E+12
-1 46E+12
-1.50E+12
1.00E+10 1.00E+01 1 00E+02 1.00E+03 1 00E+04 1.00E+15 1.00E+16
Offset Frequency
Setting ALC Bandwidth Control
Figure 3-3 Amplitude Softkeys
Amplitude 7 Amplitude # Amplitude 7
Atten/ALC, Amptd Ref Set User Pouer HMax
Control 0.00 dBm 0.00 dBm
ALC amptd Ref R IFERr
OFf oz O e Esnle
Amptd Offset ALC BU,| g ™AIT Banduidih Enables the
0.00 dB (AuULo) automatic
S/ Auto ALC .
User FlatnessM 8 o bandwidth
mode
) 200 Hz +——(Auto).
Output Blankin . .
Off On lﬂ!!ﬂ Disabling the
S Auto ALC
fore 1 of 3 ™ Hore 2 of 3 % fore 3 of 3 ™ mode, sets
the
bandwidth to
200 Hz.
For details on each key, use key help Refer to the SCPI Command To display the next menu, press
as described on page 40. Reference. More.
Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 45



Basic Operation
Configuring a Swept Output

Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude points:

Step sweep (page 49) provides a linear or logarithmic progression from one selected frequency,
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along the
sweep. The sweep can progress forward, backward, or manually.

List sweep (page 54) enables you to enter frequencies and amplitudes at unequal intervals, in
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep
data in the file catalog (page 65).
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Figure 3-4 Sweep Softkeys

The selected sweep type determines the displayed parameter.
Selecting step sweep also displays the step spacing (Lin or Log).

Basic Operation

Configuring a Swept Output

J During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

Progress Bar: Note that very fast sweeps
can appear to sweep randomly or

backward.
FREQUEHCY AAPLITUDE SueepsLi
6.000 000,000 00 &z | -144.00 den ez, > ey Tioie
Sweep Tupe 037
8 /List Status Informatjion List %
o Freq
ELETR O SLecp Fepegt an
Sweep Tupe (Step LIN Single ﬁ
Manual Mode o OFfF arotd
Sweep Direction: Up off i
Sweep Repeat 1 Cont
Sweep Triooer @ FreeRun
Step Points 101 Point Triooer : FreeRun Confioure
Step Snessf— PA98 49
Step Duell : 2.000msec
flore 1 of 3
Sweep without waiting for
_Trigger Setup 7 trigger at each point. On vector models:
/}ioint Trigger pauses for the dwell Available when
Free Run time prior to the first sweep. See Sweep Type = List
page 108.
SueeEZList F q
Configure Trigger Key Trigger on a remote command.
List Sueep®f —Page 54
Bus Apply a TTL/CMOS signal to the
SHeep Tr“igger“' rigger In connector.
(Free Run? Down sweeps from
ExLH Periodically issue a trigger event to stop to start

Point Trigger
(Free Run)”|

Timer TriggerM

1 Hore 1 of 2 %

-whatever selects it as a source.

SueeEZList 7
N . S Sweep Direction
Using timer trigger with single Dowun NN
sweep results in a delay prior to the

first sweep. See page 108. Trigoer Out

frequency/amplitude.

Up sweeps from start
to stop
frequency/amplitude.

> page 58 — Ngglar“lt
] Sets the trigger Does not effect
_Trigoer Setup source to any Sweep Retrace Sweep Out BNC
~Tore 2 of 8 g | enabled LXItrigger. OfFf or TRig Out BNC
Y Lt LHI LAN input event. signals that are
routed as Source
Sets an LXI Alarm Settled (See
during a sweep or page 48).
LA (LR [ point trigger. )
Configure alarm via Route Conmectorssf—page 48

SCPI only.

- __flore 3 of 3 %

For details on each key, use key help as described on page 40.
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Basic Operation
Configuring a Swept Output

Routing Signals

Sweep > More > More > Route Connectors

Trio DUt BHC Select the signal that you want
Gt Connectors 7 Trie Out BAC 7]
Route co"r;‘ectorsT routed to each output connector.
oute (o 3
Trig Out BMC > Sueep Trig Out
Creep 1o D) N5161AY/62AY/81A/82 Trig Out BAC
~A see
i " Sueep Out BIE_/
Sueep Dot BNDL_AOWY _y Sueep Out BHC Source Settled) | Ly [FPage 113
(Sleep Out) ~ . out
Hee| 1)
ute 103 h i Pulse Sunc
Event. 1 BHCH These N
G 4 softkeys are N
only available Source Settled ]
for the Pulse Yideo
winaaee |\ pulse video
\\ EBG Markers >—

Sueep Dut BHC

N5183A Only\‘W Hore 1 of 2

Marker 2 ST (T These softkeys are only
N5183A only: available on a
Optimizes the < (ot 5128 QU N5162A/82A with a BBG.
Marker 3 N5183A 10V —} ptimized for ;
Th ftk trols th
Sep Swueep [ B Sinton) i oy conte e
weep Ou
BNG sotup 5 cettled (N5162AL/82A only) on
Marker with the ource setile the rear panel TRIG OUT
8757D.* BNC connector.
e — Jl Pulze Wideo Y
e *The N5183A ig out BHC
signal
generator does Marker 1
not support the
8757 system
interface. Marker 2
Source Settled is not effected by Trig
Out Polarity Neg Pos softkey
selections (see page 47). Marker =
Marker L

-

1 The N5161A and N5162A are identical to an MXG with a front panel display, except that the front
panel, hardkeys and softkeys functionality are only available via SCPI commands or through the
Web-Enabled MXG. Refer to Programming Guide and SCPI Command Reference for information on
Web-Enabled MXG.

For details on each key, use key help Refer to the SCPI Command
as described on page 40. Reference.
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Step Sweep

Basic Operation
Configuring a Swept Output

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or
both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The
sweep can progress forward, backward, or be changed manually.

The N5183A allows you to use step sweep along with the frequency markers on instruments during
measurements (refer to “Using Frequency Markers (N5183A Only)” on page 52).

NOTE

The N5183A does not support the 8757 system interface.

Figure 3-5 Sweep Softkeys

For details on each key, use key help
as described on page 40.

Dwell Time = the time that the signal is settled and you can make

v a measurement before the sweep moves to the next point.
SueeEZList 7 E E 7| Steé Sueeé 7 . S
Step Suee (Point-to-point time is the sum of the value set for the dwell plus
Sweep | Freq Start Step Duell processing time, switching time, and settling time.)
(Off) &.00000000000GH=z 2.000 msec

Sweep Tupe
List %

Freg Stop
. 00000000000GHz

Step Spacing
LOG™ ]

Step Sweep and List Sweep dwell times are set independently.

N Lin = steps equally spaced over the sweep; the output changes
linearly.

Log = step spacing increases logarithmically over the sweep; the

SHeep Repeat Amptd Start (

Sinole Mo -135.00 dBm \_ Markersy
Amptd Stop
—135.00 dBm ot

Conf igure

# Points
Step Sweep*— 101

fore 1 of 3

fMore 1 of 2

Example: Configuring a Continuous, Linear Step Sweep

output changes exponentially.

N5183A Only: Opens the frequency marker menu. See page 52.
(The N5183A does not support Agilent 8757 the system interface.)

Output: A signal that continuously sweeps from 500 to 600 MHz and from —20 to 0 dBm, with a
dwell time of 500 ms at each of six equally—spaced points.
1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step spacing

selection, you do not need to set these parameters.

Open the step sweep menu: Press Configure Step Sweep.

Set the following parameters:

Start frequency 500 MHz:

Stop frequency 600 MHz:

Amplitude at the beginning of the sweep, —20 dBm:
Amplitude at the end of the sweep, 0 dBm:

6 sweep points:

Dwell time at each point, 500 milliseconds:

Press Freq Start > 500 > MHz
Press Freq Stop > 600 > MHz
Press Amptd Start > -20 > dBm
Press Amptd Stop > 0 > dBm.
Press # Points > 6 > Enter

Press More > Step Dwell > 500 > msec
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Basic Operation
Configuring a Swept Output

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd Off On.

A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude.
The SWEEP annunciator displays, and sweep progress is shown in the frequency display, the
amplitude display, and the progress bar.

5. Turn the RF output on: Press RF On/O0ff.
The RF LED lights, and the continuous sweep is available at the RF Output connector.

Using Basic Step Sweep Functions
This procedure demonstrates the following task:

¢ “Configuring a Frequency Sweep” on page 50

Configuring a Frequency Sweep

For this example, we are going to set a step sweep using the N5183A, over a frequency range of
7.5 GHz to 10.0 GHz, using a band-pass filter as our device under test, and display that response on
a 8757D Scalar Analyzer.

1. Set up the equipment as shown in Figure 3-6.

NOTE The N5183A signal generator does not support the 8757 system interface.

Scalar analyzer settings must match the signal generator’s settings.

Figure 3-6 Equipment Setup

BNC Cable
BNC Cable
Z-Axis' Sweep
Blank/Mkrs Out
_.,_-"" ofl
! Eﬁﬁ.ﬂ"ﬂﬂr\ in
. HED a
|
RF
Output
N5183A 8757D
MXG Microwave Signal DUT Detector Scalar
Generator ] 1 Network

Analyzer*

*The N5183A signal generator is not compatible with the 8757 system interface.
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Basic Operation
Configuring a Swept Output

2. Turn on both the 8757D and the N5183A.

3. On the 8757D:
a. Press SYSTEM > MORE > SWEEP MODE and verify that the SYSINTF softkey is set to OFF.
b. Press SYSTEM > MORE > DC
Press SYSTEM > Freq LABELS > START FREQ > 7.5 GHz
d. Press SYSTEM > FREQ LABELS > STOP FREQ > 10.0 GHz
e. Press SYSTEM > TRACE # POINTS > 801
4. On the N5183A:
a. Change the connector routing to 8757D System, enabling the N5183A to provide a sweep out
to the 8757D during Step sweep operations. Press Sweep > More > More > Route Connectors >
Route to Sweep Out BNC > Sweep Out (Optimized for 8757D System).
b. Press Sweep > Configure Step Sweep > # Points > 801
Press Sweep > Configure Step Sweep > Freq Stop > 10.0 GHz
d. Press Sweep > Configure Step Sweep > Freq Start > 7.5 GHz
e. Press Sweep > Sweep > Freq On Off set to On
NOTE During swept RF output, the FREQUENCY and/or AMPLITUDE areas of the signal generator’s
display are greyed out, depending on what is being swept. In this case, since frequency is
being swept the FREQUENCY area of the display is greyed out.
5. On the 8757D: Adjust the settings for start and stop frequency response of the device under test

(DUT) so it is clearly seen on the 8757D display.

You may need to rescale the response on the 8757D for a more accurate evaluation of the
amplitude. Figure 3-7 on page 52 shows an example of a bandpass filter response.
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Basic Operation
Configuring a Swept Output

Figure 3-7 Bandpass Filter Response on 8757D

STRT 7.50082 GHz STOP 10.220@ GHz
DC 421 SYSINTF OFF

Using Frequency Markers (N5183A Only)
In step sweep mode, you can use the N5183A to create up to 20 frequency markers to display on
your measurement equipment.

NOTE The N5183A does nmot support the 8757 system interface.
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Figure 3-8 Frequency Marker Softkeys

Sweep > Configure Step Sweep >
More > Markers

Y

FREQUEHCY

40.000 000 000 00 &z

ANPLITUDE

-20.00 den

Frequencu Start: L0O.0000000000GH=z
Frequency Stop @ LO.0000000000GH=

Step Points: 101

Marker Marker Frequency On/0ff Ref
0 0
1 L0. 00000000000 GHz OFF ==
2 L0, 00000000000 GHz OFF ===
3 L0, 00000000000 GHz OFF ===
L L0, 00000000000 GHz OFF ===
5 L0, 00000000000 GHz OFF ===
6 L0, 00000000000 GHz OFF ===
? 40. 00000000000 GHz OFF ==

Basic Operation
Configuring a Swept Output

For details on each key, use key help
as described on page 40.

Sets the frequency for the
marker number highlighted.
Harker Freg f——Up to 20 frequency markers
can be set.

Markers

Enables the selected
frequency marker.

Marker On/O0ff

Selects the highlighted marker
-¢—as the frequency reference
marker for the rest of the

Oelta Ref Set

Turn Off frequency markers.

Markers
If the Delta Ref Set softkey

has been pressed, this softkey
-t——-enables the Marker Delta
function and uses the Ref

fore 1 of 2 marker as the frequency
marker reference for the other
markers.
Harkers

Sets the center frequency of
Marker->Centar 44— the sweep to the value of the
Freg highlighted marker (row).

M1->Start Sets the start frequency of the
Mz-»5top M——sweep to the value of marker

1 (M1) and the stop frequency
to the value of marker 2 (M2).

Amplitude Markers
Off

Sets the marker’s amplitude
Marker Amplitude re—Vvalue displayed on the

2.00 dB instrument (Range: —10 dB to
10 dB).

At
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Basic Operation
Configuring a Swept Output

List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear

ascending, descending, or random order. List sweep also enables you to copy the current step sweep
values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file
catalog (page 65). Dwell time is editable at each point. For fastest switching speeds, use list sweep.

Figure 3-9 List Sweep Configuration Softkeys and Display

Sueep Hode For details on each key, use key help
as described on page 40.
v Off
SueeEZList 7 Freq
an
Sheep -
[k >
) amptd
Displays the selected on
ﬁ‘j Tupe | sweep type parameters
Step (see page 55) [P Available only on vector models,
an A and
SSiHS?g HeEeat only when Sweep Type = List.
A\M Available only when
page 49 waveform entry is selected
gronfioure, | -—‘ FREQUENCY ANPLITUDE Table
;—nm Tor3 6.000 000 000 00 &z | -144.00 wn |/
Sueep/list F . CH
) List Mode Ualues (no rroclulatlon)/
Lcigg\céﬁggg, A ¢ V] Frequency  Pouer Uaveform Duell
% 5. 00000000000 GHz|-135. 00| s STy 2.000 ms T B
Sweep Trigoer
(Free Run)® r
A Oelete Fou
Point Trigger
(Free Run)®
Goto Fowe
fore 1 of 2
Each line defines the Vector models only
corresponding point in \j
the sweep. For example, .
line 1 defines point 1. List Table 7
Load/Storem
Sweep Direction see page 55
bown MR L Preset. Liste
Trigoer Out ) h . .
Polarit The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell
Heg lﬁ time is the same at each point; List Sweep dwell time can be different at each point. Insert Item
Sueepuﬁ?t Dwell Time = the time that the signal is settled and you can make a measurement before the
— sweep moves to the next point. Delete Item
Eoint-to-Point ‘Timt.a = the sum of the value set for the dwell plus processing time, switching Duell Tupe
time, and settling time. Step
__fHore 2 of 2%
Foute Connectorss ~ page 48
__Hore 3 of 3%
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Example: Configuring a List Sweep Using Step Sweep Data

1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep
configured on page 49.
2. In the SWEEP menu, change the sweep type to list:
Press SWEEP > Sweep Type List Step to highlight List.
The display shows sweep list parameters, as shown below.
FREQUEHCY ANPLITUDE Sueep/List
6.000 000 000 00 sz | -144.00 cen Suen,
Speep Tupe
3 /List Status Information [ step
Sreep o OFfF Current Point : 0/1
SHeep Tupe :List Sweep Speed : Opts/sec ﬁhg?g %?.t
Manual Mode HE
SHeep Direction: Up
Sreep Repeat : Cont
Onell Points g i Sweep Triocger @ FreeRun
Ouell Tupe 1 List Foint Trigger @ FreeRun
Conf igure
Step SHesp?
[ Tore 1 of 3
Open the List Sweep menu: Press More > Configure List Sweep.
4. Clear any previously set values from the menu and load the points defined in the step sweep into
the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset.
The display updates with the values loaded from the step sweep, as shown.
FREQUEHCY ANPLITUDE Tist Table Vector Models:

6000 000 000 00 GHz —14400 dBnm Loadsstares]  Presetting the list clears

any previously selected

- Preset Lists waveforms.
(Lilz§t tlode Ualue? P lavef Duell
requency ouer avetrorm [1[=} : :
-— CH ¢na modulation) 500.000 ms Ineert Tt For information on
—- CH (no modulation) 500.000 ms MESG e selecting a list sweep
-— CH (no modulation) 500.000 ms
-- CH (no modulation) 500.000 ms waveform, see Example:
—— CH (no modulation) 500,000 ms Delete Ttem e :
— B fro modulation) E00.000 me Editing List Sweep
Points on page 56.
Waveforms are available ell Tupe
only on vector models. Step
NMore 2 of 2

Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the
SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

If not already on, turn the RF output on: Press RF On/Off.
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.
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Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 42.

1.

2
3.
4

Create the desired list sweep. This example uses the list sweep created in the previous example.
If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error.
Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight List.

In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.
Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row.
This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.
7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row
5, then press More > Insert Item.
This places a copy of the highlighted frequency value in row 6, shifting the original frequency
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the
power and dwell time entries do not shift down).
8. Change the still-active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5
is now the active parameter.
9. Insert a new power value (—2.5 dBm) for point 5, and shift down the original power values for
points 5 and 6 by one row: Press Insertltem > -25 > dBm.
10. To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.
11. For an analog instrument, go to step 14. For a vector instrument, continue with step 12.
12. Select a waveform for point 2:
a. Highlight the waveform entry for point 2 and press the More > Select Waveform.
The signal generator displays the available waveforms, as shown in the following example.
FREQUEHCY ANPLITUDE Arb laveforn
6.000 000 000 00 &z | -144.00 den | seiect yaveforn] Either select a waveform,
Display uaueFDr“m’
Select Seament On ) Sequence On And Markers or
(1/1) BBG Media Points Int Media Segs
RAMP_TEST_WFHM 200 A L Haveform
CINE_TEST LIFT ; Segments®
LW select no modulation.
WM (no modulat ion)
Manad o)

b. Highlight the desired waveform (in this example, SINE TEST) and press either the Select
hardkey or the Select Waveform softkey.
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13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The
following figure shows an example of how this might look.

FREQUEHCY ANPLITUDE List Table

6.000 000 000 00 &z | ~144.00 den Foit. Tten

The empty entry is equivalent to
choosing CW (no modulation).

List. Mode Ualues
(1 Frequency  Pouer Haveform Duell

500.00000000000 MHz| -20.00|-— CH (no modulation) 100,000 ms

1)

1

2(LL45. 00000000000 MHz| -16.00|WFM1:SIME_TEST_MFH 500.000 ms Insert Rou

3|540.00000000000 MHz| -12.00|-- CW (no modulation) 500.000

4|560.00000000000 MHz| -8.00|-- CW (no modulation) 500.00

5(590.00000000000 MHz| -2.50|WFM1:RAMP_TEST_HFM S00.A00 ms Delete Row

6|560.00000000000 MHz| -8.00|WFM1:RAMP_TEST_MFM

7|590.00000000000 MHz| -4%.00|-- CW (no modulation) & |S500.000 ms

8|E500.00000000000 MHz| +0.00 500.000 ms

) Goto Rou
NMore 1 of 2

14. Turn sweep on:
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15. If it is not already on, turn the RF output on:
Press RF On/Off.

The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping,
and the progress bar shows the progression of the sweep.

NOTE If the instrument is in manual sweep (page 58), the active row (row 6 in the figure above) is
the selected (manual) point, and the signal generator outputs the settings for that selection
when the RF output is on.

Example: Using a Single Sweep
1. Set up either a step sweep (page 49) or a list sweep (page 55).

2. In the List/Sweep menu, set the sweep repeat to single:
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to
be initiated.

If not already on, turn the RF output on: Press RF On/Off.
4. Initiate the sweep: Press Single Sweep.
A single repetition of the configured sweep is available at the RF Output connector.

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the
progress bar shows the progression of the sweep.

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.
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Example: Manual Control of Sweep

1. Set up either a step sweep (page 49) or a list sweep (page 55).

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.

3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.

4. If it is not already on, turn the RF output on: Press RF On/Off.

Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF output

changes to the settings in that selection.

The SWMAN annunciator
indicates that the sweep
is in manual mode.

The currently sweeping
parameter stops and
displays the selected point.

When you enter a manual point,
the progress bar moves to and
stops at the selected point.

FREQUEHI AAPLITUDE Su List
-— Conf igure
14400 dBn List Suesp®
SUNAN

Manual Point: 3
5 fList Status Information

Sweep Trigoer
(Free Run)®

The parameters of the selected sweep point (point 3
of 6 in this example) define the signal available at the
RF Output connector.

1 Freg

Sweep Tupe : Step LIM
Frequency Start : 500.00000000MHz
Frequency Stop @ B00.00000000MHz

Sreep
Sweep Speed
Manual Mode

Step Points HE o)

(Current Point @ 3/6 )
1 Opts/sec
: On

Point Trigger
(Free Run)®

Manual Mode |

0ff

When you turn manual mode on, the
current sweep point becomes the
manual point.

Manual Poin%

fore 2 of 3
T —

Modulating the Carrier Signal

To modulate the carrier signal, you must have both

e an active modulation format
and

¢ modulation of the RF output enabled

Example

1. Preset the signal generator.

2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating

that a modulation format is active.
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3. Enable modulation of the RF output: Press the Mod On/0ff key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not
modulate until you subsequently turn on a modulation format.

Annunciator indicates active AM modulation

ANPLITUDE

-144.00 den

A .
0ff Nl j«——AM modulation format on.

Al Tupe
L IH WS

Modulation Status Information

Hod State Depth/Dev Source Rate Uaveform AM Depth
An fMod OFf  0.1% Internal LO0. OHz Sine 0.1 %

AN Source
(Internal®

AM_FRate
L00.0  Hz . -
A lit LED indicates that any

active modulation format can
modulate the carrier.

NOTE To turn modulation off, press the Mod On/0ff key until the LED turns off.

When the Mod On/0ff key is off, the carrier signal is not modulated, even with an active
modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/0ff key until
the LED lights.

See also: “Using Analog Modulation (Option UNT Only)” on page 73
“Using Pulse Modulation (Option UNU or UNW)” on page 117
“I/Q Modulation” on page 183
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Simultaneous Modulation

NOTE The Agilent MXG is capable of simultaneous modulation. All modulation types (AM, FM, ¢M,
and Pulse) may be simultaneously enabled. But, there are some exceptions. Refer to
Table 3-1.

Table 3-1 Simultaneous Modulation Type Combinations

AM? FM oM Pulse®
AM -- X X X
FM X -- not applicable X
oM X not applicable -- X
Pulse X X X --

Linear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 4.
bPulse modulation requires Option UNU or UNW. Refer to Chapter 6.

Working with Files

* File Softkeys on page 61

* Viewing a List of Stored Files on page 62

e Storing a File on page 63

¢ Loading (Recalling) a Stored File on page 65

¢ Moving a File from One Media to Another on page 66
¢  Working with Instrument State Files on page 67

¢ Selecting the Default Storage Media on page 71

The signal generator recognizes several types of files, such as instrument state files, license files, and
list sweep files. Files can be stored either in the signal generator’s internal storage or on the USB
media. This section provides an overview of how to navigate the signal generator’s file menus, and
how to view, store, load, and move files.

See also: Storing, Loading, and Playing a Waveform Segment on page 130.
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File Softkeys
For details on each key, use key help as described on page 40.
File Note: Available file types depend on the installed options.
Display internal or USB Instrument operating parameters (see page 67).
files, depending on the Catalog Tupe
Catalog & i . .
selected storage media. ALl Sweep data from the List Mode Values table editor.
EatalDQ(FT‘ﬁ?' >
User flatness callibration corrections.
Einary
Delete Filew
State Catalog Tupe age 62
Copy File FFE: /p
Deletions require Catalog Tupes”] ) )
) confirmation. List Displays IQ Files
Fename File i tH?dul?tion'
atalog Tupes .
User Flatness Displays FSK
Delete ALL Filesk Files
Hore 1 of 2 > FIR \
More 1 of 2 Displays FIR
Files
-~
Catalo Default Storage - N
nutomatiﬁgélﬁ gse
edia
Coteluony If Present
n Default Path
Use Only page
Securitusf— page 266 Internal Storage Duirs“gcggrr:zegg
Use Onl (IE(REVINS (FEIE Available only with USB connected
USE File Manaoerw USSBHBE ig (i.e. Without external USB connected,
DeFault P / softkeys are greyed out).
Specifu Default
- T S w—
USE"if present.) 4 B Y
More 2 of 2 The signal generator does not

Shows the current directory

FREQUEHCY

\/

6.000 000 000 00 &z

ANPLITUDE

-144.00 den

e |

USBE Nedia

T
PERSISTEMT

RAMP_TEST_WFM
RAMP_TEST_WFM
RAMP_TEST_WFM

USB(Dlrectorg JUSER ) T
(Thls path is the default path)

E
STATE
STATE
LIST
USERFLAT

HWAVEFORMN

90.1MB Free

155 B
155 B
5.2L4kB

16 B
1.03kB
132 B
200 B
800 B

04/12/065 092
04/12/065 092
06/1L /05 1k

04/12/065 092
04/12/065 092
O4/12/065 09:

Recall
Instrument State

Copy File to
Instrument |

format USB media or change file
permissions. Use a computer to
perform these operations.

The display indicates when the current directory is the default storage path.
For information on setting the default storage path, see page 71.

This key changes, depending on
}—the selected file. See page 65.

page 66

Up Directory’|

Available only when the
current directory is not the
top level directory.

Ls Delete File or

06/14/05 14:LE Directory

06/1L /05 1h:

M

Requires
confirmation

28 Create Directory

flore 1 of 2
T

——page 66

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the
signal generator displays the message External Media Not Detected.
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ARB File Softkeys

Waveform files and their associated
marker and header information.

Arb [:atalo§ TQEB? Arb Catalog Tupe

- EBG Seoments

Stored
Seaments

Sequence

oo Note: Available file types depend on the installed options.

MOMOD

_ _fore 1 of 2 &

For details on each key, use key help as described on page 40.

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to
Auto, as described on page 71.

Viewing a List of Files Stored in the Signal Generator
1. If USB media is connected, disconnect it. The signal generator’s storage media switches to
internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press File > Catalog Type > desired catalog (in this example, All). The
selected files appear in alphabetical order by file name, as shown in the following figure.

FREQUEHCY ANPLITUDE Catalo

The selected file catalog and 6.000 000 000 00 GHz _144.00 dBm EatalDQ(FT‘ﬁ?’

the storage media

- - Oelete Filew
Catalog oF&nll Files in Int Storageg 30.5MB used  LEYME free
| File Hame — — — Tupe  Size  [MNodified |
1 . 5 5 Ok £ 10 J —————
2 12TOMNE_WFH SNLIFH 10752 (09/22/06 22:36 Opy F1le
3 1A SEQ 533 10/31/06
4y 200 STATE 201 11/02/06
5 BOGUS LIST 63 09/22/06 22:36 Rerame File
6 BOGUS NHKR £3 10/09/06 1h:Li
7 BOGUSII LIST £3 09/22/06 22:36
8  COMAZK_SCHAN_LFM SMULFH 1474752 09/22/06 22:36 )
9 COHAZK_PILOT_LFM SNLIFTH 1474752 09/22/06 22:36 Delete ALL Filesk
10 DISPLAY.BMP BINARY 76918 09/22/05 22:36
More 1 of 2
——

Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which can
display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:
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With the USB media connected, select the desired file catalog: press File > Catalog Type >
desired catalog. The selected files appear in alphabetical order by file name.

Using the USB File Manager:

Use the Page Up and Page Down  |[JG Directory: /USER 50.11B Free AoStyirent
(This path is the default path)

hardkeys to scroll through the

. File Hame Tupe Size Modified
contents of the directory. a0 - Up Directory
B O/ :

0_02 STATE 156 B 0O4/12/06 09:38
LAST LIST C.2LkB DOb/1L/05 1L:LE DBlEtE.FllE o
LAST USERFLAT 16 B 06/14/05 1L:LE HrEEEE
PERSISTENT STATE 1.03kB D5/1L/DE 1L:LE
RAMP_TEST_WFH HEADER 132 B 0L4/12/06 09:38 )
RAMP_TEST_HFH MARKERS 200 B Ou/12/06 09:38 Create Directory
RAMP_TEST_HFH WAVEFORM 800 B OL/12/05 039:38

With USB media connected, open the USB File Manager: press File > More > USB File Manager.
The instrument displays the default directory on the USB Media, as shown in the following figure.
Note that when you attach USB media, the display goes directly to this menu.

FREQUEHCY ANPLITUDE USBE Nedia

6.000 000 000 00 &z | -144.00 0 |, .ccerotl

Copy File to

flore 1 of 2
T

Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument
states, lists, and waveforms.

An instrument state file contains instrument settings. For this type of file, use the Save hardkey
shown in Figure 3-10 on page 67.

For other types of data, use the Load/Store softkey (shown below) that is available through the
menu used to create the file.
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Load/Storem

Load From
Selected File

Eile Type Save From

List Sweep menu
State Save menu
Waveform Mode menu

User Flatness ~ Amplitude menu
User Preset User Preset menu

Text Entry

Enter

Clear Text

diting Mode

Store To |
File

N

For details on each key, use key help as described on page 40.

\J

Feplace

Show Alpha Table
Off

Use this menu to enter the file name,
as described on page 41.

File Length (including extension)
Internal Media: 25 characters
USB Media: 39 characters
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There are several ways to load (recall) a stored file.

Basic Operation
Working with Files

¢ For an instrument state file, use the Recall hardkey shown in Figure 3-10 on page 67.

* For other types of data, use the Load/Store softkey (shown below) that is available through the

menu used to create the file.

Load From |
Selected File

Load/StoreqH—

Store To
FileM

N

Loading a File From USB Media

Confirm Load

Confirm Load
From File

R DU

Eile Type Recall From
List Sweep menu
State Save menu
Waveform Mode menu

User Flatness
User Preset

Amplitude menu
User Preset menu

To load a file from USB media, use the USB file manager shown below.

File > Catalog Type > <type> > More > USB File Manager
or

File > More > USB File Manager

or

Insert the USB media

File Type Extension
List list

State .state
Waveform .waveform
User Flatness .uflat

User Preset .uprst
License lic

Pressing Select with file highlighted...
loads list and starts sweep

load instrument state

loads and plays waveform

loads and applies user flatness

loads and executes user preset

installs purchased license

If the signal generator does not recognize the
file, you must select how the file is to be used.

USE Hedia ) .
Fecall This key changes, depending
| Instrument. State P on the selected file.

Copy File to
Instrument

Up Directory

Delete File or

Diractoru®

Create Directory

fore 1 of 2 3

| Copy & Select User Flatness
Copy & Play Waveform

Copy & Play Sequence

Enter Directory

Recall Instrument State

Load List

Install licenses

No action (USB disconnected)

Use As

For details on each key, use key help as described on page 40.

\J

Use File

Load Sweep List

Fecall State

Copy & Select
User Flatness
Corrections

Copy & Play
Havewform

Copy & Play
Sequence
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

File > Catalog Type > <type> > More > USB File Manager

or
File > More > USB File Manager
or Copy File As ~|
Insert the USB media Selecting a waveform or _
an unknown file type Skesp List
displays this softkey.
USE fedia /7| This key changes, Instrument State
depending on the selected
Recall™p—file. See page 65 Copy to
i User Flatness
Instrument. State ED%%SEI’{&%E EE' SO eSS
EBG Memor
Copy File to .} Whether a menu is available \ u
ISRV depends on the selected file. - / Lave Formey—
ED%SE{&%%E Internal Storage
Up Directory 1 Moves up one
directory level Sequence
Detetg File ol Requies confimatin phn
These softkeys only are
Create Directory available on the
N5162AY/82A with
fore 1 of 2 BBG.
Copy File As
Latalog Tupe,L  Catalog Type Menu
- page 61
— USBE Hedia -
Copy File Copy All Files
Internal Fiiscaise—#= EoRUSE
nternal Filelsim
to Copy to USB MniB=rEll, SO
Copy ALl Filese L B to

LS|
Internal Storage

Delete All Files i i i
in Current Dir"] Requires confirmation These softkeys / BBG Herrob
are only \ to Ush \
M\_— available on IR

the N5182A
with BBG. to BEG Memory

1 The N5162A is identical to an MXG with a front panel display, except that the front panel, hardkeys

and softkeys functionality are only available via SCPI commands or through the Web-Enabled MXG.

Refer to Programming Guide and SCPI Command Reference for information on Web-Enabled MXG

ATE.

For details on each key, use key help as described on page 40.
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Working with Instrument State Files

¢ Saving an Instrument State on page 68

e Saving a User Preset on page 68

¢ Recalling an Instrument State on page 68

¢ Recalling an Instrument State and Associated Waveform File on page 69
¢ Recalling an Instrument State and Associated List File on page 69

* Moving or Copying a Stored Instrument State on page 70

Figure 3-10 Save and Recall Softkeys

For details on each key, use key help

'Sa\re \ Recall as described on page 40.
L J [ "l
Save State 7 Saue Stale fecall State
SAVE .
Seql0l ReofO0] SEliEEs B3R 2R [
Select Reo: Delete All Select Seq: When saved to the signal generator, instrument settings
(auailable) 00 Feos in SeqlO1* 0 (states) save to instrument state memory. Instrument state
memory is divided into 10 sequences (0 through 9); each
Select Seq: Delete All Oelete i i
4 Elote Ally Seqr0l Rectabi™ sequence comprises 100 registers (00 through 99).
Delete softkeys in the Save and Recall menus enable you
Delete ALl L .
Reos in SeqfdIM to delete the contents of a specific register, or the contents
\M“NMM of all sequences in the state file catalog.
Delete ALl
Sequences® . ) ) .
The signal generator requires that you confirm a deletion.
Hore 1 of 2 % Hore 1 of 2 %

The following information is not stored in a state file:

System Security Level List Mode Freq Hostname Remote Language FM Deviation

System Security Level Display List Mode Power IP Address FTP Server PM Deviation

System Security Level State List Mode Dwell Subnet Mask Manual DHCP MAC

Web Server (HTTP) List Mode Sequence Default Gateway  VXI-11 SCPI User Power Correction
Sockets SCPI (TELNET) Display State On/Off  ARB Files List Files 1/Q Calibration Data
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Saving an Instrument State
1. Preset the signal generator and set the following:

* Frequency: 800 MHz + Amplitude: 0 dBm ¢ RF: on
2. (Optional, vector models only) Associate a waveform file with these settings:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first
move it from internal or external media to BBG media, see page 130.

Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.
4. Select the desired register (in this example, 01): Press SelectReg > 1 > Save Reg.

If a waveform is currently selected, saving the instrument state also saves a pointer to the
waveform file name.

5. Add a descriptive comment to sequence 1 register 01:

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in
the Saved States list when you press Recall. If the instrument state has an associated waveform,
entering the waveform name in the comment makes it easy to identify which instrument state
applies to which waveform.

Saving a User Preset

A user preset is a special type of instrument state file.
1. Preset the signal generator and set as desired.

2. Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as containing
user preset information.

You can set up several preset conditions under different names:

1. After you save a user preset, rename it to something other than USER_PRESET (see page 70).
2. Save as many user presets as you wish, renaming the USER_PRESET file each time.

3. Give the desired file the name USER_PRESET.

Recalling an Instrument State
1. Preset the signal generator.

2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored in the
registers in that sequence; RECALL Reg is the active entry.

3. Select the desired instrument state:

If the desired state is listed in the currently selected sequence, press desired number > Enter.
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.
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Recalling an Instrument State and Associated Waveform File
1. Ensure that the desired waveform file exists, and that it is in BBG media (page 130).

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform name. It
does not recreate the waveform file if it was deleted, or load the file into BBG media if it is in
internal or USB media.

Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.
The name is displayed as the selected waveform.

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency
and/or amplitude values. Because you must load the list file from the file catalog, when you store a
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).
2. Load the desired list file:
a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. This
is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].
4. Press Re-SAVE Seq[n] Reg[nn].

This overwrites previously saved instrument state settings with the new comment.
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Moving or Copying a Stored Instrument State

Figure 3-11 Instrument State File Catalog

[Fue
—

l Sequence Register

FREQUEHCY ANPLITUDE Catalo

6.000 000 000 00 s#z | -144.00 den Catalog, Tupe,

Delete Files

tate Files in Int Storage ES.1MB used  L3EME free
Hame Tupe i dified
11/ b8 X
2 002 STATE 11/07/06 16:33 Copy File
3 PERSISTENT STATE 11707 /06 12:23
L USER_PRESET STATE 11/07 /06 16:36
9 USER_PRESETZ STATE 213 11/07/06 16:L0 Fername File
Delete ALl

State Files™

More 1 of 2 \

The signal generator recognizes only the file named USER_PRESET as user preset information (page 68).

A user-created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same
name as an existing file. If you rename a state file to something other than a valid sequence/register
name, the file does not appear in either the Save or Recall menu.
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Selecting the Default Storage Media

Basic Operation
Working with Files

You can configure the signal generator to store user files to either the internal storage or to external
USB media. To automatically switch between USB media and internal storage, depending on whether
USB media is attached, select Automatically Use USB Media If Present. To avoid storing any confidential

information in the instrument, select Use Only USB Media. To avoid storing any confidential information
to USB media, select Use Only Internal Storage.

This selection is unaffected by power—cycle or preset.

File > More >

Current
selection

Catalo

Goto Fowe

Securitus

USE File Managerw

Internal/USBE
Storage SelectionM
—(USE if present)

— - Default Storage
Automatically Use

flore 2 of 2

In the front panel alsp|ay
error queue, error
messages display on an
enumerated (“1 of N”)

basis.

USB Hedia |
If Present

This is the recommended selection. When USB media is attached to the
front panel, it is the selected media; when USB media is not attached,
internal storage is used.

Use Only
Internal Storage

____ Memory in the instrument is used, and USB media is ignored.

Use Only
USE Media |

\Media attached to the front panel USB connector is used, and no user

data is stored to internal storage.

Specifu Default
Storage Path form
USE Media

. Select the directory on the USB media to be used for all file operations
when USB media is attached and enabled.

For details on each key, use key help as described on page 40.
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Reading Error Messages

If an error condition occurs, the signal generator reports it to both the front panel display error
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed
separately; for information on the SCPI error queue, refer to the Programming Guide.

Characteristic Front Panel Display Error Queue
Capacity (#errors) 30
Overflow Handling Drops the oldest error as each new error comes in.
Viewing Entries Press: Error > View Next (or Previous) Error Page
Clearing the Queue Press: Error > Clear Error Queue(s)
Unresolved Errors? Re-reported after queue is cleared.
When the queue is empty (every error in the queue has been read, or the queue is cleared), the
No Errors following message appears in the queue:
No Error Message(s) in Queue 0of O

3Errors that must be resolved. For example, unlock.

Error Message Format Error Description
Error Number Error Message (May be truncated on the display)
—222 Data out of range; value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal
source frequency that is beyond the specific limits

_,_//

_

Explanation is provided in the Error Message file (see page 277)
(This is not displayed on the instrument)

The annunciator indicates an unviewed message.

new indicates a message generated
since messages were last viewed.

Hodulation Status Information Error
Hod State Depth/Dev Source Rate Havefo| |
Fn On 1. 0000KHz Internal 400, OHz Sine ‘ Message number and longer description
FREQUEHCY AMPLITUDE [ _Error Info /|
2.000 000 000 00 &z | -144.00 e | vy e
[ A1) [ERH]
Vied Mext
Error Queue .4 Y Error Page
= = 221, Sett flict; Enabled modulat, Flict: C )
EBROR: -221. Settings conflict Sunﬁrgméﬂgfﬁﬂanigu TRAULaELon SHURCA. PRBvLAs MRGUlStion 1 of 1
sabled.

Clear
Error Queue(s)

Error messages appear in the lower-left corner
of the display as they occur.

fee= PROTO CODE == NOT FOR CUSTOMER [SE e O /DR /2006_T0:12
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4 Using Analog Modulation (Option UNT Only)

NOTE
installed.

The Mod On/Off hardkey and LED functionality are only valid for MXGs with Option UNT

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Chapter 3, “Basic Operation,” on page 39 and familiarize yourself with the information in that

chapter.
e The Basic Procedure on page 74

¢ Using an External Modulation Source on page 75

* Removing a DC Offset on page 75
Figure 4-1 Analog Modulation Softkeys

N
AM ﬁ FMI“—'
. oM Y

[Tl | Fi/oH
AN @
on
A Tupe N
[RYW E-F an

Fr Dew
] (S 1.0000 KAz

FM Source
S geurssmt—paoe 75 s
FM_Rate
hDSTDHaﬁg Loo0.0 Hz
Hore 1 of 2 __fore 1 of 2 —l
\J
i} [FiF]
A Hode
Mormal OCFM/OCHM Cal
\w

For details on each key, use key help
as described on see page 40.

I 57 T

Fri_ I
High BH

iyl
on

@M Dev
0.000 rad

M Source
tInternal)*f——Page 75

M _Rate
Loo.0 Hz

__fore 1 of 2 §—l

Fli700

DCFM/DC@N Cal

\w
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The Basic Procedure

The Basic Procedure

1. Preset the signal generator.

2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4

Configure the modulation:

AM

FM

OM

a. Press AM

b. Set the AM type (Linear or Exponential):

AMType to highlight desired type.
c. Set the AM Mode (Normal or Deep).

Default is Deep. To select Normal enable

More to highlight desired type.
d. Set the AM Depth:
Default 0.01%

Range 0.01 to 100%

e. Set the rate:
AM Rate > value > frequency unit

5. Turn on the modulation:

AM

AM Depth > value

a. Press FM/®M

b. Set the deviation:
FM Dev > value > frequency unit

c. Set the rate:
FM Rate > value > frequency unit

FM

a. Press FM/®M > FM ©®M
b. Set the BW (normal or high):

FM ®M to highlight desired type

c. Set the deviation:

®OM Dev > value > pirad

d. Set the rate:

©®M Rate > value > frequency unit

OM

AM Off On softkey to On

FM Off On softkey to On

OM 0ff On softkey to On

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”

on page 272.

See also “Modulating the Carrier Signal” on page 58.
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Using Analog Modulation (Option UNT Only)
Using an External Modulation Source

Using an External Modulation Source

Currently selected modulation.

Default
Source ; i
tInternal” Internal Select to use external modulation
Ext
Rear panel inputs are
described on page 15
AM input FM or ®M input

R;‘?#T o SWEER OUT LU M PULSE A TRIG IN TRIGOUT REF IW 10MHz QUT O
D@D
GRIA
I KN )= (

@] (OO = OSSO0 2 0 @:D:D@@Cﬁ

Removing a DC Offset

To eliminate an offset in an externally applied FM or ®M signal, perform a DCFM or DC®M
Calibration.

NOTE You can perform this calibration for internally generated signals, but DC offset is not usually
a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.
2. Press FM/®M > More > DCFM/DC®M Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal,
and the applied DC level becomes the new zero reference point. When you disconnect the DC signal,
perform the calibration again to reset the carrier to the correct zero reference.
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Using an External Modulation Source
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B Optimizing Performance

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 39 and familiarize yourself with the information in that
chapter.

e Using the Dual Power Meter Display on page 78

* Using Flatness Correction on page 86

¢ Using External Leveling (N5183A Only) on page 95

e Using Unleveled Operating Modes on page 103

* Using an Output Offset, Reference, or Multiplier on page 104
* Using Free Run, Step Dwell, and Timer Trigger on page 108
e Using LXI on page 110

* Using a USB Keyboard on page 116
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Using the Dual Power Meter Display

The dual power meter display can be used to display the current frequency and power of either one
or two power sensors. The display outputs the current frequency and power measured by the power
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 5-2,
Figure 5-2, and Figure 5-3.

NOTE The dual power meter display feature is only available on instruments with serial prefixes
>US/MY/SG4818.

To use two U2000 USB Series power sensors with the MXG, a USB hub (with power supply),
can be connected to the MXG’s front panel USB connector.

Figure 5-1 Dual Power Meter Display with Power Sensors A and B Calibrated

Once turned on, the

| Nouer Meter /7
—__power meter

Channel A readings are always
aff visible, even if
another instrument
feature is selected
(i.e. Sweep, AM,
etc.).

ChA:—66.L4E dEm
ChE:-45.31 dBm

40.000 000 000 00 &Hz

Chanoel Ay
Setup

[Palier Meter Measurements

ChA cusB: nuL7u001L3) ChB ¢stk: 1u1.121.92.700 \ Epnal B

This area is the main

PR .
~61.40 dBm -4864dBn  LL = St
easured.

50.000 MHz

0 MHz

For details on each key, use key help as described on see page 40.
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Figure 5-2 Dual Power Meter Display Menu

Auxzillary

Fouer Meter

Measurements’|

/\ M

FREQUEHCY

40.000 000 000 00 &z

RF_OFF

Pouer Heter

Pouer Heter Measurements

Chanoel Ay
Setup

TR On

Channel B |——

Channel B J=—
Setup

Optimizing Performance
Using the Dual Power Meter Display

Enables the power sensor on
channel A.

See
page 80

Enables the power sensor on
channel B.

Channel B is configured similarly to
channel A. See page 80

For details on each key, use key help
as described on see page 40.
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Figure 5-3 Configuring the Power Sensor Channels

AUX Fctn > Power Meter
Measurements

Note: This figure illustrates channel A, but channel B is similar.

Pouer Heter Channel A Setup - ChA_Connection
Chanmel A Connect ion,| Connect ion Tupe -
aon Settings (USEDY > Coni Enables the power meter
connection type: Sockets
Channel A Channel USE Dewvice Sockets LAN, VXI-11 LAN, or USB.
L i Ls o (USB POLER SEMSORM
SEEVp EEE e FvL7L00143) _
Note: The VXI-11 softkey is
Charnel B WHI-11 used to communicate
on remotely with a power meter
that has a GPIB connector
UsSE via LAN-GPIB gateway.
Ehangg%ugb / Zero SBHQ This softkey is active when /
there are one or more USB
N power sensors connected. - -,
e Calibrate Sensor P,
USB U2000A Series Power

Sensors do not require the
sensor to be calibrated.

The MXG uses the USB
U2000A Series Power
Sensor’s “Internal” zero.
Refer to the USB U2000A
Series Power Sensor’s
documentation.

Zero Sensor and
Calibrate Sensor softkeys
are inactive during a
measurement.

Y

ChA Settings ~#

External Power
Meter Channel
ElE

Selects the channel on the
external power meter that the
— power sensor is connected to.

Channel Freg
50. 00000000MHz

. Selects the frequency that
channel A has been calibrated to.

Channel Offset
0.000 d&

___Enables a power offset in dB for
the current channel.

Averaoing,
(AULO)

. Enables averaging. Instrument
default is Auto with 1024 points.

Measurement.
Units
| cbm I

Sockets LAN: Sets the
IP port to 5025 (standard)

ChA Connection

Connection Tupe]

or 5023 (telnet)
programming.

(Sockets)
Sets the power meter’s IP

ddress or LAN-GPIB

P%HBEUE?ESE gateway'’s IP address (Sockets Fouer Meter
LAN and VXI-11 LAN only). IF Port

Whether a softkey is available

./ depends on the selected
. Fr WHI-11
Connection Type. Device Mame
s ,/“* i opibd,13
L,

For details on each key, use key help as
described on see page 40.

VXI-11 LAN: Opens a
menu for entering a
device name for the
power meter being used.
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Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A
P-Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and
calibrated, as required.

On the MXG:
1. Setup MXG for Step Sweep. “Configuring a Swept Output” on page 46.

CAUTION Verify RF Output power is off before continuing.

2. Connecting the Channel A power sensor: Connect USB sensor to MXG. The MXG should display a
message across the bottom that reads similar to:
USB TMC488 device (USB POWER SENSOR,MY47400143) connected

Figure 5-4 MXG Displays Connection to U2000 USB Power Sensor
FREQUEHCY

6.000 000 000 00 &z

‘USB THCL88 device (USB POUER SEHSOR.NYL7L00143) connected | —>

3. Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > Connection Type >
USB Device (None) > USB POWER SENSOR (MY47400143)

4. Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a
different serial number is connected to the MXG (refer to Figure 5-5). After the U2000 has been
recognized by the MXG, the U2000 power sensor is saved as a softkey in the instrument and the
dialog box in Figure 5-5 won’t be displayed (press DONE, if you see this message).

Figure 5-5 Diagnostic Dialog Box for USB Sensor

| Dimgnostic Dialog
i

Verifu That the sensor is connected to the Power Meter
Reference or the MXG RF Out

A Running Calibration(s) bar is displayed on the MXG. Refer to Figure 5-6 on page 82.
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Figure 5-6 Running Calibration(s) Bar (Zeroing Sensor)

FREQUEHCY

40.000 000 000 00 &z

RF_OFF

Pouer Heter Measurements

Running Calibration¢s)
S0% complete

| )
For details on
each key, use key
help as described
b on see page 40.
e
NOTE The U2000 Series USB Power Sensor, does not require a 50 MHz calibration. If a

calibration is attempted with the U2000 Series Power Sensors, the MXG displays a
message reading:

The U2000 series power sensor does not require a 50 MHz calibration. Refer to
Figure 5-7 on page 82.

Figure 5-7 Diagnostic Dialog Box Displayed for U2000 Power Sensor

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

The U2000 series power sensor does not require a 50 MHz oK
calibration

For details on

each key, use key

| help as described
on see page 40.

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the
instrument's display and in the upper right portion of the display under Power Meter. Refer to
Figure 5-8.
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Figure 5-8 Channel A Power Sensor Displayed on MXG

[RE_OFF_|/POYER NETER | Payer leter .~
40.000 000 000 00 &Hz oot gl ) et )

Chanoel Ay
Setup

Pouer Heter Measurements

Channel B

A cusB: nMyL7LODIL3) on

-69.81 dBm

50.000 MHz
help as described

— — on see page 40.

6. On the N1912A P-Series Power Meter (Channel B power sensor): Connect the N1912A P-Series
Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

Channel B,
Setup

For details on

NOTE It is recommended, but not required to use the channel B on the N1912A. This provides
continuity with the MXG’s dual display. For this example, the U2004A has already used

up the channel A position on the MXG.

8. Connect the power sensor input to the 50 MHz reference of the power meter.
9. Press Channel B Setup
10. Press Connection Settings > Sockets

11. Press IP Address > IP address > Enter

NOTE The IP address of the power meter should be displayed in the ChB section of the display.

Figure 5-9 Channel B Power Sensor with IP Address Entered

FREQUEHCY RF_OFF |/POUER NETER

40.000 000 000 00 &Hz

ChA:—67.01 dEm Chanmel A

0ff iGN

Chanoel Ay
Setup

Pouer Heter Measurements

ChA cuse: nyu7u00113) (\_) R O
Channel B,

~67.01 dBm ol .

50.000 MHz

each key, use key
I help as described
on see page 40.

12. Press Return > Channel Settings > External Power Meter Channel to B
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13. On the MXG: Press Channel B to On and then back to Off again. This initializes the MXG to the
external power meter.

14. Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 5-10 on page 84).

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 5-10 Diagnostic Dialog Box for Channel B

FREQUEHCY RF_OFF |/POUER NETER

40.000 000 000 00 &Hz ENA: -60.80 dEm
: Dimgnostic Dialog
Pouer —

[: Werifu That the sensor is conmected to the Power Meter N

Reference or the MXG RF Out

For details on
each key, use key
50.000 MHz help as described
on see page 40.

15. Press Done
The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait....
16. After Running Calibration(s) bar disappears: Press Calibrate Sensor
Diagnostic Dialog box is displayed that prompts for verifying the connection of the power sensor

to the power meter 50 MHz reference (refer to Figure 5-11 on page 84).

Figure 5-11 Diagnostic Dialog Box for Calibration

RF_OFF

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

Verifu That the sensor is connected to the Power Meter DOME
Reference or the MXG RF Out

For details on
each key, use key

T help as described

T —_— on see page 40.

84 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Optimizing Performance
Using the Dual Power Meter Display

17. Press Done

Calibration progress bar is displayed. Refer to Figure 5-12 on page 85.

Figure 5-12 Running Calibration(s) Bar (Calibrating Sensor)

"**%0.000 000 000 00 sz | - 20.00 w1 (.

Pouer Heter Measurements

Running Calibration¢s)
S0% complete
I

For details on
each key, use key
help as described
on see page 40.

18. Press Return > Channel B to On

19. The current power meter sensor reading should be displayed on the MXG in the ChB portion of
the display and in the upper right corner of the display under Power Meter and to the left of the
Power Meter power sensor reading.

Figure 5-13 Channel B Power Sensor Displayed on MXG

FREQUEHCY

40.000 000 000 00 &Hz

RF_OFF |/POUER NETER

| _Pouer Neter .~
Channel &
P aOff

b=l P
ChE:-43.31 dEm

Chanoel Ay
Setup

Pouer Heter Measurements T~

/ -
ChA cusB: nyu7u001L3) ChB ¢stk: 1u1.121.92.70) (_ Epnal B >

Channel B,
etup

-61.40 dBm -48.64 dBm S| ——

each key, use key
help as described
on see page 40.

50.000 MHz 50T H=

20. The power sensors are now ready to be connected in a measurement setup.
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Using Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in cables,
switches, or other devices. Using an Agilent N1911A/12A, E4419A/B, or U2000 Series power
meter/sensor to calibrate the measurement system, a table of power level corrections can
automatically be created for frequencies where power level variations or losses occur. Supported
connection types to the power meter/sensor are Sockets LAN, VXI-11 LAN, USB, and GPIB via
VXI-11 LAN using a LAN-GPIB gateway (e.g. Eb810A Gateway or equivalent).

NOTE A power meter with GPIB requires using the Connection Type VXI-11 softkey, as well as a
LAN-GPIB gateway, to control a power meter. Refer to the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009), Agilent MXG’s FAQs “How do I connect to
the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.

If you do not have an Agilent N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may
save individual user flatness correction tables to the signal generator’s memory catalog and recall
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal
generator’s RF output (see page 90).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on page 94
to recall a user flatness file from the memory catalog and apply it to the signal generator’s RF
output.
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Figure 5-14 User Flatness Correction Softkeys
For details on each key, use key help

E as described on see page 40.
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Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array
contains ten frequency correction pairs (amplitude correction values for each specified frequency),
from 500 MHz to 1 GHz.

An Agilent N1911A/12A or E4419A/B power meter and E4413A power sensor are used to measure
the RF output amplitude at the specified correction frequencies and transfer the results to the signal
generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter and E4413A
power sensor.) The signal generator reads the power level data from the power meter, calculates the
correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a LAN,
GPIB, or USB interface, you can enter correction values manually.

NOTE On the N5183A, if the setup is using an external leveling configuration, the equipment setup
in “Required Equipment” on page 88 assumes that the steps necessary to correctly level the
RF output have been followed. If you have questions about external leveling, refer to “Using
External Leveling (N5183A Only)” on page 95.

Required Equipment

e Agilent N1911A/12A or E4419A/B power meter (a power meter is not required with the
U2000A/01A/02A/04A Power Sensor)

¢ Agilent E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor
* GPIB, LAN, or USB interface cables, as required

¢ adapters and cables, as required

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 89.

NOTE During the process of creating the user flatness correction array, the power meter is
remotely controlled by the signal generator.

88 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Connect the Equipment
e Agilent N1911A/12A or E4419A/B power .

meter?
e Agilent U2000A/01A/02A/04A power *
Sensor?
E5810A
LAN/GPIB Gat
Signal
Generator

RF Output

Input Port
USB port for connecting _
USB-compatible power " Cables ™
meters/sensors (e.g.
N1911A/12A Power Meters aggvci)ézgr )
and U2000A Series USB ~
Power Sensors). T
Flatness
Corrected
Output

Power Sensor

- — — A =

Device Under Test

Out In
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LAN, GPIB, or USB interface
cables, as required
adapters and cables, as required

The LAN, GPIB*, and USB connections are
for convenience. If your power meter does
not have LAN, GPIB, or USB, then manually
enter corrections as described in the
correction entry step in this section.

*GPIB control of a power meter requires a
LAN-GPIB gateway and use of the connection type
VXI-11. Refer to the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009),
Agilent MXG's FAQs “How do | connect to the
LAN?", and to the E5810A User's Guide or
equivalent LAN/GPIB gateway device.

Power Meter
(if applicable)

Note: Agilent U2000 Series
USB Power Sensors connect
directly to the signal generator’s
front panel USB port (i.e. the
power meter is not applicable).

For operating information, refer to the power meter/sensor documentation.
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Figure 5-15 Configure Power Meter Menu Softkeys

AMPTD > More > User
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Meter
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Connection Tupe #
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IP Address
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ddress or LAN-GPIB
/gateway’s IP address (Sockets
LAN and VXI-11 LAN only).

Enables the power meter
connection type: Sockets
LAN, VXI-11 LAN, or USB.

Note: The VXI-11 softkey is
used to communicate
remotely with a power meter
that has a GPIB connector
via LAN-GPIB gateway.

Sockets LAN: Sets the
IP port to 5025 (standard)
or 5023 (telnet)
programming.

Fouer Meter
IF Port
5025

> Whether a softkey is available
depends on the selected

Zero Sensor

Connection Type.

Calibrate Sensor

USB U2000A Series Power
Meters do not require the
sensor to be calibrated.

Basic Procedure

1. Create a user flatness array.

a.
b.
c. Configure the
d.

Configure the

power meter/sensor

Connect the equipment

signal generator

PH WRI-11
Device Name
opib0,13

VXI-11 LAN: Opens a
menu for entering a
device name for the
power meter being used.

Enter the user flatness correction values

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.
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Configure the U2000A/01A/02A/04A Power Sensor

1.

Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect the
Equipment” on page 89.

2. Zero the power sensor using the signal generator softkeys.

CAUTION Verify the signal generator RF Output power is set to the desired amplitude before
performing the power meter zero. No RF Output amplitude check is done by the signal
generator during zero.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power

sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor,
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware
has turned off the RF Output’s power.

For operating information on your particular power sensor, refer to its operation guide.

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal
generator or the front panel of the power meter.
Enter the power sensor calibration factors into the power meter as required.

4. Enable the power meter’s cal factor array.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power

sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor,
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware
has turned off the RF Output’s power.

For operating information on your particular power meter/sensor, refer to its operating
guide.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1.

Configure the signal generator:

a. P

reset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

i

ii.

Press AMPTD > More > User Flatness > Configure Power Meter > Connection Type > connection
type.

If connection type is USB:
1. Zero Sensor

2. Go to step c.
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iii.

else

If Sockets LAN or VXI-11 LAN: Press Power Meter IP Address > power meter’s or LAN- GPIB
gateway IP address > Enter.

If Sockets LAN: Press Power Meter IP Port > IP port > Enter.
else
If VXI-11: Press PM VXI-11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the
power meter’s documentation. Typically, this is “inst0” and is case sensitive for some
power meters. Refer to your power meter’s documentation, the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009), and Agilent MXG’s FAQs “How do I
connect to the LAN?”

When connecting via a LAN-GPIB gateway, enter the SICL address of the power meter.
Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the
gateway and “13” is the GPIB address of the power meter. Refer to the Agilent
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094-90009), Agilent MXG’s FAQs
“How do I connect to the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB
gateway device.

Open the User Flatness table editor and preset the cal array:
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

In the Step Array menu, enter the desired flatness-corrected start and stop frequencies, and
the number of points:

Press More > Configure Step Array >

Freq Start > 500 > MHz >
Freq Stop > 1 > GHz >
# of Points > 10 > Enter

Populate the user flatness correction array with the step array configured in the previous
step:

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

Set the output amplitude to 0 dBm.

Turn on the RF output.
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2. Connect the power meter to the RF output and enter the correction values:

With a Power Meter Over LAN, GPIB, or USB

i. Create the correction values:
Press More > User Flatness > Do Cal.

The signal generator begins the user
flatness calibration, and displays a progress bar.

The amplitude correction values load
automatically into the
user flatness correction array.

ii. View the stored amplitude correction values:
Press Configure Cal Array.

The user flatness correction array title displays User Flatness:

ii.

iii.

iv.

Vi.

Manually

Open the User Flatness table editor and highlight
the frequency value in row 1:
Press More > User Flatness > Configure Cal Array.

The RF output changes to the frequency value of
the table row containing the cursor.

Note the value measured by the power meter.

Change the sign on the delta value (e.g. the delta
value of the 0 dBm reference value (step f), and the
measured value from i is -.34, change the value to
+.34).

Highlight the correction value in row 1.

Press
Select > enter the delta calculated in step iii > dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output amplitude
based on the correction value entered.

Repeat steps ii — v until the power meter reads 0 dBm.

vii. Highlight the frequency value in the next row.

viii.Repeat steps ii through vii for the remaining rows.

(UNSTORED), without a name,

indicating that the current user flatness correction array data has not been saved to the file

catalog.

Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any
user flatness correction files saved to the catalog can be recalled, loaded into the correction array,
and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

¢ Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the

array is applied to the RF output.
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Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction
Values on page 91.

1. Preset the signal generator.
2. Recall the desired User Flatness Correction file:
a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.
b. Press More > Load/Store.
Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using External Leveling (N5183A Only)

While operating in external leveling mode, if either the RF or the DC connection between
the signal generator and the detector is broken, maximum signal generator power can
occur. This maximum power may overstress a power-sensitive device under test.

Amplitude &

Atten/ALC,,

Atten Hold sets to On and grays out (inactive) with Ext Detector
selection. When re-selecting Internal, the softkey becomes

Control

ALC
Off

Leveling,|
Control

flore 1 of 2

Y

Amplitude V'

Amptd Ref Set
0.00 dem

ﬂﬁtd EEF

Amptd Offset
0.00 de

/

Wﬁ'ﬁ

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so

Amptd

Offset
16.00 dB

[ ALC Control 7| /
active, but attenuator hold remains on. If desired, manually set it
to off.

Option 1E1 feature—With the Ext Detector selection, Set Atten
> / has no effect on the output power level. During external detector
Sk e use, use the attenuator to keep the ALC power level at
approximately 0 dBm when using negative dBm power levels.
Set. ALC Level See page 98.
0.00 dEm
Leveling Hode #
Internal
Leveling v
: Ext Detector
Leveling Mod
Hintermaly " f ™
Ext. Leveling W

"~ This softkey works with only the Ext Detector selection. It uses
16 dB as its zero reference point.

These settings do not change the output power amplitude of the

MXG, they only let you modify the front panel display amplitude
value so it closely approximates the power level measured at the

output of the coupler/splitter. See page page 102.

that it accounts for most of the power uncertainties inherent to the cabling and components in a test

setup. Refer to Figure 5-16.
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Figure 5-16 ALC Circuity

Signal Generator

Opt 1E1 Output

Attenuator Leveled Output
ALC Modulator (see page 98).
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_ | OUTPUT Component O'I(ELI
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§ [] External Detector

: (Negative output)
ALC Cabling

- \ *— Internal Detector
Driver

ALC INPUT

The external detector outputs a negative voltage to the signal generator’s rear-panel ALC INPUT
connector based on the power level at the detector. As the RF power level at the coupler’s/power
splitter input changes, the external detector returns a compensating negative voltage. The ALC circuit
uses this negative voltage to level the RF output power by raising and lowering the signal’s power,
thus ensuring a constant power level at the point of detection (external detector). Since the point of
detection does not occur at the output of the device to which the detector is connected, there is
some power loss that is not compensated for by the external detector. For example on a coupler, the
coupled port siphons some of the signal’s energy to drive the external detector. In addition the
coupler experiences some insertion loss between the coupled port and the output.

Figure 5-18 on page 98 shows the input power versus output voltage characteristics for typical
Agilent Technologies diode detectors. Using this chart, you can determine the leveled power at the
diode detector input by measuring the external detector output voltage. For a coupler, you must then
add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values shown
in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that the
detector, coupler/power splitter are specified for the power and frequency range of interest. To
determine the signal generator’s actual power range during external leveling, see “Determining the
Signal Generator’s Amplitude Range” on page 100.

With external leveling, the displayed amplitude value can vary significantly from the actual output
power of the coupler/power splitter to which the external detector is connected (see Figure 5-17).
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display
an accurate amplitude value. Also components between the signal generator and the external detector
can affect the output power of the coupler/power splitter. You can compensate for this power display
difference by using the

Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two softkeys is
that the ExtLeveling Amptd Offset functions only while external leveling is active. For more information
on using the external leveling offset feature, see “Adjusting the Signal Generator Display’s Amplitude
Value” on page 102.

96 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Optimizing Performance
Using External Leveling (N5183A Only)

Figure 5-17 Power Value Differences with External Leveling
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Figure 5-18 Typical Diode Detector Response at 25° C
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Option 1E1 Output Attenuator Behavior and Use

When using the internal detector, the Option 1E1 output attenuator enables signal generator power
levels down to —135 dBm at the RF Output connector. It accomplishes this by adding attenuation to
the output signal after the ALC detection circuit. The output power value (shown in the Amplitude
area of the display) is the resultant of the Set Atten and Set ALC Level values (see page 95). With the
external detector selected, the output attenuator no longer attenuates the output signal since the
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feedback for the detection circuit has been moved beyond the output attenuator. Because the
attenuator no longer affects the amplitude of the output signal, the output amplitude is determined
by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet).
As stated earlier, the actual output power may vary due to the external detector and the
coupler/power splitter performance characteristics.

NOTE When the internal detector (Internal selection) is reselected, the signal generator does not
turn the attenuator hold off.

Even though the output attenuator no longer affects the output power, it is still useful to drive the
ALC circuit to its mid- power point of approximately 0 dBm, which is optimal for the internal leveling
circuitry and typically provides the best amplitude flatness results. This is useful with negative power
values of -5 dBm or less. For example, to drive the ALC to approximately mid-power with a —20
dBm power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (20 + 25).

NOTE If there is too much attenuation, it will drive the ALC circuit too high and cause the signal
generator to go unleveled. Ensure that you decrease the attenuation as you increase the
power level.

Configure External Leveling

Basic Setup Process
¢ If working with a single frequency signal, perform Steps 1 through 5.

e If working with multiple frequencies:
a. Perform Steps 1 through 4.
b. Perform a user flatness correction, see “Using Flatness Correction” on page 86.
¢ If working with a sweep:
a. Perform Steps 1 through 4.
b. Setup the sweep, see “Configuring a Swept Output” on page 46.
Setup the equipment, see “Equipment Setup” on page 99
Configure the carrier signal, see “Configuring the Carrier” on page 100

Select external leveling, see “Selecting External Leveling” on page 100.

L

Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude Range”
on page 100

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude Value” on
page 102
Equipment Setup

Set up the equipment as shown in Figure 5-19 on page 100. Place the external detector (detector and
coupler/power splitter) as close as possible to the DUT.
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Recommended Equipment
e Agilent 8474E negative detector
e Agilent 87301D directional coupler

e cables and adapters, as required

Figure 5-19 Typical External Leveling Setup using a Directional Coupler

Negative Detector

ALC INPUT q b
= o
l ooOSooOOac0 O .
BERAAERAAEERS RF OUTPUT Leveled Signal
. = ™
Signal Generator Amplifier Coupler

Configuring the Carrier
1. Press Preset.

2. Set the carrier frequency.
3. Set the power level to 0 dBm:

o If the signal generator has no output attenuator (no Option 1E1) or it has Options 1E1 and
532 or 540 installed:

Press AMPTD > 0 > dBm.
* If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:
a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.
b. Press SetAtten > 0 > dB.
c. Press SetALC Level > 0 > dBm.

Selecting External Leveling

Press AMPTD > Leveling Control > Leveling Mode > Ext Detector.

Determining the Signal Generator's Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency
points and there is a need to know the maximum output amplitude for each frequency point, refer to

the Data Sheet for the power bands. Then use this procedure to determine the maximum amplitude
for each band.
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With external leveling and Option 1E1, the signal generator’s the power range approximates that of a
standard option instrument (no Option 1E1). But Option 1E1 does let you use the attenuator to drive
the ALC to its mid-power point when using negative amplitude values. However adding attenuation
does decrease the upper range limit. For more information, see “Option 1E1 Output Attenuator
Behavior and Use” on page 98.

1. If Option 1E1 is installed, adjust the attenuator to the desired level.

NOTE If the Option 1E1 output attenuator value is to high (approximately >55 dB), it will cause an
unlevel condition to occur when the RF output is turned on.

a. Press AMPTD > Atten/ALC Control > Set Atten.
b. Enter the attenuator value.
Turn on the RF output: Press RF On/0ff to On
3. Set the AMPTD step increment value to one dB.
¢ Press AMPTD > Incr Set > 1 > dB.
4. Determine the minimum amplitude value:
a. Set the amplitude to —25 dBM.
b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.
c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range
value.

5. Determine the maximum amplitude value:
a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

e If the unleveled annunciator appeared, decrease the amplitude until the annunciator is
gone. The value where the annunciator disappears is the maximum upper range value.

e If the signal generator displays Error: 501, Attenuator hold setting over range at
the bottom of the display, the value showing is the maximum upper range value.

To remove the error message, press the down arrow key until the message is gone. The
error appears when an attempt is made to increase the amplitude beyond the maximum
value as it relates to the current attenuator setting.
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Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference,
the signal generator provides two methods for configuring the displayed power value so that it closely
matches the measured value at the output of the coupler/splitter.

1. Connect and configure a measurement instrument:

a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.

b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:
If using the ExtLeveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal
detector.

a.
b.

On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

While viewing the carrier amplitude value on the signal generator display, use the RPG
knob (detent knob) to adjust the offset value until the integer part of the displayed
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB.

Using the number keypad, make the necessary fractional adjustments to the display
amplitude value.

If using the Amptd Offset Softkey:

On the signal generator, press AMPTD > Leveling Control > More > Amptd Offset.

Calculate the difference between the signal generators displayed Amplitude value and the
measured value.

Using the numeric keypad, enter this difference as the Amptd Offset softkey value.
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Figure 5-20 Power Search and ALC Off Softkeys
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— Auto: The calibration routine executes whenever
output frequency or amplitude changes.

— Span: Pressing Do Power Search executes the
power search calibration routine once over a
selected frequency range.

The corrections are stored and used whenever you
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Note:

1) This feature is not available on N5183A.
2) This feature is only available in instruments
beginning with serial number 4818 or greater or

and with Option 099.

Pouer Search

RMS

Fixzed

Manual

Modulated

RN

RMS: Value is a DC
bias equivalent to the
value derived from the
file header or the
calculated value from
the current 1/Q data.
Fixed: Uses a fixed
1.0V DC bias value
(Same value is used
with Ext I/Q data).
Manual: Allows user to
specify the DC bias
voltage value (0-1V).
Modulated: Uses the
AC bias from the actual
modulating signal.

Turning ALC off deactivates the signal generator’s automatic leveling circuitry, enabling you to
measure the output at a specific point in a test setup and adjust as required for the desired power
level at that point. Turning ALC off is useful when the modulation consists of very narrow pulses
that are below the pulse width specification of the ALC or when the modulation consists of slow
amplitude variations that the automatic leveling would remove.

A

Set the desired frequency.
Set the desired amplitude.

Turn the RF output on.

highlight Off.

Preset the signal generator.

Connect the power meter to the point at which you want a specific power level.

Deactivate the signal generator’s automatic leveling control: Press AMPTD > ALC Off On to
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7. Adjust the signal generator’s amplitude until the power meter measures the desired level.

Power Search Mode

Refer to Figure 5-20 on page 103. Power search executes a routine that temporarily activates the
ALC, calibrates the power of the current RF output, and then disconnects the ALC circuitry.

NOTE For the power search routine to execute, RF must be on and ALC must be off.

Example: Automatic Power Search
1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic leveling control:
Press AMPTD > ALC O0ff On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument change
that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes.
The Do Power Search feature enables you decide when to execute a power search to compensate for
changes, such as temperature drift or a change in the external input.

Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset
(positive or negative) from the entered value.

RF Output = entered value — offset value

Displayed Value = output frequency + offset value

To set an offset:

e Frequency: Press Freq > Freq Offset > offset value > frequency unit.
e Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Indicates that an offset is on

FREQUENCY ﬁ
6.000 000 001 00 &z | -143.00 den
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Examples

Example | Example | Example

#1 #2 #3 Comments

Parameter

Entered (and displayed) Value: | 300 MHz | 300 MHz | 2 GHz The entered value must be positive.

Offset: 50 MHz -50 MHz | -1 GHz An offset value can be positive or negative.

The signal generator alerts you if the

Output Frequency: 250 MHz | 350 MHz | 3 GHz output frequency or amplitude is out of range.

When using the signal generator as a local oscillator (LO), you can use the offset to display the
frequency of interest, as illustrated below:

Antenna tuned to 1321 MHz

RF Amplifier Mixer Filter IF Amplifier

IF Output
IF =321 MHz 321 MHz
— >

&

T Output Frequency = 1000 MHz

Selected Offset Slgnal Generator Display
321 MHz 1321 MHz (Antenna Frequency)

Signal Generator —679 MHz 321 MHz (IF Output)
(local oscillator)

Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset
(positive or negative) by the entered value from a chosen reference value.

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.
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FREQUEHCY REF

Indicates that a reference is on

0.00 tz

ANPLITUDE REF

-144.00 s

Examples
Example | Example | Example
Parameter #1 #2 #3 Comments
Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.
Entered (and displayed) Value: | 2 MHz —2 MHz -1 GHz The entered value can be positive or negative.
Output Frequency: 52 MHz 48 MHz 1 GHz The signal generator alerts you if the output frequency or

amplitude is out of range.

To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the

steps above.

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple
(positive or negative) of the output value.

Displayed Value = multiplier value X output frequency

Output Frequency = displayed value + multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency.

The display equals the output frequency times the multiplier value.
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Indicates that a frequency multiplier is on

FREQUEHCY HULT ANPLITUDE Frequenc!
600.000 000 00 mz | -144.00 den Frea et sct
HN:GU&UOUUUOOUMHZ Incr: 100.00000kHz Weg?
Freq Offset
0.00 Hz
Freg Multiplier
3.000 %

WWMW

Examples
Example | Example | Example
Parameter #1 #92 #3 Comments
Frequency Multiplier: 3 -3 4 A multiplier value can be positive or negative.

Entered (and displayed) Value: | 600 MHz | —-600 MHz | 8 GHz

The signal generator alerts you if the output frequency is

Output Frequency: 200 MHz | 200 MHz 2 GHz out of range.

When using the signal generator as the input to a system, you can set the frequency multiplier so
that the signal generator displays the output of the system, as illustrated below using a doubler:

Signal Generator Doubler
- - Selected  Entered/Displayed Signal Generator
Input = 2 GHz X2 M» Multiplier ~ Frequency Output
2 4 GHz 2 GHz

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 107



Optimizing Performance
Using Free Run, Step Dwell, and Timer Trigger

When measuring mixers, the frequency multiplier and frequency offset are often used together. In the
upconverter example below, the multiplier is set to —1 and the offset is set to 3 GHz so that the
signal generator displays fyp.

Mixer

fre = 2200 - 2400 MHz fie = 3000 MHz

T fLo = 800 — 600 MHz

Selected Selected Entered/Displayed Signal Generator

Multiplier Offset Frequency Output (fL o)
(frF)
Signal Generator -1 3000 MHz 2200 MHz 800 MHz
(local oscillator) -1 3000 MHz 2400 MHz 600 MHz

Using Free Run, Step Dwell, and Timer Trigger

Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 5-21 on page 109) the signal generator waits for the signal to
settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In addition,
the time to complete the entire sweep can vary. There is always a minimum value of Step Dwell for
each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 100 us. The
time between frequency points is the sum of the settling time, plus the Step Dwell time. The settling
time is dependent on frequency, amplitude, band crossings, and other factors, so the time between
frequency points can vary.

Timer Trigger instead of Free Run (Figure 5-21 on page 109) the signal generator generates equally
spaced triggers, and it moves to the next point at each trigger. This has the advantage that the time
between points is consistent and the overall sweep time is consistent. But, if the trigger is too fast,
the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the
point-to- point time is consistent, use Free Run and Set Dwell time.

If the signal’s point-to- point time requires consistency but the specific settling time at each point can
vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the signal
generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point-to-point time is
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms,
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers.

108 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Sweep > Configure Step
Sweep > More

¢

Step Duell

Figure 5-21 Free Run, Set Dwell, and Timer Trigger Softkeys

Optimizing Performance

Using Free Run, Step Dwell, and Timer Trigger

Use Step Dwell with Free Run when additional measurement wait

time is desired after settling.

2.000 msec

Step Spacin
i |

bt ittt nnin, |

Sweep > More

'

Sueep/sList &

Configure,
List Sueep

Skeep Trigoer)
(Free Fun)

(Free Fun)

Hore 2 of 3

Trigger Setu

Free Run

Trigger Keu

Point Trigger b

Bus

Exty

If the signal is to be settled for a minimum specific time at each point
and it is not important if the point-to-point time is consistent, use

Step Dwell and Free Run time.

-

Timer Trigger .~

Timer Triggerw

For details on each key, use key help as described on see page 40.

Trig Timer Period
1.000 msec

M

If the signal’s point-to-point time
requires consistency but the
specific settling time at each point
can vary, then use the Timer
Trigger. Avoid using too fast of a
sweep which does not allow the
signal generator to settle.

If the signal needs to be settled for
a specific minimum time and
consistent point-to-point time is
required, then you should set the
Timer Trigger to be the sum of the
switching time (900 us (Option
UNZ) or 5 ms (Standard)) plus the
minimum settled time that is
needed to make the measurement.
Example: If you need the signal to
remain settled for 3 ms, and you
have Option UNZ which settles in
0.9 ms, then set the time trigger to
the sum which is 3.9 ms.
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Using LXI

NOTE LXI Class B Compliance Disclaimer

As of this product firmware release in June 2008, LXI Class B Compliance Tests, using the
new IEEE 1588-2008 Precision Time Protocol (PTP), were not available. This product
provides the features of an LXI Class B instrument by adding LAN Triggering and Time
Synchronization to its LXI Class C compliance. References to LXI Class B in the document,
instrument menus and web pages do not insure LXI Class B compliance. This product will
apply for LXI Class B Compliance when the LXI Consortium has approved its specification
changes and can provide certified testing. Refer to http.//www.lxistandard.org/home.

LXI-B is only available on instruments with serial prefixes >US/MY/SG4818.

The LXI Standard (Lan eXtensions for Instruments) brings the connectivity of the internet to the Test
and Measurement industry. LXI adds a number of tools that a system integrator may use to improve
the efficiency of his measurements and improve his visibility into his system.

This section assumes the user is well acquainted with LXI terminology and use models. Also, this
section assumes that the user has read and understands the Chapter 3, “Basic Operation.” Refer to
the Programming Guide and to www.lxistandard.org.

Understanding LXI Clocks

In the simplest test system, one Personal Computer (PC) connects to one LXI instrument via LAN.

The PC has its own internal or browser clock and the LXI instrument has two clocks: the Operating
System Clock (MS Windows, Windows CE, VX Works, etc.) and the PTP clock. This is shown in the
following illustration.

Figure 5-22 LXI PC with Clock (Browser Clock) and MXG (Operating System Clock and PTP Clock)

Master Clock GrandMaster
Clock

PC with clock
(Browser clock) LXI Instrument includes Operating
System clock and PTP clock

The PC browser clock shows the local civil time using a standard Date/Time representation. If the PC
is connected to a Network Time Protocol (NTP) server (via LAN), then its time will be relatively
accurate. However, because the PC may be in a different time zone or have a different Daylight
Savings Time offset (or both) than the instrument, it is possible for the PC Browser clock to have a
different time than the Instrument's Operating System (OS) clock.

110 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Optimizing Performance
Using LXI

The LXI instrument has two clocks. The instrument's Operating System clock, similar to a PC's
browser clock, shows civil time in a Date/Time format. The second clock is the instrument's PTP
clock. It is this clock that synchronizes to the Master Clock (if one is in the system). Typically, this
PTP clock shows time in elapsed seconds since its epoch.

As you create larger systems by adding more LXI instruments, the total number of system clocks
increases significantly. In addition to instrument clocks, you may have PTP Master clocks and a PTP
GrandMaster clock. Also, you may have one or more Boundary Clocks in your test system. Boundary
Clocks will have both Master and Slave clocks depending on the port.

NOTE The concept of local clock or local time can be confusing depending on your frame of
reference. For example, if you think of yourself in front of the PC, then local is the Browser
clock. If you think of yourself in front of the instrument, then local is the instrument. In
most test systems, the PC and the instrument are located close together. But, in some test
systems they may be located many miles apart, in different timezones, or even across an
ocean. Also note that the SCPI uses local in the context of the instrument OS clock.

Getting Started With LXI

Setting the LAN Extensions for Instrumentation (LXI).

NOTE Enabling the LXI subsystem effects switching speed.

For optimal switching speed, disable LXI subsystem when not in use.
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Figure 5-23 Configuring the LXI subsystem

Utility > More ——»»| Utility 7
LXI-EM
Services—Page 38
\J
FREQUENCY BE OFF LRI-B Enables or disables the LXI
6.000 000 000 00 &z LKI-B Enabled subsystem. NOTE: LXI
2 Off On/Off setting is persistent.
PTP Domain Sets the Precision Time
LT Status Information o Protocol Domain.
Iﬁ}ég_ElStEtg: ) gn SYERS (TenrH Sets the LXI Event Domain.
ock Domain:
Event. Domain: u]
Grandmaster Clock: 016b0cO0002L Configure
Master Clock: 016b0c000024 LHI Ewents’|
Route ConmectorsH—Page 48

Enabling the LXI-B subsystem (On) opens the Status Information window where the
PTP and Event Domain are configured. The Grandmaster and Master Clocks are
controlled by remote commands only.

\i

LXT-B Events

Configure LXI |8
Trioger venta*f— Pad® us

Confioure LKIWL  page 114
For details on each key, use key help Refer to the Programming Guide and the SCPI Command Reference. Output Events
as described on page 40.

L
— kA
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Figure 5-24 Configuring LXI Trigger Input Events
Utility > More > LXI

v

LAT-B
LHXI-B Enabled
TN On

PTP DDrnaiB page 112 T7i-h Toenis
Configure LHI
Event. Domain Trigger Events”]

Configure LHI
Output Events™ page 114

Configure,| >
L¥I Events

Sny
—h

Route Comnectorse—— Page 48

\J
FREQUEHCY RE_OFF Input is

6.000 000 000 00 = S I kit

Input Events

These are the pre-defined default input LAN event identifiers and can not be deleted.
An incoming LAN event is treated as a trigger. The trigger event identifier must be
enabled (On) and the LXI LAN (page 47) selected as the source of the trigger.

For details on each key, use key help Refer to the Programming Guide and the SCPI Command Reference.
as described on page 40.
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Figure 5-25 Configuring LXI Output Events
Utility > More > LXI

v

LAT-B

L¥I-B Enabled
[ OFf ]

PTP DornaiB page 112

Event. DDrnaiB

ey TR Fuents

Configure LKI|
Triogger Events

page 113
Route Connectorsei— Page 48

Configure LHI

Internal Status Events

Indicates whether or
not a measurement
operation is underway.

Select Source

Perat ionComplete

J

Indicates that the
instrument is

Settling

N

settling.

Sweeping

/

Indicates whether
[~—__or not the

Haitin
For Trigger

&

instrument is
sweeping the LO.

Indicates the

Output Events’| A instrument is
waiting for a
s ad trigger.
FREQUENCY Sl il Enables or
6 000 000 000 00 GHz Togole disables the
. Event. Stat instrument event
LANO — LAN7
Gutput Events Select Sourcek
P =]
i hone . Select DriveW
N\
\
These are the pre-defined default outgoing LAN event identifiers and can not
be deleted.
The generation of an outgoing LAN event is dependant on the LAN event Y Disables the LAN

identifier being enabled (On) and the occurrence of one of the Internal Status
Events. The signal state of the outgoing LAN event can be the same as or

inverted from the source internal status event.

For details on each key, use key help
as described on page 40.

Select Drive

0ff)

event.

Typical operation

where both edges
of the instrument
event are

Wired-0r

il

transmitted.

Only one edge of
the instrument

event is transmitted

Refer to the Programming Guide and the SCPI Command Reference.
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For More Information

For more information on using LXI see the Agilent website dedicated to LXI instrumentation:

www.agilent.com/find/lxt.

Agilent LXI Application Notes:

Using LXI to go beyond GPIB, PXI and VXI (AN 1465-20)

10 Good Reasons to Switch to LXI (AN 1465-21)

Transitioning from GPIB to LXI (AN 1465-22)

How to Use VXI and PXI in Your New LXI Test System (AN 1465-23)
Using Synthetic Instruments in Your Test System (AN 1465-24)
Migrating system software from GPIB to LAN/LXI (AN 1465-25)
Modifying a GPIB System to Include LAN/LXI (AN 1465-26)
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Using a USB Keyboard

You can use a USB keyboard to remotely control the RF output state, the modulation state, and to
select a memory sequence and register.

The register selection, RF output state, and modulation state are affected by power cycle or preset,
but the USB keyboard control state and the sequence selection are not.

USB Keyboard Key Signal Generator Function

Delete, Enter RF On/Off
¢ Insert Mod On/Off
Recall State Home, Up Arrow Next Sequence
RECALL HEE End, Down Arrow Previous Sequence

Page Up, Right Arrow, + Recall Next State Register

select Seqé Page Down, Left Arrow, - Recall Previous State Register
Delete
SeqC0] ReglO01*
Delete ALl
Regs in SeqlO1*
Delete ALL FREQUEHCY AAPLITUDE Auto Recall
elete
EREt 6.000 000 000 00 &z | -144.00 den Next. <60
Hore 1 of 2
Prew SEO
Recallvstate SEQ REG MUD RF
Mext. REG
Auto Recallyp——— e
I 0 N D f f Frew REG
T eV
USE Keuboard
_Control
| Off gl

Turning the USB keyboard control off disables the USB
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on see page 40.
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6 Using Pulse Modulation (Option UNU or UNW)

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 39 and familiarize yourself with the information in that
chapter.

* Pulse Characteristics on page 119
e The Basic Procedure on page 121

* Example on page 121
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Figure 6-1 Pulse Softkeys

[?J

Pulse

Fulse
| O+ Wi

Pulse Source

Pulse Source

(Free-Run)®

Pulse Period
L.00 usec

Pulze Oelay
0.00000000  sec

Pulze Hidth
2.00 usec

Pulse

A

NMore 1 of 2 3—»

Trig Out BHC
Wideo Polarity
Invert

transmitted out of the Trig Out BN/

Determines the type of signal
Normal = high state.

Ext Polarity
Invert

Invert = low state.

Route Connectorsk

Square
Pulse Source
Free-Run Gated
page 121

Triggered page 121 Ext Pulse
Adjustable
_ Doublet
Trigoer Doublet

fore 1 of 2
These softkeys are Tri§ Out BAC__7 Low = settled

only available when
the Pulse-Source is
set to Adjustable
Doublet.

Sueep Trig Out

Source Settled

Latency from the external
pulse input to the pulse
sync output = 50-60 ns.

Y

Determines how the signal generator’
responds to an external pulse signal.
Normal = high state.

Invert = low state.

For details on each key, use key help
as described on page 40.

Hore 2 of 2 %

These
softkeys are
only available
for the
N5182A.

Select which marker to
route to the Event 1 BNC.

Width  Period
;?g a;scg Egge 15 50 ns >50ns
pag | Pulse Sunc 20 ns <50ns
Rout.e{ Connectors Sueep Out BHC 7
Foute To Pulze Wideo
Trig Out BHCH— Sueep Out
(Sweep Trig Out)
Foute To EBG Markersm—
Sweep Out. BNCw P Source Settled

(SWeep Out)
Foute To
Event. 1 BEMCH
(Marker 1)

| o

farker 1

More 1 of 2

Trig Out BHC 7

Aux Pulse Gen

Marker 2

Marker 3

Marker L

e

R

This is the 2nd page of
the Menu.

Marker 1

Pulse Wideo

TTL signal

N

Select the signal
routed to each
output connector.

Marker 2

Select which
marker to
route to the

Marker 3

Trig out BNC.

Marker L

These
oftkeys are
only available

for the
N5182A.
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Pulse Characteristics

Pulse Characteristics

NOTE When using very narrow pulses that are below the signal generator’s ALC pulse width
specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn
ALC off (see page 103).

Pulse Source Type Period® Width & Delay® Uses Trigger Event”
Square Internal free run pulse train with Determined by . .
a 50% duty cycle. user defined rate.
Free Run . . .
Internal free run pulse train User Defined User Defined —
(default)
Triggered Internal pulse train — User Defined v
User Defined:
First pulse is relative to the
Adjustable Two internal pulse trains for each o rising edge of trigger signal. v/
Doublet trigger event. Second pulse is relative to the
rising edge of first pulse.
See Figure 6-2 on page 120
The first pulse follows the
A . . trigger signal.
Trigger Two internal pulse trains for each - v
Doublet trigger event. Second pulse is user defined.
See Figure 6-3 on page 120
Gated Internal gated pulse train — User Defined v
External External pulse signal at the rear - - -
panel Pulse connector

3All delays, widths, and periods have a resolution of 10 ns.
ba signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.

Rear panel inputs are described on page 15

External pulse input

R;‘?#T O BWEEP QUT AM m PULSE TRIG IN TRIG QUT REFIN 10MHz OUT O
(e ] GhiE

@] DDCHJDICHJDQDDDDO ©0 @:D:D@@Cﬁ
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Figure 6-2 Adjustable Doublet

External
Trigger

RF Output —
' Pulse 1 ' Pulse 1 '

'<¢—— Delay —»'—— Width —»

The delay of the first pulse is measured from ~
the leading edge of the external trigger signal.

Pulse 2 : Pulse 2
'€«— Delay —————P'€—— Width ——»,

The delay of the second pulse is measured from
the leading edge of the first pulse.

Figure 6-3 Trigger Doublet

External
Trigger

RF Output —

Pulse 1 . Pulse 1
~€—— Delay —p»-+—— Width ——P»

The first pulse follows the The delay of the second pulse is measured from
external trigger signal. the leading edge of the external trigger signal.
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The Basic Procedure

The Basic Procedure

1. Preset the signal generator.
2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4. Configure the modulation:
a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

Square Free Run (default) | Triggered | Adjustable Doublet | Trigger Doublet Gated External
Pulse Rate — — — — - _
— Pulse Period — — —_ Pulse Period —_
— Pulse Delay Pulse Delay | Pulse Delay Pulse Delay — —
— Pulse Width Pulse Width | Pulse Width Pulse Width Pulse Width —_
— — — Pulse 2 Delay — — —
— — — Pulse 2 Width —_ —_ —_

5. Turn on the modulation: Pulse Off On softkey to On.
The the PULSE annunciator lights, indicating that you enabled modulation.
6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.
The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 58.

Example

The following example uses the factory preset pulse source and delay.
Output: A 2 GHz, 0 dBm carrier modulated by a 24 ps pulse that has a period of 100 us.

Preset the signal generator.

Set the frequency to 2 GHz.

Set the amplitude to 0 dBm.

Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

S o

Turn on both the pulse modulation and the RF output.
The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”
on page 272.
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Example
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1 Basic Digital Operation—No BBG Option Installed

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG ATE or via SCPI commands. Refer to the Installation Guide,
the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter
3, “Basic Operation,” on page 39 and familiarize yourself with the information in that chapter.

See Also: “Adding Real-Time Noise to a Dual ARB Waveform” on page 211
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1/Q Modulation

The following factors contribute to the error vector magnitude:
¢ Differences in amplitude, phase, and delay between the I and Q channels
e DC offsets

The I/Q menu provides adjustments to compensate for some of the differences in the I and Q signals
or to add impairments.

See also, “Modulating the Carrier Signal” on page 58.

Figure 7-1 1/Q Display and Softkeys

Ija This panel displays the current status and settings
This panel displays the external of the I/Q adjustments. Grey text indicates 1/Q
1/Q signal routing. adjustments are off.
FREQUEHCY ANPLITUDE

6.000 000 000 00 &z | -144.00 e Ig;ﬂ

I/0 Adjustments
(134

I/0 Routing & Optimfzation I/0:  Off /
/

I1/0 Adjustments
I/0 Adjustments
0n

02/10/2006 1L:12

External Input
I Offset
0.000 W

External Input
0 Offset

Sets the dc offset

Quadrature
Anole ﬂdjustnﬁn%

For details on each key, use key help
as described on page 40.

Offsets the phase of the Q signal relative to the phase of the

| signal. The quadrature adjustment key is in units of
degrees. This adjustment is not calibrated.

The following table shows common uses for the adjustments.
Table 7-1 1/Q Adjustments Uses

I/Q Adjustment Effect Impairment
Offset Carrier Feedthrough dc offset
EVM error phase skew

Quadrature Angle

I/Q Images I/Q path delay
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Configuring the Front Panel Inputs

The Agilent MXG accepts externally supplied analog I and Q signals through the front-panel I Input
and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel
Overview - MXG N5181A/82A” on page 5.

a. Connect an analog I signal to the signal generator’s front-panel I Input.
b. Connect an analog Q signal to the signal generator’s front-panel Q Input.
Turn on the I/Q modulator: Press 1/Q 0ff On to On.

3. Configure the RF output:
a. Set the carrier frequency.
b. Set the carrier amplitude.
c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 124) as needed.
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8 Basic Digital Operation (Option 651/652/654)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXGor via SCPI commands. Refer to the Installation Guide, the
Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter
3, “Basic Operation,” on page 39 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 651,
652, or 654.

* Waveform File Basics on page 128

* Storing, Loading, and Playing a Waveform Segment on page 130
*  Waveform Sequences on page 132

e Saving a Waveform’s Settings & Parameters on page 136

* Using Waveform Markers on page 142

e Triggering a Waveform on page 158

* C(Clipping a Waveform on page 165

* Scaling a Waveform on page 174

* Setting the Baseband Frequency Offset on page 180

* 1/Q Modulation on page 183

¢ Multiple Baseband Generator Synchronization on page 188

e Waveform 5-Pack Licensing (Options 221-229) on page 199

See Also:
* Adding Real-Time Noise to a Dual ARB Waveform on page 211
* Real-Time Phase Noise Impairment on page 216

e Multitone and Two-Tone Waveform Generator (Option 430) on page 251
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Waveform File Basics

There are two types of waveform files:
* A segment is a waveform file that you download to the signal generator.
For information on creating and downloading waveform files, refer to the Programming Guide.

* A sequence is a file you create in the signal generator that contains pointers to one or more
waveform files (segments, other sequences, or both).

For information on creating sequences, see page 132.

Signal Generator Memory

The signal generator has two types of memory:

* Volatile memory, baseband generator (BBG) media, where waveform files are played from or
edited.

* Non-volatile memory, either internal (int) or external (USB) media, where waveform files are
stored.

Dual ARB Player

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player
also provides markers (page 142), triggering (page 158), clipping (page 165), and scaling (page 174)
capabilities.

Most procedures in this section start from the Dual ARB menu, shown below.
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Storing, Loading, and Playing a Waveform Segment

Before using this information, you should be familiar with the signal generator’s file menus. If you
are not, refer to “Working with Files” on page 60 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 132.

The signal generator has two types of waveform media: non-volatile (internal or USB), and volatile
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 8-2 Waveform Segment Softkeys
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Select Haveform
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\i
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changes to Show Waveform Sequence Contents.
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Load ALl
From Int Media

Goto Roue Delete Seamentw

Oelete ALl
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Int Media
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These keys change to indicate the default media.

For information on selecting the default media,

see page 71.

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included

Use the arrow keys or knob to

highlight a letter or character. —————®

Cycling power or rebooting the signal generator deletes the files in BBG media.

Text Entry

Enter

Clear Text

Editing Mode
Feplace

Show Alpha Table
aOff

in a sequence.

NOTE

created in BBG media: RAMP_TEST WFM and SINE TEST WFM.

There are additional sample waveforms that are available in the internal storage and that
can be loaded into memory. Refer to www.agilent.com and search on “Factory Default

N5182A” and “waveforms”.

Each time the instrument powers up, two factory-supplied segments are automatically

Press Mode > Dual ARB > Select Waveform > Waveform Segments.
2. Press Load Store to highlight Load, then, using the arrow keys, highlight the desired waveform

segment.

3. If there is already a copy of this segment in the currently selected media and you do not want to
overwrite it, rename the waveform segment before you load it (refer to the previous procedure).
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4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press
Load All From currently selected Media.

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media
(page 71). If you have not downloaded a waveform segment, either refer to the Programming Guide,
or use one of the factory-supplied segments.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.
4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want to
overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.

b. Enter a name for the waveform segment.

c. Press Enter > More.

d. Highlight the waveform segment that was renamed.

Press Store Segmentto currently selected Media.
6. Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press
Store All to currently selected Media.

Playing a Waveform Segment

1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.
3. Press Select Waveform.

4. Set ARB Off On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and the
waveform modulates the RF carrier.

Annunciators display with active waveform (ARB On)

[1/0]_ARE |
~—_
Select
Haveform
ARE Setup

¥ L N

Current waveform selection
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5. Configure the RF Output:
Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector.
Waveform Sequences

Figure 8-3 Waveform Sequence Softkeys

Sequence name
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For details on each key, use key help
as described on page 40.

A waveform sequence is a file that contains pointers to one or more waveform segments or other
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or
other sequences, or both thereby eliminating the need to stop waveform playback just to select
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the

sequence; you must also store the individual segments or they are lost when you turn off or reboot
the signal generator. If the segments are located in internal/external media, you must load them into
BBG media prior to selecting a waveform sequence (see page 130). If you attempt to play a sequence
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without the segments loaded into BBG media, the signal generator reports: ERROR: 629, File
format invalid. If this happens and the segments are not stored in internal/external media, you
must recreate the segments using the same file names that the sequence points to before you can
play the sequence.

Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences
(nested sequences). The signal generator lets you set the number of times the segments and nested
sequences repeat during play back. But there is a difference between repeating a segment versus
repeating a nested sequence. Each segment can repeat up to 65,535 times, but no matter how many
times a segment repeats, it counts as a single segment. However each repetition of a nested sequence
counts as additional segments.

——Segment 1
Sequence A — 2 segments
L Segment 2
Waveform 11 segments
Sequence _ Sequence AN\ g oo oments
Sequence B | repeated 4x 9 segments

L Segment 3

The maximum number of times that a nested sequence can repeat is based on the number of
segments in the nested sequence and the remaining number of allowed segments (1,024). For
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the
nested sequence is limited to 250 repetitions:

24 + (4 x 250) = 1,024 maximum number of segments per sequence
Even though there is a limiting factor on the maximum number of times that a nested sequence can
repeat, each segment within the nested sequence can repeat up to 65,5635 times.
Example

Use the following procedure to create and store a waveform sequence using one repetition each of
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on loading
waveform segments into BBG media, see page 130.

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence > Insert
Waveform.

b. Highlight the desired waveform segment and press Insert.
2. Select the second segment:
a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting
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3. Name and store the waveform sequence to the Seq file catalog:
a. Press More > Name and Store.
b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 134 and “Setting Marker Points in a
Waveform Segment” on page 149.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey
1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey
1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

* change the number of times each segment or nested sequence plays

* delete segments or nested sequences from the sequence

* add segments or nested sequences to the sequence

* toggle markers on and off (described on page 154)

¢ save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

CAUTION If you edit and resave a segment used in a sequence, the sequence does not
automatically update the RMS value in its header. You must select and update the
sequence header information (page 136).

Use the following steps to edit a sequence that has two different segments so that the first segment
repeats 100 times and the second segment repeats 200 times, then save the changes.

Assumption: A waveform sequence that has two different segments has been created and stored (see
previous example on page 133).

1. Select the sequence:
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence >
Edit Selected Waveform Sequence.
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2. Change the first segment so that it repeats 100 times:
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry.

3. Change the repetition for the selected entry to 200:
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps:
Press More > Name and Store > Enter.

To save the changes as a new sequence:

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence.

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 133.

NOTE To play a waveform segment individually or as part of a waveform sequence, the segment
must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” on
page 130.

1. Select a waveform sequence:
a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RMP200) from the Sequence On
column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform:
SEQ:SINE100+RMP200).

Annunciators display with active waveform (ARB On)

DE

2,000 000 000 00- Ose o 000

HRB

FREQUEHCY

ARE
0ff iGN

Select
HaveFarm®

ARE Setupw

Ir‘igger W

Current waveform selection

2. Generate the waveform:
Press ARB Off On to On.

This plays the selected waveform sequence. During the waveform sequence generation, both the
I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier.
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3. Configure the RF output:

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector.

Saving a Waveform's Settings & Parameters

This section describes how to edit and save a file header. When you download only a waveform file
(I/Q data, which the signal generator treats as a waveform segment), the signal generator
automatically generates a file header and a marker file with the same name as the waveform file.
Initially the file header has no signal generator settings saved to it, and the marker file consists of all
zeros. For a given waveform, you can save signal generator settings and parameters in its file header
and marker settings in its marker file (page 142); when you load a stored waveform file into BBG
media, the file header and marker file settings automatically apply to the signal generator so that the
dual ARB player sets up the same way each time the waveform file plays.

Figure 8-4 Header Utilities Softkeys
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When you create a waveform sequence (as described on page 133), the signal generator automatically
creates a waveform sequence header that takes priority over the individual waveform segment
headers. During a waveform sequence playback, the segment headers are ignored, except to verify
that all required options are installed. Storing a waveform sequence also stores its file header.

Some of the current signal generator settings shown in the file header appear as part of the softkey
labels, and others appear in the dual ARB summary display, shown in the following example.
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All settings in this menu can be stored to
the file header (Table 8-1 on page 137 lists

AMPLITUDE all settings stored in a file header)
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Table 8-1 File Header Entries

32- Character Description A description entered for the header, such as a the waveform’s function (saved/edited with the Edit

Sample Rate

Runtime Scaling

RMS

Marker 1...4 Polarity

ALC Hold Routing

RF Blank Routing

Mod Attenuation

BB Freq Offset
AWGN: State
AWGN: C/N Ratio
AWGN: Carrier BW
AWGN: Noise BW

AWGN: Carrier RMS

Description softkey, see Figure 8-4).

The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown
in Figure 8-1 on page 129).

The Runtime scaling value is applied in real-time while the waveform is playing. This setting can be
changed only for files playing in the dual ARB player (see page 177).

When the modulator attenuation setting (see page 129) is set to Auto, this value is used to calculate
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562

Marker polarity can be positive or negative (described on page 154).

Which marker, if any, implements the ALC hold function (described on page 144), which holds the
ALC at its current level when the marker signal is low. All waveforms generated in the signal
generator have a marker on the first sample point. To see the results from the three routing
selections, you may need to select a range of sample (marker) points (see “Setting Marker Points in
a Waveform Segment” on page 149).

Which marker, if any, implements the RF blanking function (described on page 152) when the
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold
Routing for the same marker when you are using the RF Blank Routing function. When the marker
signal goes high, RF blanking discontinues.

The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 8-1 on
page 129).

The baseband frequency offset, in Hz (see page 180).

Indicated whether real-time noise is on (1) or off (0) (see page 211).
Carrier to noise ration, in dB (see page 213).

Bandwidth over which the noise power is integrated, in Hz (see page 213).
Bandwidth of the noise, in Hz (see page 213).

The carrier RMS across the carrier bandwidth (see page 213).
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Table 8-1 File Header Entries (Continued)

Phase Noise State Indicated whether phase noise is on (1) or off (0) (see page 216).

Phase Noise F1 The start frequency for the level mid-frequency characteristics (see page 216).

Phase Noise F2 The end frequency for the level mid-frequency characteristics (see page 216).

Phase Noise Lmid The amplitude for the level mid-frequency characteristics (see page 216).

Over- Range Protect Indicated whether DAC Over-Range Protection is on (1) or off (0) (see page 220).

Unique Waveform Id 0 = no Id; once an Id is assigned, it cannot be changed.

License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and

Licenses” on page 36

Can be Read Out Indicates whether the waveform can be queried through SCPI or FTP.

Viewing and Modifying Header Information

The following example uses the factory-supplied waveform file RAMP TEST WFM.
1. From BBG media, select the waveform RAMP TEST WFM:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP TEST WFM.

c. Press Select Waveform.
2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 8-5 shows the default file header for the factory-supplied waveform RAMP TEST WFM.
The Header Field column lists the file header parameters; use the Page Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified.
Unspecified means that there is no setting saved for that particular parameter.

The Current Inst. Settings column shows the current signal generator settings. In this
example, these are the settings that you will save to the file header.

NOTE If a setting is unspecified in the file header, the signal generator uses its current value for
that setting when you select and play the waveform.
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To calculate the RMS waveform voltage:

Press Calculate

I Then refer to Header Field information.

Note: For greater accuracy, if the waveform has long rise/fall times, a DC
offset, or noise* already added to the waveform (for a bursted signal), it

is recommended that the Edit RMS and Edit AWGN RMS Override
softkeys are used for the best measurement accuracy.

*Option 403 Real-time AWGN does not affect the Header Field RMS
value. But, noise added to the waveform prior to downloading and

playing in the signal generator does affect the Header Field RMS value.

Clear Header +— Resets the saved

Opens a menu for manually
defining the carrier RMS value
to use for calculating the
AWGN: Carrier RMS value
in the Header Field.

header settings
entries to default
settings

Edit._Header

Enter

Unspecified

Calculate

3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now display
the same values; the Saved Header Settings column lists the settings saved in the file header.

4. Edit and Update Settings

a. Return to the ARB Setup menu:
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the file

header. Figure 8-1 on page 129 shows the ARB Setup softkeys used in the following steps.
Set the ARB sample clock to 56 MHz:

Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%:
Press Waveform Runtime Scaling > 60 > %.

Return to the Header Utilities menu:

Press Return > More > Header Utilities.

As shown in the following figure, the Current Inst. Settings column now reflects the
changes to the current signal generator setup, but the saved header values have not changed.
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FREQUEHCY AAPLITUDE Edit._Header
6.000 000 000 00 &z | -144.00 den pescr1rEiLE
Eclit’ Values differ between
File Header Information: HFHLzRANP_TEST_UFN : AMS"] __— the two columns
Header Field Saved Header Settings Current Inst. Settings
Description ‘,,——”’EEEE’EHGN
RIS Dverride®
Sample Rate 125.000000000MHz 5. 000000000MHz F,——””””"
Funt.ime Scaling 878 - E0.00 2 L
0.814852207 M/A Clear Header
Marker 1 Polarity Pos Pos
Marker 2 Polarity Pos Pos
Marker 3 Polarity Pos Pos Save Setul
Marker L Polarity  Pos Fos To Headeg
ALC Hold Routing Mone Mone
10:22 More 1 of 2

e. Save the current settings to the file header:
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved Header
Settings column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings column
and are used instead of the saved header settings. To reapply the saved header settings, reselect the
waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 138, you can view and edit a waveform’s header information after you select
the waveform; you can also edit waveform header information without selecting a waveform, or for
another waveform than the one that is currently selected.

1. Access the file header utilities menu:
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was last
selected. The following figure shows an example of the factory-supplied waveforms in BBG media.
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Active catalog Active media

6.000 000 000|00 &z

FREQUEHCY

ANPLITUDE

-144.00 den
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Saving a Waveform’s Settings & Parameters

Header File

Select Header

i FPAME_TEST LIFM
2 SIME_TEST_LFM

Cataloo of BBG Seoment Files) in(BBG_Hemor LB used  25EME free
11e Hame Size NModified

200

Catalog Tupe ]
BEG Seamentsi®)

\
Header File
Type: ___Heqder rile .
WFM1 = Volatile Segment Stored
NVWFM = Non-Volatile Segment Seaments
SEQ = Sequence
Seguence

For details on each key, use key help

Files in BBG media — |

as described on page 40.

2. If the desired catalog is not displayed, select it.

| — BBG Segments

e S

3. Highlight the desired waveform file and press Select Header.

Active waveform catalog

Catalogs that enable you to
view files in the active media.

For details on selecting the
active media, see page 62.

The signal generator displays the file header for the selected waveform file.

4. To edit the header, press More, and proceed as described in Step 4 on page 139 (Viewing and

Modifying Header Information section).
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Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment.
When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear
panel event output that corresponds to the marker number.

* Event 1 is available at both the EVENT 1 BNC connector (see page 19), and a pin on the
AUXILIARY I/O connector (see page 20).

* Event 2 is available at both the TRIG OUT BNC connector (see page 16), and a pin on the
AUXILIARY I/O connector (see page 20).

e Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 20).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer
to “Using Waveform Markers” on page 142 for details.

When you download a waveform file that does not have a marker file associated with it, the signal
generator creates a marker file without any marker points. Factory-supplied segments
(RAMP_TEST WFM and SINE TEST WFM) have a marKker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player.
These procedures also discuss two types of points: a marker point and a sample point. A marker
point is a point at which a given marker is set on a waveform; you can set one or more marker
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:
Clearing Marker Points from a Waveform Segment on page 148
Setting Marker Points in a Waveform Segment on page 149

Controlling Markers in a Waveform Sequence on page 154

This section also provides the following information:

* Waveform Marker Concepts on page 143

¢ Accessing Marker Utilities on page 147

¢ Viewing Waveform Segment Markers on page 148

* Viewing a Marker Pulse on page 151

¢ Using the RF Blanking Marker Function on page 152
¢ Setting Marker Polarity on page 154
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment.
You can set each marker’s polarity and marker points (on a single sample point or over a range of
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

J—L Positive 43 EVENT N

Marker N

Marker

File » O _|'
Bit N ~‘ ’— RF Blank Off On
Set Marker Marker . / o Bbm?:;?:r when
I On Off Polarity Negative ;
— = Markeris Low
When the signal generator encounters an enabled marker (described on page 154), an :RF Blank Only: includes ALC Hold
auxiliary output signal is generated and routed to the rear panel. :
. . . \ Marker N
Event 1 is available at the EVENT 1 BNC connector (see page 19), and at a pin on the O—— = Holds ALC when
AUXILIARY /O connector (see page 20). Marker is Low
Events 2 through 4 are available at pins on the AUXILIARY /O connector (see page 20). Marker N

ALC Hold Off On

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator.
However some settings such as amplitude, filters, and so forth within the RF output path can create
delays between the marker EVENT output signal and the modulated RF output. When using the
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency,
and if needed, reset the marker point positions, include delay (page 186), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker
file associated with it causes the signal generator to automatically create a marker file, but does not
place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media
(see “Loading a Waveform Segment into BBG Media” on page 130).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator,
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker
polarities or routing (RF Blanking and ALC Hold) and save the information to the file header

(page 136).

NOTE When you use a waveform that does not have marker routings and polarity settings stored in
the file header, and the previously played waveform used RF Blanking, ensure that you set
RF Blanking to None. Failure to do so can result in no RF output or a distorted waveform.
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before
or after you set marker points (page 149), setting a marker function before setting marker points may
cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods,
burst ramps, or when the increased dynamic range encountered with RF blanking (page 152) is not
desired.

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output
signal (the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

NOTE Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer
than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 104.

Markers set to account for marker
response relative to RF output

RF OUTPUT | : >

e
. ."- -

=<
Marl > H
arker J] == :
Positive Polarity :
< 100 ms »
Max ALC hold time :
CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create a spike

in the RF output, potentially damaging a DUT or connected instrument. To prevent this
condition, ensure that you set markers to let the ALC sample over an amplitude that
accounts for the higher power levels encountered within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of
highest amplitude. Note that the marker is set well before the

waveform’s area of lowest amplitude. This takes into account any
response difference between the marker and the waveform signal.

Close-up of averaging

The ALC samples the waveform when the marker signal goes
high, and uses the average of the sampled waveform to set the
ALC circuitry.

Here the ALC samples during the on marker points (positive
polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the
same waveform, which sets the ALC modulator circuitry for
that level; this usually results in an unleveled condition for the
signal generator when it encounters the high amplitude of the
pulse.

Pulse Unleveled
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Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during
the marker on points; the marker signal goes high during the off | Marker Oh -
points. The ALC samples the waveform during the off marker =

points.

Sample range begins on first point of signal

Sampling both on and off time sets the modulator circuitry
incorrectly for higher signal levels. Note the increased amplitude
at the beginning of the pulse.

Marker Marker
~ Marker On <~ Off **_On ™|

Negative range set between signal and
off time
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Accessing Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Arb_MNarkers

Marker Polaritub————————————®

Note: This is the
second Arb menu.
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Narker Polarity #
Marker 1 Polarit
Heg IEEEH

Marker Routingm

Set Markersk

page 48
T poute Connectors
ﬁ
__Marker Range
First Mkr Poin%
Last Mkr Point _MNarker Range 7
20 First Mkr Poin%
frh Torkes s # Skipped Points
v o Last Mkr Point
2 3 . int
Set Marker On
First Point
Set Marker Onl APpPly To HWawveform
Range Of Paints"]

Set Marker Off

Marker 3 Polarit
Heg IEEEH

Marker L Polarit
Heg IEEEH

T

Harker 2 Polarity f€——
Heg IEEEH

For details on each key, use key help
as described on page 40.

The settings in these menus

Narker Routing
Pulse/RF Blank |
one

\j

(Mone)
ALC Hold

(Hone ) "]

\j

Range Of Points®|

Display Waveform
And Markers®|

FREQUEHCY

The display below shows the | and Q components of the waveform, and

APply To Hawveform

the marker points set in a factory-supplied segment.

6.000 000 000 00 &z

ANPLITUDE

-144.00 den

RV VY

Arb Waveform And Markers
UFNL :RANP_TEST_WFTI

FLM=\oO -

Marker points
on first / D/

Sample Point

28

Narker

First
Sample Point

Zoom In

Zoom Out

Zoom In Max

sample point

05/02/2006 10:15

Zoom Out Max

can be stored to the file
header, see page 136.

Narker Routing F

Hone

Marker 1

Marker 2

Marker 3

Marker L

First sample point

/shown on display

These softkeys change
the range of waveform
sample points shown

on the marker display.

Each press of the
softkey changes the
sample range by
approximately a factor
of two.
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a
segment (this example uses the factory-supplied segment, SINE TEST WFM).

1. In the second Arb menu (page 147), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE TEST WFM).
3. Press Display Waveform and Markers > Zoom in Max.

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set points, view the segment (page 148)
and remove any unwanted points. With all markers cleared, the level of the event output signal is OV.
To clear marker points on a segment, the segment must reside in BBG media (page 130).

Clearing All Marker Points
1. In the second Arb menu (page 147), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE TEST WFM).

3. Highlight the desired marker number: Press Marker1234.

4. For the selected marker number, remove all marker points in the selected segment:
a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of the
waveform. The factory-supplied waveform (SINE TEST WFM) contains 200 samples. To clear all
set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10—20. This
makes it easy to see the affected marker points. The same process applies whether the existing points
are set over a range or as a single point (page 149).°

1. In the second Arb menu (page 147), press Marker Utilities > Set Markers, then select Marker 1.

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than or equal to the
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this
example, 17):
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Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

. . Arb Uaveform And Markers
This turns off all marker points for UFI1 :STHE_TEST_UFN
the active marker within the range I
set in Steps 2 and 3, as shown at 0
right. %
How to view markers is described E
on page 148. 1 Sample Point 28

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 148, but set both the first
and last marker point to the value of the point you want to clear. For example, if you want to clear
a marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 130).

When you set marker points, they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set marker points within a segment, view
the segment (page 148) and remove any unwanted points (page 148).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 147), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker1234

4. Set the first sample point in the range (in this example, 10):
Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends
on sample point 20, as shown in the following figure.

Arb Waveform And Markers
UFN1:STHE_TEST_UFNI

FwMe O H

1 Sample Point 28

How to view markers is described on
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Placing a Marker on a Single Point
On the First Point

1.
2.
3.

In the second Arb menu (page 147), press Marker Utilities > Set Markers.
Highlight the desired waveform segment.

Select the desired marker number:
Press Marker1234.

Press Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in Step 3.

On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 149, but set both the
first and last marker point to the value of the point you want to set. For example, if you want to set
a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped
points) between each marker. You must set the spacing before you apply the marker settings; you
cannot apply skipped points to a previously set range of points.

1.

2
3.
4

8.

This causes the marker to occur on
every other point (one sample point is
skipped) within the marker point range,
as shown at right.

How to view markers is described on
page 148.

One application of the skipped point

Remove any existing marker points (page 143).
In the second Arb menu (page 147), press Marker Utilities > Set Markers.
Highlight the desired waveform segment.

Select the desired marker number:
Press Marker1234.

Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

Set the last marker point in the range. (The last marker point value must always be less than or
equal to the number of points in the waveform, and greater than or equal to the first marker
point, in this example, 25):

Press Last Mkr Point > 25 > Enter.

Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

Press Apply To Waveform > Return.

Arb Waveform And Markers
UFN1:STHE_TEST_UFNI

FwMe O H

1 Sample Point 28

feature is the creation of a clock signal
as the EVENT output.

150

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Using Waveform Markers

Viewing a Marker Pulse

When a waveform plays (page 135), you can detect a set and enabled marker’s pulse at the rear
panel event connector/Aux I/O pin that corresponds to that marker number. This example
demonstrates how to view a marker pulse generated by a waveform segment that has at least one
marker point set (page 149). The process is the same for a waveform sequence.

This example uses the factory-supplied segment, SINE TEST WFM in the dual ARB Player.
Factory-supplied segments have a marker point on the first sample point for all four markers, as
shown.

Arb Waveform And Markers
Marker points on UFN1 :SIHE_TEST_UFH
first sample point of I

waveform segment

FLrde

3

1 Sample Point 28

How to view markers is described on page 148
In the first Arb menu (page 129), press Select Waveform.
Highlight the SINE TEST WFM segment and press Select Waveform.
Press ARB 0ff On to On.
Connect the Agilent MXG’s rear-panel Q OUT output to the oscilloscope’s channel 1 input.

A e

Connect the signal generator’s rear-panel EVENT 1 output to the oscilloscope’s channel 2 input.

When marker 1 is present, the Agilent MXG outputs a signal through EVENT 1 as shown in the
following example.

QouTt

Marker pulse on the Event 1 signal.

T [eem  HIE
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the Marker
Utilities menu) either before or after setting the marker points (page 149), setting a marker function
before you set marker points may change the RF output. RF Blanking includes ALC hold (described
on page 144, note Caution regarding unleveled power). The signal generator blanks the RF output
when the marker signal goes low. This example is a continuation of the previous example, Viewing a
Marker Pulse.

1. Using the factory-supplied segment SINE TEST WFM, set Marker 1 across points 1-180 (page 149).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:
In the second Arb menu (page 147), press Marker Utilities > Marker Routing > Pulse/RF Blank > Marker
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Marker Polarity = Positive

: When marker polarity is positive (the default
RF Signal setting), the RF output is blanked during the off
marker points.
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Marker Polarity = Negative

When marker polarity is negative, the

RF output is blanked during the on marker

points
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.
1. In second Arb menu (page 147), press Marker Utilities > Marker Polarity.
2. For each marker, set the marker polarity as desired.

e The default marker polarity is positive.

* Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 143.

As shown on page 152:
Positive Polarity: On marker points are high (=3.3V).
Negative Polarity: On marker points are low (0OV).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed
to the rear-panel EVENT output (described in “Rear Panel Overview - MXG N5161A/62A1/81A/82A”
on page 15) corresponding to that marker number. For a waveform sequence, you enable or disable
markers on a segment-by-segment basis; this enables you to output markers for some segments in a
sequence, but not for others. Unless you change the sequence marker settings or cycle the power, the
marker setting for the last segment edited in the sequence applies to all segments in the next
sequence that you build. For information on building a waveform sequence, see “Creating a Sequence”
on page 133.
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Figure 8-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

-
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s
markers independently. You can enable or disable the markers either at the time of creating the
sequence or after the sequence has been created and stored. If the sequence has already been stored,
you must store the sequence again after making any changes. Enabling a marker that has no marker
points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker
Points in a Waveform Segment” on page 149. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 130).
2. From the second Arb menu, press Waveform Sequences.
3. Highlight the desired waveform sequence.
4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.
5. Toggle the markers:
a. Highlight the first waveform segment.
b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.
Press Return > More > Name and Store.

Either rename the sequence using the text entry keys (see page 131) or just press Enter to save
the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory-supplied waveform segments; a
factory-supplied segment has a marker point on the first sample for all four markers. In this
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and
markers 3 and 4 are enabled for the third segment.

rossiE e e
Seament On Sequence On |(UNSTORED) UHTIT
(1/1) BBG Media Int fiedia [(1/1) llaveform _Reps Sequence marker column
RAMP_TEST_HFH SEQ1 HFML:SINE_TEST_LIFT
STHE_TESTUFH  SINE100+RHP200 LF11: STNE_TEST_LFM UEEES [P &

This entry shows that markers
3 and 4 are enabled for this
segment.

LIFM1:SINE _TEST LIF

For each segment, only the markers enabled for that segment produce a rear-panel auxiliary output
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.
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Using Waveform Markers

Using the EVENT Output Signal as an Instrument Trigger

For details on each key, use key help as described on page 40.

One of the uses for the EVENT

output signal (marker signal) is to Mode |

trigger a measurement instrument. ) The settings in this menu

You can set up the markers to start J‘ o can be stored to the file

the measurement at the beginning e T e header, see page 136.

of the waveform, at any single point on #

in the waveform, or on multiple Dual AREM—B> Arb Setup 7

points in the waveform. To optimize lame e AFE Sample Clock | Sample
the use of the EVENT signal for RE 125.0000000001Hz | ate
measurements, you may also need ARE Setupel > e Noise setting
to adjust the sample rate. The —_— Setup*
location of the sample rate setting . Feal-t.i

is shown in the figure at right. Tho-Torew N e

The EVENT output signal can exhibit jitter of up to #4 ns on the rising and falling edge. This jitter
can be minimized in either of two ways.

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can
be represented exactly on the display.
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on.

If the result cannot be represented exactly on the display, jitter will be present.
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns.
For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz
provides a marker every 4 us. Because 4 us is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample

rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the
original waveform with a sample rate change, you will have to also recalculate the sample values. The
following figures illustrate the marker signal jitter and its affect on the waveform.

EVENT output signal exhibits jitter Waveform appears to exhibit jitter when The jitter is gone with
due to a non-optimal sample rate triggered using EVENT signal with jitter. an optimal sample rate

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal
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Triggering a Waveform

Triggering a Waveform

Figure 8-7 Triggering Softkeys

Mode > Dual ARB ArD

ARE
[ OFf Q]

Select
Haveform

ARE Setupk

Trigoer Tupe
{Cont inuons , M——Page 159

Free Run.

+  page 160
fMore 1 of 2 N

For details on each key, use key help
as described on page 40.

Triggers control data transmission by controlling when the signal generator transmits the modulating
signal. You can configure trigger settings so that data transmission occurs once (Single mode),
continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another,
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages
set to values other than zero.

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF
output. The Arb will present the idle IQrms value of the next Arb waveform to the I1Q modulator.
This ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a
trigger. When that trigger is received, the Arb begins playing the waveform and the modulated RF
carrier exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:
* Type determines the behavior of the waveform when it plays (see Trigger Type on page 159).

¢ Source determines how the signal generator receives the trigger that starts the modulating
waveform playing (see Trigger Source on page 160).

158 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Triggering a Waveform

Trigger Type

Type defines the trigger mode: how the waveform plays when triggered.

Mode > = Immediately triggers and plays the waveform; triggers
Dual ARB > Lontinuous fode received while the waveform is playing are ignored.
Trigger Type fArb_irigoer 7 Free Run
Continuous > . . .
(Free Run)?”| . Plays the waveform when a trigger is received;
Trigger & Run | subsequent triggers are ignored.
Sinoles
Feset. & Run
Seoment. AdvanceM Plays the waveform when a trigger is received; subsequent
\W triggers restart the waveform.
Gatedy
. * Ignores triggers
W A segment in a sequence plays received while a
once, ignoring the repetition Single Hode .~ waveform is playing.
setting, after which the dual ARB
Gated Hode pllayer stops and wait§ for a Mo Retriogger Atrigger received while
et L trigger before advancing to the a waveform is playing
Seo Advance Tiode next segment. The next segment ] waits until the current
then plays to completion. Buffered Trio $—— iveform completes,
g g Sinol . . . . then plays the waveform
Act.ive Hidh nate If a trigger is received while a oncepmgre
segment is playing, the segment Restart on Trig :
Cont inuous plays to completion. The dual A trigger received while
ARB player then advances tothe S L] the waveform is playing
next segment and plays that

immediately restarts the

The waveform stops during the inactive
waveform.

state of the trigger source, and plays
during the active state.

segment to completion.

A segment in a sequence plays continuously until the waveform receives another trigger.

If a trigger is received while a segment is playing, the segment plays to completion. The
dual ARB player then advances to the next segment and plays that segment continuously.

For details on each key, use key help
as described on page 40.

¢ Continuous mode repeats the waveform until you turn the signal off or select a different waveform,
trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

¢ Single mode plays the waveform once.

¢ Segment Advance mode plays a segment in a sequence only if triggered. The trigger source controls
segment- to- segment playing (see Example: Segment Advance Triggering on page 161). A trigger
received during the last segment loops play to the first segment in the sequence.

¢ Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and
stops playing the waveform in response to an externally applied gating signal. See Example: Gated
Triggering on page 162.
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Triggering a Waveform

Trigger Source

Mode >
Dual ARB >
Trigger Source

¢

Arb Trigger .~

Trigger Source
(Ext)

» [ Arb Trigger 7

Ext Source Trigoer Key
(Patt Trig In 13 7| Ext Trig Source
. Patt Trig In BNC connector
Ext Polarity Neg = the signal generator Patt Trig In 1 /= .. pagge 19) i
Pos responds during the trigger signal
low state.
Ext [elay \ Patt Trig In 24— Aux I/O connector (see Ext
an Pos = the signal generator page 20)

responds during the trigger signal
Ext Delay Time high state. W
1.00000000 msec

For details on each key, use key help
as described on page 40.

External Trigger Polarity
¢ In Continuous, Single, and Segment Advance modes, use the ExtPolarity softkey to set the external
trigger polarity.

* In Gated mode, the Active Low and Active High softkeys (page 159) determine the external
trigger polarity.
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Triggering a Waveform

Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence.
This type of triggering ignores the repetition value (page 134). For example if a segment has
repetition value of 50 and you select Single as the segment advance triggering mode, the segment still
plays only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 133.

1.
2.

Preset the signal generator.

Configure the RF output:

e Set the desired frequency.

¢ Set the desired amplitude.

* Turn on the RF output.

Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.
c. Press Select Waveform.

Set the triggering as follows:

e Trigger Type: continuous Segment Advance
Press Trigger Type > Segment Advance > Continuous.

e Trigger source: Trigger hardkey
Press Trigger Source > Trigger Key.

Generate the waveform sequence:
Press ARB Off On until On highlights.

(Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the
oscilloscope so that you can see the signal.

Trigger the first waveform segment to begin playing continuously:
Press the Trigger hardkey.

Trigger the second segment:
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment
to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first
segment in the waveform sequence to start when the last segment finishes.
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Triggering a Waveform

Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear-panel PAT TRIG IN
connector, as shown in the following figure. This connection is applicable to all external triggering
methods. The optional oscilloscope connection enables you to see the effect that the trigger signal
has on the RF output.

Function Generator
-~
I (€]
pooooooog o
Ooooooos o
Oscilloscope
——
RF OUTPUT
= © goc 090
E Channel 1 E Channel 2
i i
2. Preset the signal generator.
Configure the RF output:
* Set the desired frequency.
* Set the desired amplitude.
e Turn on the RF output.
4. Select a waveform for playback (sequence or segment):
a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.
5. Set the triggering as follows:
e Trigger type: Gated
Press Trigger Type > Gated.
* Active state: Low
Press Active Low.
* Trigger source: External
Press Trigger Source > Ext.
* Input connector: Rear panel Patt Trig In BNC
Press Ext Source > PattTrigin 1.
6. Generate the waveform: Press Return > ARB Off On until On highlights.
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Triggering a Waveform

7. On the function generator, configure a TTL signal for the external gating trigger.
8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external
triggering signal. You will see the waveform modulating the output during the gate active periods
(low in this example).

The following figure shows an example display.

Modulating Waveform RF Output

B
MW~ -

-

Externally Applied Gating Signal
Gate Active = Low
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Triggering a Waveform

Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel
BNC connector

FUNCTION
GENERATOR
N

pooooooog o
ooooooog ¢

1. Connect the signal generator to the function generator as shown above.

PAT TRIG

SIGNAL GENERATOR

2. Configure the RF output:

* Set the desired frequency.
¢ Set the desired amplitude.
* Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform:
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC
Press Ext Source > PattTrigin 1.

d. External Trigger Polarity: positive
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms
Press More > Ext Delay until On highlights
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

* Waveform: 0.1 Hz square wave
¢ QOutput Level: 3.5V to 5V.
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Clipping a Waveform

Basic Digital Operation (Option 651/652/654)

Clipping a Waveform

Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in
spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function
enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its
highest peak, thereby reducing spectral regrowth.

¢ How Power Peaks Develop on page 166

* How Peaks Cause Spectral Regrowth on page 168

* How Clipping Reduces Peak-to- Average Power on page 169

e Configuring Circular Clipping on page 172

¢ Configuring Rectangular Clipping on page 173

Figure 8-8 Clipping Softkeys

Mode > Dual ARB > More —»

For details on each key, use key help

as described on page 40.

Arb

Haveform,|
Sequences

Laveform,

IFN Utilities 7

Plot,
cCoF

Utilities"|

Marker,
Utilities

Header,
Utilities

W

Y

Scale Haveform,
ata

Arb Clippim

Clipping Tupe
EECXIN (17,01

Clip 1I+j0l To
100.0 %

E-Pack Licensingk

P W N

APply To Hawveform

Available only when
clipping type =] , |Q|
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Clipping a Waveform

How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop
as you construct a signal.

Multiple Channel Summing

1I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an
unusually high power peak (positive or negative) occurs in the summed waveform.

Because the high and low states of the bits in channel waveforms are random and generally result in
a cancelling effect, high power peaks occur infrequently with multiple channel summing,.

Uy

Multiple Channels to be
Summed Into One Tor Q
Waveform

i

Summed Ior Q Waveform
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Clipping a Waveform

Combining the | and @ Waveforms
When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the magnitude

of the RF envelope is f12+Q2, where the squaring of I and Q always results in a positive value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q waveforms
do not cancel each other, but combine to create an even greater peak.

4V
| _|_
[ and Q Waveforms
to be Combined
Q a— Q
RY 1
——— —— i I
[ | 4 1
I
4 566V 4V
1
4 1
566V |
Resultant Baseband TV T
Waveform Determined Vector Representation
by A 12 02
yNT*Q of High Peak
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How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high
peak- to-average power ratio, as illustrated in the following figure.

———————————————— Peak Power

Average Power

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that develops
on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see
the following figure). Clipping provides a solution to this problem by reducing the peak-to-average
power ratio.

Spectral
Regrowth

RF Signal Adjacent Band
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How Clipping Reduces Peak-to-Average Power

You can reduce peak-to-average power, and consequently spectral regrowth, by clipping the waveform.
Clipping limits waveform power peaks by clipping the I and Q data to a selected percentage of its
highest peak. The Signal Generator provides two methods of clipping:

e (Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 8-9, the clipping level is constant for all phases of the vector and appears as
a circle in the vector representation.

* Rectangular clipping is independently applied the I and Q data.

As shown in Figure 8-10 on page 170, the clipping level is different for I and Q, and appears as
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that reduces
spectral regrowth but does not compromise the integrity of the signal. The two complementary
cumulative distribution plots in Figure 8-11 on page 171 show the reduction in peak-to-average
power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is
clipped). The peaks can often be clipped without substantially interfering with the rest of the
waveform. In many cases, data that might otherwise be lost in the clipping process is retained
because of the error correction inherent in the coded systems. If you apply excessive clipping,
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that
reduces spectral regrowth while retaining needed data.

Figure 8-9 Circular Clipping

Peak Power Without Clipping -~
(Clipping Setto 100%) - ~
/ \’ g QT > ~
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! \
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\ 1
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Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 169



Basic Digital Operation (Option 651/652/654)
Clipping a Waveform

Figure 8-10 Rectangular Clipping
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Figure 8-11 Reduction of Peak-to-Average Power
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Clipping a Waveform

Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak-to-average power
ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped equally).
For more information about circular clipping, refer to “How Clipping Reduces Peak-to- Average Power”
on page 169.

CAUTION Clipping is non-reversible and cumulative. Save a copy of the waveform file before you
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP TEST WFM.
3. Press Copy File.
4. Name the copy (in this example, the name is MY TEST CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY TEST CIRC).
3. Create the CCDF plot: Press Plot CCDF.
4

Observe the shape and pOSitiOIl of Example waveform curve before clipping

the waveform’s curve (the dark line /
I:IJHPLEHEHTFIR'.-I CUMULA IUE IJISTRIBUTIEIN

in the example at right). p w00z EFORA: /T
L2_50% 0 dB
5. Activate circular clipping: Press AT ELE (T o 10
Return > Clipping > Clipping Type until 0 i; == dg p 12
[1+jQ| highlights. u'.]f]gi% - ; 0_1:4
6. Set circular clipping to 80%: Peak  L.7 dB ! l]ul-]gi;
Press Clip |1+jQ| To > 80 > %. T PERK/AUG_dB 10.0

7. Apply 80% clipping to the I and Q
data: Press Apply to Waveform.

8. Create the CCDF plot (see the Example waveform curve after circular clipping
example at right): Press Plot CCDF.

I:IJNPLENEHTFIR'.-I UNMULATIVE DISTRIBUTION
9. Ol.)sel'fve the waveform’s curve after 1S, 003 0 d8 E 1003 RUEFRN: ¥ TEST_CIRC
clipping. 10% g 10%
17 .
Note the reduction in ikE d 0 i:
peak-to-average power relative to the =001 & u.l-]ﬁ
previous plot. ¥ oo
0 PEAK/AUG_dB 10.0

172 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Clipping a Waveform

Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data
independently. For more information about rectangular clipping, refer to “How Clipping Reduces
Peak- to- Average Power” on page 169.

CAUTION Clipping is non-reversible and cumulative. Save a copy of the waveform file before you
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP TEST WFM.
3. Press Copy File.
4

Name the copy (in this example, the name is MY TEST REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY TEST REC).
3. Create the CCDF plot: Press Plot CCDF.
4

Observe the shape and pOSitiOIl of Example waveform curve before clipping

the waveform’s curve (the dark line

/
in the example at right). . fDnPLEnENLIgﬁ'EIFE%IthH_TZ[EUSIET DISTRIBUTION
L2507 0 dB %
5. Activate rectangular clipping: Press AT ELE (T o T
Return > Clipping > Clipping Type until 0 if == dg p 13
[11.1Q@] highlights. u'.]f]gi% - d8 ; 0.17
6. Set 80% clipping for the I data: Press Peak  L.7 dB I l]ul-]gi;
Clip |1] To > 80 > %. ] PERR/AUG_dB 10.0

7. Set 40% clipping for the Q data: Press
Clip |Q]| To > 40 > %.

Apply the rectangular clipping to the waveform: Press Apply to Waveform.

Create the CCDF plot (see the Example waveform curve after rectangular clipping
example at right): Press Plot CCDF.
COMPLEMENTARY/CUNULAT IVE DISTRIBUTION
10. Ol.)se?ve the waveform’s curve after 49, 503 0 d8 E 1003 UAUFFORN: M¥_TEST_REC
Chpplng- 109 =---—-dB | B 10%
. . 1z --—-di | A 1%
Note the reduction in dkE =85 017
. = tr] ——— L - e
peak.- to-average power relative to the e o @ I oow
previous plot. Y 0.001%
0 PEAK/AVG _dB 10.0
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Scaling a Waveform

Scaling a Waveform

The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which
may create a DAC over-range error condition. This chapter describes how DAC over-range errors
occur and how you can use waveform scaling to eliminate these errors.

e How DAC Over-Range Errors Occur on page 175

e How Scaling Eliminates DAC Over-Range Errors on page 176

¢ Agilent MXG waveform scaling on page 177 and page 178:

— Waveform runtime scaling to scale a currently- playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a non- playing
waveform file in BBG media

Figure 8-12 Scaling Softkeys
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How DAC Over-Range Errors Occur

The signal generator uses an interpolator
filter when it converts digital I and Q
baseband waveforms to analog
waveforms. Because the clock rate of the
interpolator is four times that of the
baseband clock, the interpolator
calculates sample points between the
incoming baseband samples and smooths
the waveform as shown in the figure at
the right.

The interpolation filters in the DACs
overshoot the baseband waveform. If a
baseband waveform has a fast-rising
edge, the interpolator filter’s overshoot
becomes a component of the interpolated
baseband waveform. This response
causes a ripple or ringing effect at the
peak of the rising edge. If this ripple
overshoots the upper limit of the DAC
range, the interpolator calculates
erroneous sample points and is unable
to replicate the true form of the ripple
(see the figure at the right). As a result,
the signal generator reports a DAC
over-range error.

Basic Digital Operation (Option 651/652/654)
Scaling a Waveform

INTERPOLATED SAMPLES

BASEBAND SAMPLES

OVER-RANGE SAMPLES CANNOT
BE INTERPOLATED CORRECTLY

L

DAC RANGE

Z

BASEBAND SAMPLES
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Basic Digital Operation (Option 651/652/654)
Scaling a Waveform

How Scaling Eliminates DAC Over-Range Errors

Scaling reduces the amplitude of the baseband
waveform while maintaining its basic shape and
characteristics, such as peak-to-average power
ratio. If the fast-rising baseband waveform is
scaled enough to allow an adequate margin for
the interpolator filter overshoot, the interpolator
filter can calculate sample points that include
the ripple effect and eliminate the over-range
error (see the figure at the right).

Although scaling maintains the basic shape of
the waveform, excessive scaling can compromise
waveform integrity. For example, if the bit
resolution becomes too low the waveform
becomes corrupted with quantization noise. To
achieve maximum accuracy and optimize
dynamic range, scale the waveform no more
than is required to remove the DAC over-range
error. Optimum scaling varies with waveform
content.

SAMPLES WITHIN DAC RANGE
INTERPOLATED CORRECTLY

L

DAC RANGE

<

N/

BASEBAND SAMPLES
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Basic Digital Operation (Option 651/652/654)
Scaling a Waveform

Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You can
apply runtime scaling to either a segment or sequence, and set the scaling value either while the ARB
is on or off. This type of scaling is well suited for eliminating DAC over-range errors. Runtime scaling
adjustments are not cumulative; the scaling value is applied to the original amplitude of the
waveform file. There are two ways to save the runtime scaling setting: by using the save function
(page 68) and by saving the setting to the file header (page 138). Saving to the file header saves the
value with the waveform file, saving with the Save function stores the value as the current
instrument setting.

Use this example to learn how to scale the currently selected waveform.
1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB 0ff On until On highlights.
Set the Waveform Runtime Scaling value:
a. Press ARB Setup > Waveform Runtime Scaling.
b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is no
single value that is optimal for all waveforms. To achieve the maximum dynamic range, use
the largest scaling value that does not result in a DAC over-range error.

c. Press Return.
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Scaling a Waveform

Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform data
and only applies to waveform segments stored in BBG media. You scale the waveform either up or

down as a percentage of the DAC full scale (100%). If you scale your waveforms using this method,

you may also need to change the waveform runtime scaling value to accommodate this scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so that
they conform to the desired scaling value. When you initiate scaling, the signal generator performs
the following actions:

¢ locates the waveform file’s absolute peak sample value

* determines its current percentage of full scale

e calculates the ratio of the desired scale value to the determined absolute peak sample scale value
¢ multiplies each sample in the waveform file by this ratio

Peak sample

DAC full scale 100%

» .‘../. ....................... 85% of full scale—Prescaling
e = Samples e
L :

. . .4 = = 60% of full scale-Post scaling
- : I R
e : Lo *
L . - ;
At - : UEL *
- Original ramp waveform PO » Scaled ramp waveform :
- [} v *

Scaled sample value = scaling ratio x prescale sample val

Scaling ratio = desired scale val / current scale val
=60/85
=0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data occurs
almost every time you reduce or increase the scaling value, and causes quantization errors.
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor.
You lose data when either the signal generator rounds fractional data down or the scaling value is
derived using the results from a power of two. This means that scaling a waveform in half (power of

two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not
correctable and may cause waveform distortion. It is always best to make a copy of the original file
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses the
factory-supplied waveform RAMP TEST WFV, it is the same for any waveform file.

Copy a Waveform File
1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP TEST WFM.
3. Press Copy File.
4

Name the copy (this example uses the name MY TEST SCAL) and press Enter.

178 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Basic Digital Operation (Option 651/652/654)
Scaling a Waveform

Apply Scaling to the Copied Waveform File

CAUTION This type of scaling is non-reversible. Any data lost in the scaling operation cannot be
restored. Save a copy of the waveform file before scaling.

1. Open the DUAL ARB Waveform Utilities menu:
Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, MY TEST SCAL).
Set and apply a scaling value (in this example 70% scaling is applied):
Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.
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Setting the Baseband Frequency Offset

The baseband frequency offset enables you to shift the baseband frequency up to #50 MHz within the
BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband generator option.
While the following figure shows how to access the control using the Dual ARB player, the location of
the Baseband Frequency Offset softkey within each arb format, through the ARB Setup softkey, is the same
as for the Dual ARB player.

Figure 8-13 Baseband Frequency Offset Softkey for the Dual ARB Player

Mode The settings in this menu
can be stored to the file
_J header, see page 136.

JL Arb $
Nodulation Hode ARE
on Arb_Setup A
. ARE_Sample Clock
=L, (e R 580, 000000kFz
Haveform
Cusiay Heal—TlrreSSEEg’ page 211
ARE SetupM >
Feal-Timag page 211
Trigger Tupe Phase Moise Setup™
(EDEtinuausib
ree Run Lawef RuAt i
Tho-Tonak ueTarm 532112‘3 page 174
52.00 %
Mult itanes e Tor T— e
—— Manual

fore 1 of 2 Hore 1 of 2
> Arb_Setup &

Easeband
Freguency Of fset
0.000 Hz

Frequency offset setting.

Multi-BBG Sunc
Setupk
(Off)

For details on each key, use key help
as described on page 40. —page 181

Common uses for the offset feature include:

e offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
¢ sum the baseband signal with external I and Q inputs to create a multicarrier signal
* use the signal generator’s I/Q signal as an IF

NOTE Changing the baseband frequency offset may cause a DAC over range condition that
generates error 628, Baseband Generator DAC over range. The signal generator
incorporates an automatic scaling feature to minimize this occurrence. For more information,
see “DAC Over-Range Conditions and Scaling” on page 181.

The baseband frequency offset value is one of the file header parameters (page 136), which means
you can store this value with the waveform. When you select a waveform with a stored frequency
offset value, the signal generator changes the current value to match the stored file header value. If
there is no stored baseband offset frequency value for the current waveform, the signal generator
uses the last set frequency offset value.

You can also use the Save function (page 68) to store this value as part of the signal generator setup.
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When you Recall a setup stored with the Save function, the baseband frequency offset value becomes
the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the
factory supplied waveform, SINE TEST WFM available in the Dual ARB Player. To view the output for
this example, connect the RF OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE_TEST WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.
Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press ARB Setup > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the
following figures.

Modulated carrier with 0 Hz Modulated carrier with 20 MHz )
baseband frequency offset baseband frequency offset Modulated RF signal

;-

LO/carrier feedtt

R

MJN\WAWNMMWM s

Mt

LRV e e

Spectrum analyzer set to a span of 100 MHz

DAC Over-Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a
DAC over-range condition, which causes the Agilent MXG to generate an error. To minimize this
condition with the frequency offset feature, the Agilent MXG incorporates an automatic DAC
over-range protection feature that scales down the I/Q data by I/square root of 2 when the offset is
something other than zero. Because it can scale the data by more than what is actually need, it
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typically decreases the dynamic range of the waveform. This is especially noticeable when using a
constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over-range feature can be turned off. When on, it is active
for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual
ARB DAC over-range protection feature is located in the key path as shown in Figure 8-14.

Figure 8-14 Dual ARB DAC Over-Range Protection Softkey Location

Nodulation Hode ArD

Dual ARBs— ARE ___fArb Setup /|
= & Arb Setu
== e BBl
Custom : :
LOm, | Select
Modu Iat. ion VaveForm®

Feal-Time AWGN
Setup®
ARE Setupkp—®

Real-Time |
TE=TTeer Tricoer Tupe FPhase Moise Setup
(Cont inuous , M -
Free Run) Lawe form Funt ime V\I_he_n the DAC over-range protection is off,
Scaling eliminate over-range conditions by
Multitones . w decreasing the scaling value (see “Setting
Waveform Runtime Scaling” on page 177).
—_——, Modulator Atten
Hore 1 of 2~ .51 dB
[ Hore 1 of 2 | Marual
More 1 of 2
Arb Setup 7
Baseband
Freguency Offset
0.000 Hz
Multi-BEG Sunc Default setting is On. Available only
SetupM when Real-Time Phase Noise is on
i (Off) (see page 215).
Avallat_)le only when X Turn off when you want to manually
Real-Time Phase Noise control scaling while using the
is on (see page 215). baseband frequency offset feature.
Manually adjust the scaling using the
N Waveform Runtime Scaling softkey
above.

For details on each key, use key help
as described on page 40.

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over-range conditions.
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1/Q Modulation

The following factors contribute to the error vector magnitude:

Basic Digital Operation (Option 651/652/654)
1/Q Modulation

¢ Differences in amplitude, phase, and delay between the I and Q channels

e DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides
adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 58.

Figure 8-15 1/Q Display and Softkeys

FREQUEHCY

This panel displays the current status and settings I/0 Source
of the I/Q adjustments. Use the Page Up and
This panel displays the current Page Down keys to scroll through these / Internal
settings for the 1/Q signal routing parameters. Grey indicates an inactive (off) -
and 1/Q correction optimized path. adjustment. =
External
ANPLITUDE T
— 1/0 Sum
6.000 000 000 00 &z | -144.00 den y
1/0 Source, PPN Py

I/0 Routing & Optimfzation
/

I/0: OFF 7

BE GEM |

cInternall)”®

:

[ Optimized Path

» I/0 0UT

I/0 Correction
Optimized PathM
(RF Output

reflected in the

I/0 Adjustments
(OfFFIY

page 186 1/Q Routing &

1/0 Calibrations—page 187

More 1, of 2

1/0

s

Int Phase
Polarity
Invert

Burst_Envelope
I On

R NP W

Inverts an internally generated Q signal, so that the | component lags the

Q component by 90 degrees.

Used only with internally generated,
bursted modulation formats.
Enables/disables the RF burst modulator.

For details on each key, use key help

as described on page 40.

I1/0 Optimization

RF Output

Ext I/0 Output

Each path requires different optimization values;

when you select a path, you are selecting the

unique optimization values required by that path.

The signal generator applies the selected
optimization values to both paths, which impairs
the unselected path.

These selections are

Optimization graphic.

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide

183



Basic Digital Operation (Option 651/652/654)
1/Q Modulation

Using the Rear Panel | and Q Qutputs

NOTE The rear-panel I and Q connectors only output a signal while using the internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated I and
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in
analog form. You can use these rear panel I and Q signals to:

¢ drive a system’s transmitter stage
¢ test individual analog I and Q components such as an I/Q modulator
¢ route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform

1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path

1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal
generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to the
rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to another
signal generator. The MXG has front panel connectors, I Input and Q Input, for this purpose.

2. Press 1/Q > 1/Q Correction Optimized Path > Ext 1/Q Output.

When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized T/0
i imizall I
I/0 Routing & Optimization - lﬂﬁ

BB GEN | ¥ 1/0 0UT HE:—,E?HEE?'
I/0 Correction
EXT IN RF ouT Optimized Pathm

(RF Output)
E Optimized Path B
I/0_Optimization 7| (O F 2

:

RF Output

Rear-panel 1/Q path optimized

<

I/0 Routing & Dptimization Ext I/0 Output

AAJ“““~‘~“’~M

[ Optimized Path
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Configuring the Front Panel Inputs

Basic Digital Operation (Option 651/652/654)
1/Q Modulation

The signal generator accepts externally supplied analog I and Q signals through the front-panel I
Input and Q Input. You can use the external signals as the modulating source, or sum the external

signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.

a. Connect an analog I signal to the signal generator’s front-panel I Input.

b. Connect an analog Q signal to the signal generator’s front-panel Q Input.

2. Set the signal generator to recognize the front-panel input signals:

* To Modulate onto the Carrier

Press 1/Q > 1/Q Source > External.

Signal generator display: both paths are calibrated
when the 1/Q Correction Optimized Path is set to
Ext I/Q Output (see page 184)

Note: when the optimized path is set to RF, only the
RF Out path is calibrated.

¢ To Sum and Modulate onto the Carrier
Press 1/Q > 1/Q Source > Sum.

I/0 Routing & Optimization

EXE e T

[ Optimized Path

To select and play a waveform for the BB GEN path, see page 131.

Signal generator display: both RF paths are calibrated
when the I/Q Correction Optimized Path is set to
RF Output (see page 184)

I/0 Routing & Optimization

[ Optimized Path

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear-panel I and Q

outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator:

Press 1/Q0ff On to On.

4. Configure the RF output:
a. Set the carrier frequency.
b. Set the carrier amplitude.

c. Turn the RF output on.
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1/Q Adjustments

Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

1/Q > 1/Q Adjustments

I1/0 Adjustments
I/0 Adjustments
0n

the ARB. See page 139. BB I/0 Adj

I Offse
Adjusts the | signal amplitude relative to the Q 0.000 ¥
signal amplitude. Use this as an internal
impairment, or to compensate for differences in 0 Offset
signal path loss that occur due to path 0.000 X

irregularities in the external | and Q output =
cabling. I/0 Gain

The DC offset values are calibrated relative to
the RMS waveform voltage being played out of

Ealance
0.000 d&

Internal Baseband
Adjustments”]

External Input

Ext Out I/0 Adj

I/ D%\%ngnﬁnode
et Range
ﬁm Fine
Common Mode

I/0 Offset
0.0000 W

I Offset
Available only 0.0000 W
with Option 1EL Diff. Mode

Offsets are typically used to either reduce carrier leakage, or to create
an impairment that simulates carrier leakage.

Common Mode I/Q Offset Range

This changes the adjustment range of the Common Mode 1/Q Offset
from Coarse (Default) to fine or vice versa. The Coarse range
corresponds to the default value of + 2.5V. The Fine range corresponds
to a value of + 100 mV.

Common Mode I/Q Offset

This adjusts the DC offset of both | and Q signals simultaneously.
Diff Mode | Offset

This adjusts the DC offset level of the | and I-bar output signal. | and
I-bar cannot be adjusted independently.

Diff Mode Q Offset

This adjusts the DC offset level of the | and I-bar output signal. | and
I-bar cannot be adjusted independently.

! L - -
Ad justments® Ext_In 170 Ad
Extern?lD%?Du%
S
External Output
Adjustments®| 0.000 ¥
External Input
Lt 0 Offset
Quadrature
Anole Adjustment
0.0
Y "~"‘~“‘\‘\4mﬂ\‘

Skew is typically used either to create impairments, or to
reduce error vectors on large bandwidth signals.

Provides a relative time delay correction between the | and
Q signals. The different signal paths traveled by the | and Q
Oiff. Mode signals result in time delay differences that show up as an
EVM error in large bandwidth modulated signals.

Adding an equal and opposite time delay (skew) in the 1/Q

0 Offset signals during baseband generation eliminates the time
0.0000 W delay error, correcting for any delays in signals that are
generated in the internal baseband generator.

L Quadrature
Anole Adjustment
0.00 deg

Offsets the phase of the Q signal
relative to the phase of the I signal.
The baseband quadrature
adjustment key is calibrated in units
of degrees. The external input
quadrature adjustment is not
calibrated.

The function provided by this key is
not the same as the function
provided by the 1/Q Skew key.

fore 1 of 2

Available only when a
waveform is playing.

Changes the absolute phase of both the | and Q signals with
respect to triggers and markers.

Positive values add delay and negative values advance the
signals. This value affects both the baseband signal
modulated onto the RF and the external output signals (I and
Q). This setting cannot be used with constant envelope
modulation and it does not affect external | and Q inputs.
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1/Q Calibration

Table 8-2 1/Q Adjustments Uses
I/Q Adjustment Effect Impairment
Offset Carrier feedthrough dc offset
EVM error phase skew
Quadrature Angle
I/Q Images I/Q path delay
1/Q Skew EVM error high sample rate phase

skew or I/Q path delay

I/Q Gain Balance

I/Q amplitude difference

I/Q gain ratio

The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any
latency between the EVENT output signals (marker signals) and the RF output.

17Q Calibration

Use the 1/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected

depends on whether the signal is internally or externally generated.

Correction Internal I and Q | External I and Q
Offset X X
Gain Balance X --
Quadrature Error X X

When you perform an I/Q calibration, that calibration data takes precedence over the
factory-supplied calibration data. The calibration routines improves performance that may degrade
over time or due to temperature changes.
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I/Q > 1/Q Calibration T/0 Calibration 7]

Execute Cal

Calibration Tupe
User  Full

Revert to
Default Cal
Settings

Note

A DC calibration requires the following settings:

*1/Q: On
» Optimized Path: RF Output
* Source: Internal

Multiple Baseband Generator Synchronization

Available only when
Callibration type = User

Deletes any user-generated
calibration data and restores
the factory—supplied
calibration data.

DC optimizes the 1/Q performance for the current
instrument settings, and typically completes in several
seconds. Changing any instrument setting except for 1/Q
adjustments after performing a DC calibration voids the DC
calibration and causes the signal generator to revert to the
factory—supplied calibration data.

Presetting the instrument or cycling power is equivalent to
pressing Revert to Default Cal Setting.

User provides a quicker calibration when a full calibration
is not required. You can limit the calibration by specifying
the calibration start and stop frequencies.

When you limit the calibration to less than the instrument’s
full frequency range, the factory—supplied calibration data
is used for the rest of the range.

Information is retained through a preset or power cycle.

Full takes 5 minutes, executing measurements over the
instrument’s entire frequency range.

Information is retained through a preset or power cycle.

For details on each key, use key help
as described on page 40.

Available in the Dual ARB menu, this feature lets you set up a master/slave system of up to sixteen
Agilent MXGs so that the baseband generators (BBG) synchronize the playing of waveforms. The
system count includes one Agilent MXG to function as the master (see “Equipment Setup” on

page 192).

The MXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common external
LO signal to create phase coherent system. Refer to “Understanding Option 012 (LO In/Out for Phase
Coherency) with Multiple Baseband Generator Synchronization” on page 195 and the Data Sheet.
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Figure 8-16 Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger Softkeys and Menu Location

Note: The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this
process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 190.

Nodulation Hode

Arb Setup 7

Mode
Arb Setup V'
ARE Sample Clock
Dual ARBR 125 D000000G0AH= ; Bag%gang
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see page 130 : 0.000 He
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- Protection
celect Haveform Eunfi;rre Off
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ARE Set HDdUlatTE Stétgg . \
i ¥ ellpe———— .
VRN Hanual A
| _fore 1 of 2 Trigger Tupe _fore 1 of 2 see page 190
i (Eontiguausib
rioger Lin
see page 158 Tri 5 \ BBG sync automatically changes the trigger type to Trigger and Run
FOEEEr ?E;E?- if the current setting is Free Run or Gated. If desired, manually set
y differently on either the master or slaves, or both either before or
Greys out for slave instruments. More 1 of 3 % after configuring the BBG sync setup parameters.

Remains active for the master
instrument.

For details on each key, use key help
as described on page 40.

Free Run and Gated are unavailable choices while using BBG sync.

Master default settings. If

desired, change th

settings after designating the after selecting an instrument

ese

instrument as the master

'

Arb Trigger ~#

Slave default settings. These
settings are not accessible

Note: A setting conflict error occurs
when at the time of the master/slave
selection, the following trigger setting(s)

is true:
as a slave. Master
« Free Run or Gated trigger type
Slave
FRERIGIGoen e « Free Run or Gated trigger type

« Ext Polarity Neg trigger source

Trigoer Source Trigoer Source
(Ext 1Y (Ext 1Y
Ext Source Ext Source
(Patt Trig In 1)* (Patt Trig In 13"
. K Neg is the factory default setting.
Exagégg ExtNgglaﬁ 4 The slave selection changes it to
— Pos. If desired, manually change to
Ext Deloy Ext. Delay Pos prior to selecting as a slave.
an an
Ext Delay Time Ext Delau Time
1.00000000 msec 1.00000000 msec
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Figure 8-17 Multiple BBG Synchronization Front Panel Displays

Master Display and Available Softkeys

HTRE
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7
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Understanding the Master/Slave System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform
generation capability of up to 16 signal generators to within a characteristic value of + 8 ns between
the master and the last slave. This minor amount of delay (*+ 8 ns) can be reduced further to
picosecond resolution by using the 1/Q Delay softkey located in the I/Q menu. To reduce the delay,
check and adjust the BBG signal alignment for each signal generator in the system. For more
information on adjusting the delay, see “I/Q Adjustments” on page 186.

The delay value includes compensation for cables that have less than 1 ns of propagation delay
between the EVENT1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is an
Agilent BNC cable, part number 10502A. The use of cables with greater propagation delay may not
allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the master signal generator sends a one-time event pulse that
propagates through and to each slave in the system. Prior to this event, each slave must recognize
that it is waiting for this event pulse, which occurs during the system configuration (see “Configuring
the Setup” on page 192). In order to properly send the synchronization pulse, the trigger source and
the Dual ARB Player for each signal generator must be turned off.

The master/slave setup does mot incorporate a feedback system between the slaves and the signal
generator selected as the master. After synchronization, if changes occur to the Multi-BBG Sync
Setup menu or a signal generator is added to the system, the master does not automatically
resynchronize the setup. This may cause the signal generators in the system to incorrectly report
their status as In Sync.

The system can also misinterpret other signals as the synchronization pulse, which results in an
incorrect In Sync status. These types of signals include a continuous trigger or an active Marker
routed to the EVENT 1 connector. Improperly connected rear-panel cables can also create a false
status.

You must resynchronize the entire system after making any change in one or all of the Multi- BBG
Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status of
a signal generator. Changes to parameters that are outside of the Multi-BBG Sync Setup menu such
as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have no effect
on the system synchronization. To resynchronize a system, see “Making Changes to the Multiple Sync
Setup and Resynchronizing the Master/Slave System” on page 194.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 189) for each
signal generator. For signal generators selected as slaves, you can only modify the trigger type (with
restrictions). The trigger source is fixed and set to receive a trigger through the rear-panel PAT TRIG
connector. On the master, you can change both the trigger type (with restrictions) and the trigger
source. The trigger source provides three options for triggering the waveforms: external trigger,
front- panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature
changes the trigger settings to what is shown on page 189. When this change occurs, the Agilent MXG
generates a settings conflict error to alert you to the changes. To avoid the error generation,
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appropriately configure the trigger settings prior to selecting a signal generator as the master or
slave.

The system trigger propagates in the same manner as the synchronization pulse initiated by the
master (see System Synchronization). So if it is not turned off during changes to the synchronization
parameters, it can cause a false In Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization
feature is turned off. To play waveforms after disabling the feature, you must either set the trigger
type to Free Run or provide a trigger to start the waveform play back.

Equipment Setup

Figure 8-18 Multiple Baseband Synchronization Setup

Note: To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended
cable for the rear-panel daisy chain connections (see page 191).

If not using the Trigger key, provide an external trigger
source. For information on the PAT TRIG connector,

PAT TRIG l see page 19.
or GPIB
A —— ———————
Master = EEL
. et | P ) e RF OUTPUT
EVENT 1 10MHz Out
- PATTRIG REF IN
: 36 ¢ eIEEREES
1 L= UG s a——w RFOUTPUT
EVENT 1 10MHz Out

PATTRIG 4 REF IN

Slave(s)< 2 e e ouTeUT

There can be 1 to 15 EVENT 1 "10MHz Out

slaves in a setup.
PATTRIG 4 4 REFIN
3 g
e L s a—— RFOUTPUT

.
Configuring the Setup

Set the Common Parameters
Perform the following steps on all signal generators:
1. Set the frequency of the carrier signal.
2. Set the power level of the carrier signal.
3. Select the desired waveform (see page 130).
Do not turn the Dual ARB on.

192 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



5.

Basic Digital Operation (Option 651/652/654)
Multiple Baseband Generator Synchronization

Except for triggering, set the desired waveform parameters such as markers and sample clock.

The baseband synchronization feature limits the trigger selections for both the master and slaves.
If the current trigger settings include unsupported BBG synchronization parameters, the Agilent
MXG generates a settings conflict error and changes the trigger settings. To avoid the settings
conflict error, manually set the trigger parameters as shown on page 189 prior to setting the
multiple BBG synchronization parameters.

Turn on the RF Output.

Set the BBG Synchronization Master Parameters

1.
2.
3.

Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-Bbg Sync Type > Master.
Set the number of slaves using the Number of Slaves softkey.
If desired, modify the trigger parameters (see page 189).

The master signal generator allows the modifications of both the trigger type and the trigger
source.

a. Return to the Dual ARB menu (see page 189).
b. Set the desired trigger type and source.
c. Return to the Multi-BBG Sync Setup menu.

Set the BBG Synchronization Slave Parameters

1.
2.
3.

Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-BBG Sync Type > Slave.
Set the number of Slaves using the Number of Slaves softkey.

Set the slave position that the signal generator occupies.

There can be up to fifteen slaves in a system.

Press the Listen for Sync softkey and verify that Waiting for Sync appears in the Status area of
the display.

If desired, select a different trigger type parameter:
a. Return to the Dual ARB menu (see page 189).
b. Set the desired trigger type.

c. Return to the Multi-BBG Sync Setup menu.

Repeat for each slave signal generator in the system.
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Synchronize the System

Perform this procedure only after setting the parameters for both the master and slave signal
generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple Sync
Setup and Resynchronizing the Master/Slave System” on page 194.

1. On the master, press the Sync Slaves softkey.

NOTE All of the signal generators in the master/slave system must be resynchronized when any
changes are made to the master/slave settings or with the addition of a slave instrument,
even if In Sync appears after pressing the Listen for Sync softkey on the slave instruments.

2. On the front panel displays, ensure that all of the signal generators show In Sync as the Status.

Trigger and Play the Waveform
1. On all Agilent MXGs, press Mode > Dual ARB > ARB 0ff On to On.

2. Start the trigger signal going to the master signal generator.

Making Changes to the Multiple Sync Setup and Resynchronizing the Master/Slave System

If any changes are made to the master/slave parameters or a signal generator (slave unit) is added to
the system, the system must be resynchronized even if In Sync appears in the Status portion of the
display.

1. Turn off the trigger source. If using the Trigger key, there is nothing to turn off.

If the trigger source is on and provides a continuous pulse stream, it may cause the signal
generators to incorrectly display In Sync as the status after pressing the Listen for Sync softkey.

2. On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.

If a signal generator(s) has the Dual ARB on during changes, signal generators further in the
chain may incorrectly display In Sync after pressing the Listen for Sync softkey.

On each of the signal generators, press ARB Setup > More > Multi-BBG Sync Setup.
4. Make the changes in the Multi-BBG Sync Setup menu.

Out Of Sync appears as the status message.

On each of the slave signal generators, press Listen for Sync.

Ensure that all of the slaves’ Status show Waiting for Sync. If In Sync shows as the status,
perform the following steps:

a. Check that the PATTTRIG to EVENT 1 cables are properly connected on the rear-panel.
A disconnected cable can cause a false In Sync status.

b. If the cables are connected, perform steps 1 and 2.

c. Press Listenfor Sync and ensure that Waiting for Sync appears as the status.

On the master signal generator, press Sync Slaves.

Verify that In Sync appears as the status on all master/slave signal generators.

Perform the process “Trigger and Play the Waveform” on page 194.
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Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple
Baseband Generator Synchronization

NOTE This section assumes that the previous section on Multiple Baseband Generator
Synchronization has been read and understood. If not, refer to “Multiple Baseband Generator
Synchronization” on page 188 before continuing.

The MXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common external
LO signal to create a phase coherent system (refer also, to “Multiple Baseband Generator
Synchronization” on page 188).

RF phase coherency may not be needed for general STC/MIMO receiver testing, since a MIMO receiver
perceives any phase differences between the sources as part of the channel conditions and correct for
them. But, RF phase coherency might be desirable for certain applications such as R&D on
beamforming systems.

Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

The Agilent BNC cable, part number 10502A, is the recommended cable for the standard multi- BBG
synchronization setup, and is recommended for Option 012 too (see also Figure 8-18 on page 192).
Additionally, for the 2x2, 3x3, and 4x4 MIMO connections from the LO IN and LO OUT to the splitter,
additional cables are required (refer to Table 8-3, Figure 8-19 on page 197, and Figure 8-20 on
page 198).

NOTE Agilent recommends the LO Output be covered when not in use.

When the LO In/Out jumper cable is removed and the instrument is in Dual ARB mode, the
instrument is unleveled and the instrument displays an Unlevel error message.

All test equipment requires a 12 hour warm-up period to ensure accurate performance.

The phase coherent configuration requires the following:

¢ The recommended LO input drive level should be in the 0 to 6 dBm range.

NOTE The 0 to 6 dBm LO input drive level ensures the instruments will operate over the full
frequency and over the full 0 to 55 ambient temperature rangel.

e The I/Q calibration and the self-test must be performed with the LO In/Out jumper cable in place.
Where the I/Q calibration cannot be run, the baseband offset can be manually adjusted to
minimize the I/Q offsets.

* The phase coherency feature only applies to the Dual ARB modulation mode.

e All cables from the splitter output to the instrument inputs should be of equal lengths.

Lo input power requirements vary with temperature; power <0 dBm may work at 20-30 degree ambient
temperature conditions. Refer to the Data Sheet.
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Table 8-3 Option 012 (LO In/Out for Phase Coherency) Equipment

MIMO Configuration | papt2 Cable Length Notes

2x2 n/a As required SMA flexible cables are connected from
the power splitter outputs to the LO
inputs on the rear panel of both the
master and the slave MXGs. Refer to
Figure 8-19 on page 197.

11636A n/a Power Divider, DC to 18 GHz. Refer to
www.agilent.com.

3x3 n/a As required SMA flexible cables are connected from
the power splitter outputs to the LO
inputs on the rear panel of the slave
MXGs. Refer to Figure 8-20 on

page 198.

PS3-20-451/128 | m/a 3-Way Pulser Microwave Corp., 3-Way
Wilkinson Dividers

4x4 n/a As required The SMA flexible cables are connected
to the power splitter output to the LO
inputs on the rear panel of the slave
MXGs. Refer to Figure 8-20 on

page 198.

PS4-16-452/105 | n/a 4-Way Pulser Microwave Corp., 4- Way
Wilkinson Dividers

All 10502A 22.86 cm (9 inches) Refer to Figure 8-19 on page 197 and
Figure 8-20 on page 198. See also
“Multiple Baseband Generator
Synchronization” on page 188.

30n all of the MIMO configurations, the same length of SMA flexible cables are connected from the splitter
output to the inputs on the master and slave instruments. Refer to Figure 8-19 on page 197 and to Figure 8-20 on
page 198.
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2x2 MIMO (LO In/OQut for Phase Coherency) Configuration

For the 2x2 MIMO (LO In/Out for phase coherency) setup, the LO from the master MXG can be ran
through a power splitter and used as the LO input to both the master and the slave MXGs. No
external source is required.

To generate phase coherent signals for a 2x2 MIMO configuration, the master MXG LO OUT is
connected via a power splitter to the slave LO IN. The LO OUT provides a sufficient amplitude LO
signal when connected directly, to drive the Slave MXG(s), thus providing phase coherency for the RF
output signals. In this example, we show two MXG signal generators with Option 012 connected for a
phase coherent 2x2 MIMO solution. Refer to Figure 8-19.

Figure 8-19 2x2 MIMO (LO In/Out for Phase Coherency) Equipment Setup

Master

M5182 Option 012 | EVENT 1({0ut)

' o CiieEe -
— i E}, 2 RF Output
= B e -
Lo DUTl LOIN 10 MHz AUT
GPIB/LAN r
REF IM
Signal Studio Software
LOIMN I—
M7E158 or M7E178 FAT TRIG (In)

RF Output

Slave
N5 1224 Option 012

Note:
To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 2-way splitter
connections to the LO IN of the MXGs with Option 012 (see page 195).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear-panel daisy chain

3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Configurations

For a 3x3 and 4x4 MIMO (LO In/Out for phase coherency) setups, an additional analog source is
needed to provide the higher LO power required by the power splitter and the additional
instruments.

Splitting the LO output four ways causes too much loss to drive the LO input of the N5162/82As in
the system. Also, there is no amplitude adjustment to the LO output of the N5162A/82A. To generate
phase coherent signals for a 3x3 and 4x4 configurations with the MXG, an external Master LO is
needed to provide a sufficient amplitude LO input signal to the vector MXGs (refer to Figure 8-20 on

page 198).

NOTE The Master LO is not controlled by any of the Signal Studio software, but must be set
manually by the user to the desired frequency and amplitude.
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Figure 8-20 3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Equipment Setup

Note:

A SMA flexible cable is recommended for the input to the 4-way splitter connections to the LO IN and LO OUT of the MXGs with

Option 012 (see page 195).

To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 4-way splitter
connections to the LO IN of the MXGs with Option 012 (see page 195).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear-panel daisy chain
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Waveform 5-Pack Licensing (Options 221-229)

Waveform 5-Pack licensing enables you to create, generate, and permanently license up to 45 Signal
Studio waveforms (e.g. Each Option 22x enables licensing of five waveforms (Option 221, 222, 223,
229).

Each Waveform 5-Pack License includes one N7699A-D01 30-day Signal Studio demo license.
N7699A-DO01 allows access to all N76xxB Signal Studio software products to create and generate
signals for 30 days so you can build, test, and license individual waveforms of your choice.

To redeem Option 22x and N7699A-DO01, refer to the N5182A-22x Entitlement Certificate that comes
with the N5182A-22x order.

Use the signal generator to manage the licensing of these waveforms. For example, you can use the
signal generator to select individual waveforms for licensing and you can view a list of all currently
licensed waveforms.

Understanding Waveform 5-Pack Licensing

Waveforms licensed with 5-Pack cannot be exchanged. Once a waveform is licensed, that license is
permanent and cannot be revoked or replaced. Option 22x waveform licenses are signal generator
specific (i.e. signal generator serial number specific).

Waveform 5-Pack licensing enables you to create and generate signals which can be saved for
unlimited use in a signal generator (i.e. Waveform 5-Pack Option 22x is a perpetual fixed waveform
license).

Use the Signal Studio software to build and download waveforms to the signal generator’s volatile
memory to be played. When you are satisfied with the waveform, it must be stored to non-volatile
memory before it can be licensed.

If a licensed Option 22x waveform file is transferred to another signal generator, the file must be
licensed by a separate Option 22x that is in the other signal generator before it can be played. For
more information on extracting and downloading waveform files, refer to the Programming Guide.

To license additional waveforms that exceed the number permitted by an Option 22x, you must
purchase an Option 22x that you do not already own. For example if you already own Option 221
with only two remaining licenses and you need ten more waveforms, purchase Options 222 and 223
to have enough licenses to license ten more waveforms. This would leave two remaining licenses on
Option 223. (Repurchasing Option 221 a second time, for the same signal generator, gives you no
additional Waveform 5-Pack licenses.)

Each Option 22x comes with a redeemable certificate for the N7699A-D01 30-day Signal Studio demo
license. The 30-day countdown for N7699A-DO01, begins at the time of the redemption. For maximum
usage when purchasing multiple Option 22x, only redeem one N7699A-DO01 at a time (e.g. after the
first 30-day N7699A-DO01 license expires, redeem the 2nd, etc.). This maximizes the time allowed for
waveform creation using the N7699A-D01 30-day Signal Studio demo license (refer to the

N5182A- 22x Entitlement Certificate). N7T699A-D01 30-day Signal Studio demo license cannot be
purchased separately from Option 22x.

Downloaded waveforms can be licensed either during the N7699A-D01’s 30 days or after the 30 days
expire. However, after expiration of the N7699A-D01, you cannot playback any unlicensed downloaded
waveform until it is licensed using the Waveform 5-Pack License Option 22x.
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After licensing a waveform, you can make copies of the waveform using different file names for use
on the same signal generator and even rename the original file without affecting the waveform
license.

You can also use the Option 22x to license waveforms from N76xxB Signal Studio software
downloaded during its 14-day free trial license. All of the N76xxB Signal Studio software products
provide a 14-day trial period (trial license). This 14-day trial license lets you download and play back
waveforms during the trial period. These waveforms are denoted by the TRL in the status message
area of the waveform segment catalog. After the trial period expires, the TRL message is removed but
the waveform remains. You can license these waveforms after the TRL message is gone.

Waveform 5-Pack requires firmware version >A.01.20.

Installing an Option N5182A-22x Waveform 5-Pack Licensing

1. Load a Waveform 5-Pack license, Option N5182A-22x, into the signal generator using License
Manager or a USB media. For more information on loading the Waveform 5-Pack License, refer to
the N5182A-22x Entitlement Certificate.

2. Redeem the N7699A-D01 that came with your copy of Option 22x. For more information on
redeeming the N7699A-DO01, refer to the N5182A-22x Entitlement Certificate.

Licensing a Signal Generator Waveform File
1. Create the waveform:

a. Download any of the N76xxB Signal Studio software that interest you. For downloading
N76xxB Signal Studio software, refer to the N5182A-22x Entitlement Certificate.

b. Create and download a waveform to a signal generator using any of the N76xxB Signal Studio
software. Refer to your Signal Studio software Help.
Waveform 5-Pack Licensing Softkeys Overview

Figure 8-21 Waveform 5-Pack licensing Softkeys

Mode > Dual ARB > More >
Waveform Utilities >

Note: Waveforms licensed with 5-Pack cannot be “exchanged”. Once a waveform is
licensed, that license is permanent and cannot be revoked or replaced.
UFN Utilities
Plot,)
CCOF
Sl Haung{g’ 5-Pack Licensing
T E-Pack Historusp— page 207
AT+3a13" >
oty i
S-Pack Licensing Th'S_l Sglﬁk'?yhls only
00004 .
—__available if there is an M For details on each key, use key help
Option 22x installed on the ]
PP NPW instrument as described on page 40.
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Figure 8-22 Add a Waveform to 5-Pack Softkeys

Mode > Dual ARB > More >
Waveform Utilities > 5-Pack
Licensing > Add Waveforms to

5-Pack + revoked or replaced.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Note: Waveforms licensed with 5-Pack cannot
be “exchanged”. Once a waveform is licensed,
that license is permanent and cannot be
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Table 8-4 on page 202.
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12TOME_FM E-Pack License Mot Reguired
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This softkey is only active when
there are secure waveforms that
can be added and a Waveform
5-Pack license with available
slots (i.e. if a waveform is already
licensed or does not require
licensing the softkey is greyed
out). Refer to page 205.

To select a waveform
to receive one of your
Waveform 5-Pack
licenses, use the
arrow keys to highlight
the waveform and
then press Add
Waveform.

Refer to the SCPI Command
Reference for related 5-Pack
License Commands.

This softkey
displays a catalog
of the waveform
segments stored
in the Int Storage
or USB Media.

This softkey
displays a catalog
of the waveforms
stored in the BBG
memory.

For details on each
key, use key help
as described on
page 40.
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Table 8-4 Waveform 5-Pack Licensing Status Messages for the “Catalog of Segment Files in Int Storage [or USB Media]”

Status Message

Meaning

Notes

Empty field

If no status message, then the waveform is
licensable.

Once a Trial (TRL)?
license expires, the
waveform becomes
licensable (i.e. the status
message for the TRL
waveform becomes an
empty field).

If a licensed Option 22x
waveform file is
downloaded to another
Nb5182A signal generator,
the waveform becomes
licensable on that other
signal generator (i.e. the
status message field is
empty).

5-Pack Licensed

This waveform is licensed by Option 22x.

5-Pack License Not Required

This status message applies to:

Any free waveforms provided with the
Agilent MXG (e.g. RAMP_TEST WFM, and
SINE_TEST WFM, etc.)

Any customer created waveform

Any waveforms that have a valid license (e.g.
Trial (TRL) licenses, Advanced Design System
(ADS), etc.).

Once a Trial (TRL)
license expires, the
waveform becomes
licensable (i.e. the status
message for the TRL
waveform becomes an
empty field).

If a licensed Option 22x
waveform file is
downloaded to another
N5182A signal generator,
the waveform becomes
licensable on that other
signal generator (i.e. the
status message field is
empty).

Trial license (TRL) is not applicable to N7699A-D01. A license downloaded with N7699A-D01 always has an empty field before it is licensed
with Option 22x. A Trial license is not licensable with Option 22x until after the 14-day trial expires.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Example: Licensing a Signal Studio Waveform

The following steps add a single waveform file, to a Waveform 5-Pack license. Refer to Figure 8-24 on
page 205.

2. There are two methods to save a waveform to the internal memory:

NOTE Before you can license a waveform with the Waveform 5-Pack licensing, the waveform must
be saved in either the internal storage or the USB media.

a. Save the file to internal storage using the Backup Waveform To Int Storage softkey:
1. Press Return > Return > More > Waveform Utilities > 5-Pack Licensing > Add Waveforms to 5-Pack.

2. Press Backup Waveform To Int Storage (refer to Figure 8-23).

Figure 8-23Backup Waveform To Int Storage softkey

The Confirm Adding
FREQUEHCY ANPLITUDE Add To 5-Pack Waveform To 5-Pack

935.200 000 00 | ~10.00_am Nl

internal storage.

/
B?Ckup e o Press this softkey to store the
waveform into the Internal

o Int Storaoe
erfor‘m Backup Required! | | ##x Storage and to activate the
> = iy Confirm Adding Waveform

To 5-Pack softkey.

For details on each key, use key help
as described on page 40.

3. Go to 3 Step d.

b. If the waveform has already been stored in the signal generator using the Backup Waveform to
Int Storage softkey then proceed to Step d.

1. Otherwise use the ARB Segments menu Load Store softkey to store the waveform to
internal storage. Refer to “Working with Files” on page 60.

2. Proceed to Step 3 once you've stored the waveform to internal storage (internal media).
3. License the waveform:
a. Press Return > Return > More > Waveform Utilities > 5-Pack Licensing > Add Waveforms to 5-Pack.

The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in
BBG Memory.

b. Use the arrow keys to highlight and select the file to be licensed.
c. Press Add Waveform.

A warning is displayed: *** Waveform Licensing Warning!!! *** [f necessary, verify you
have selected the correct waveform you want for licensing by pressing Return. Otherwise
continue to the next step (refer to Figure 8-24 on page 205).

d. Press Confirm Adding Waveform to 5-Pack.

The display returns to the Catalog of BBG Segment Files in BBG Memory and the file’s
Status column is now labeled 5-Pack Licensed (refer to Figure 8-24 on page 205).
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

e. Make a backup copy of this waveform on a USB media or a computer (If the waveform is lost
or deleted on the signal generator it cannot be recovered).

CAUTION It is important that a backup copy is made of any 5-Pack waveforms; the backup copy
must be stored on a computer or other media. Do not store the backup copy on the
signal generator. If all of the copies of the waveforms are deleted or lost, then there is
no way to recover the waveform or reassign the license. Refer to “Working with Files”
on page 60.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Figure 8-24  Add Waveform to 5-Pack Softkey

Mode > Dual ARB > More > Status area for the ) Important! Always
Waveform Utilities > 5-Pack waveform N7602B-WFM1 is backup licensed
Licensing > Add Waveforms to empty and the Add waveforms in a separate
5-Pack Waveform softkey is active, place from the
indicating the waveform is instrument (e.g.
licensable. computer, USB media,
etc.).

been verified as

Catalon Tupe 201 the waveform
—page
(BEG Seameris)’| o you want to be
licensed, press
N0 E— L] Confirm
RAMP_TEST_HFM 5-Pack License Mot Required Adding
SINE_TEST_HFM S—Pack License Mot Reguired Waveform To
5-Pack.

Caution! This
step cannot be

Y undone.

FREQUENCY ANPLITUDE A | _Add To 5-Pack - If tlhe ngfeform
935.200 000 00 MHz _10.00 m Add Haweforme ﬁ(?eicstﬁg P?EZIS
[1/0]_ARE_]|

icenses/Used: 7/uS

[:ata%og of BBG Seoment Files in BB

FREQUEHCY ANPLITUDE

message 935.200 00000 mz| _-10.00 _cen

Add To 5-Pack
- anfIrmg
Adding_Hawveform
To 5-Pack

This warning

indicates that
this is the last

chance for

verifying that

Lheemvgavefmm ﬁ** WaveformLicensing Karning! ! | #xk )

licensed is the Once a waveform is 5-Pack licensed it will use up an

one you want. avallable license slot and it can not be un-licensed.

\IL;:/Z form Be sure that uou want to license this waveform.

selected has Important! Keep a backup copy of the uaveform elseuhere

not been in case you delete all files in Int Storage.

verified, press

Return and 15716

verify the \J
selection. FREQUEHCY ANPLITUDE fdd To_5-Pack

935.200 000 00 mz| _-10.00 _cen (:

Catalog Tupe,
BEG_Memo icenses Used: g/45| (HEG Seoments)

For details on each key, use key

help Note that N7602B-WFM1 has a Status of “5-Pack Licensed”

and the Add Waveform softkey is no longer active.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Using Waveform 5-Pack History

The Waveform 5-Pack History softkeys can be used to manage the Waveform 5-Pack files on your
signal generator. The 5-Pack History softkeys can be used to:

* Create a list for a specific Waveform 5-Pack licensed waveform including any renamed files that
have been leveraged from that licensed waveform

¢ Create a list of all licensed and unlicensed waveforms on the signal generator
Refer to Figure 8-25 on page 207, for a description of the Waveform 5-Pack History softkeys.

The 5-Pack History softkey is only active, if you have previously stored a Waveform 5-Pack file in
non-volatile memory (internal storage, or USB media). But, the softkey 5-Pack History tracks the
history of licensed waveform files that may no longer be available in non-volatile memory (e.g. if the
waveform file has been deleted from internal storage or is located on a USB media that is not
attached to the instrument, the 5- Pack History softkey remains active). b-Pack History retains a
catalog of the Redemption Date, Waveform ID, and the Original Filename.

NOTE You can display either a catalog of the Internal storage or of the USB media but not both at
the same time.

If you switch from the internal storage to the USB media, and the instrument displays an
“Error -230, Data corrupt or stale” this is typically because a file (or files) was found
with the same name, but the file is a different waveform file (has a different Waveform ID)
than the original 5-Pack licensed internal storage file.
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Figure 8-25 Waveform 5-Pack History Softkeys

Mode > Dual ARB > More >
Waveform Utilities > 5-Pack
Licensing > 5-Pack History

FREQUEHCY

6.000 000 000 00 &z

Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Only available when there have

been waveforms with Waveform

5-Pack licenses previously stored.
W\

\

ANPLITUDE

-144.00 den

Haveform 5-Pack License History
uaueForm 1D

Redemption Date

G/ 7
DS;’DB;’EDD? N7E025

05,/03./2007

CIF 362263
dfa7hesd

Original Filename

Licenses Used: 3/ULS

1
2
N7E028_3

9-Pack Histor

Pressing this softkey searches for
every copy of the highlighted
waveform regardless of the current
filename. If the search returns no
results, then the original waveform has
been deleted and cannot be found.

/

Find Haweforme

\ Find ALl
Wateforms®

—

10:238

Displays the number of
\Waveform licenses used
and the number of total
waveform license ‘slots’
available (e.g. For this
| example 3 of the 45

This area displays the date the waveform was licensed, the unique Waveform ID, and
Original filename at the time the waveform was first redeemed.

licenses have been
| used).

All Haveforms

nt Storag
Int Storage
Int Storage
Int Storage
Int Storage

N7E02B_1_COPY1
N7E028_1_COFY2
N7BE028_1_COFY3
N7E028_2
N7E028_3
W7BE028_1_COFY3

13: 2L

This screen displays all
waveforms that are
licensed by Option 22x.

"

For details on each key,
use key help
as described on page 40.

Location is the memory location:
*Int Storage

*BBG Memory, Or

*USB Media

Note:

1) In this example, the waveform N7602B_1_COPY3 is stored in the Int Storage and playing in the BBG Memory:

/

2) In this example, the Int Storage has been selected as the non-volatile storage location. To view any 5- Pack/waveforms stored on the USB media, the
USB media must be selected as the default storage. Refer to page 60.

FREQUENCY 935.200 000 00 = n“pLI—TTBOUU dBn

Haveform 5-Pack Search Results
Location

Int Storage

Int Storage

Int Storage

EBG Memory

N7BE02B

/Current. Filenamd\

N7E02E_
N7E0ZE_

( H7602B_1

¥

1_COPYl
1_COPv2
1_COPY3

Find Haveform

When you press Find Waveform,
any copies of the originally saved
waveform are displayed on the
instrument (e.g.
N7602B_1_COPY1,
N7602B_1_COPY2, and
N7602B_1_COPY3). In this
example, the original filename
N7602B_1 was not found because
the original file was deleted or the
name was changed. But three
copies were found
(N7602B_1_COPY3 was found in
both the Int Storage and the
BBG Memory).
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Example: Finding the History of a Waveform 5-Pack License

Use the following procedure to create a catalog of licensed Waveform 5-Pack files in the internal
storage or USB media. Refer to Figure 8-26 on page 208, for the following procedure.

The following procedure generates a catalog for a Waveform 5-Pack file labeled: N7602B-WFM1.

1. On the signal generator:

a. Press Mode > Dual ARB > More > Waveform Utilities > 5-Pack Licensing > 5-Pack History

b. Use the arrow keys to highlight the cataloged file N7602B-WFM1.

c. Press Find Waveform

The instrument displays a catalog titled “Waveform 5-Pack Search Results”. This catalog
displays a list of all of the files that are copies of the original file that was licensed with the
Waveform 5-Pack licensing, named N7602B-WFM1. For this example, the copies are currently
in the BBG memory and the Internal storage and named N7602B-WFM1 and
N7602B-WFM1_COPY (respectively). Refer to Figure 8-26 on page 208.

NOTE
page 204.

If no files are found, you can reload the backup copies that were made in Step e on

Figure 8-26

Mode > Dual ARB > More >
Waveform Utilities > 5-Pack
Licensing > 5-Pack History

6,000 000 000 00 o | ~144.00 & |

Using Waveform 5-Pack History “Find Waveform” Softkey

The highlighted file
N7602B-WFML is the
waveform created in this
example. (Notice the unique
Waveform ID displayed for
each licensed waveform.)

For details on each key,
use key help
as described on page 40.

9-Pack Histor

Find Haweforme

Find ALl _ see page 209.

Haveform 5-Pack License History
Redemption Date Haveform ID

05 /03,2007 dfabbesd N7E02E_1

05 /03,2007 2c15a2ca N7E02E8_2

05/10/2007 fabsbclc UNWTITLEO-HFML

05/10/2007 L250b52e UNWTITLEO-HFML

05/10/2007 0f2037d0 UNWTITLEO-HFML
2feebib2

0S5/ 1L /2007 UNTITLED-HFML
05 /16/200 bi76a7da MZE02E=LIEML

Original Filename

Licenses Used :\ B/LS Haveforms T

Notice that the originally
5-Pack licensed waveform,
N7602B-WFM1, has been

bbakDbla

'

changed to
N7602B-WFM1_COPY and
is saved in the Internal
Storage and playing in the
BBG Memory.

If no waveforms are listed
when Find Waveform is

I e

Haveform 5-Pack Search Results
Location

Int Storage

EBG Memory

Current Filename O\

N7E02B-HFM1_COFY
N7BE02B-HFM1_COPY

pressed, then the waveform
cannot be found in BBG
Memory, Internal
Storage, Oor USB Media

( H7602B-LFN1
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Finding All Waveforms Associated with 5-Pack Licenses

The following procedure displays a catalog of all of the Waveform 5-Pack files in the BBG memory
and the internal storage:

1. On the signal generator:
a. Press Mode > Dual ARB > More > Waveform Utilities > 5-Pack Licensing > Find All Waveforms

The instrument displays a catalog titled: Waveform 5-Pack Search Results. Refer to Figure
8-27.

NOTE If no files are found, you can reload the backup copies that were made in Step e on
page 204.

Figure 8-27  Using Waveform 5-Pack History “Find All Waveforms” Softkey

Mode > Dual ARB > More > Waveform Utilities >
5-Pack Licensing > 5-Pack History > Find All

l

Waveforms

Haveform 5-Pack Search Results All Haveforms
Location Current Filename
Int Storage W7EO2B_1_COPY
Int Storage WFEDZB_2
Int Storage N7E0ZE_1_MHHHK
Int Storage UNTITLED-HFM_ZEB
Int Storage N7E026_1
Int Storage N7E02E8_2_COPY
Int Storage N7E02B_2_COPY_AR
Int Storage UNTITLEO-HFM1_COPYH
Int Storage W7E02B-HFH1_COPY
EEG Memory N7E02B-HFH1_COPY
16:23
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)

Waveform 5-Pack Warning Messages

Figure 8-28
FREQUEHCY AAPLITUDE Add To 5-Pack ‘é’hislstar(ljdard warning is
; isplayed every time a
935.200000 00 mz| -10.00 0 | ccoine oefern waveform i selected to e
To S—Pack licensed. This notification
L ARB indicates that one of the
available “license slot[s]" is
/about to be used from
. . . / Option 22x.
xkk Waveform Licensing Warning! || #x%  <— ALWAYS make
Once a waveform is 5-Pack licensed it will use up an backup copies of
available license slot and it can ot be un-licensed. ‘é":r‘)’;rfgt;mnso'r:‘_ \?olatile
Be sure that uou want to license this waveform. memory in case a file
Inportant! Keep a backup copy of the waveforn elsauhere is deleted or lost
in case you delete all files in Int Storage. from theinstrument’s
internal storage.
| [FREQUENCY ANPLITUDE Add To 5-Pack

) 935.200 00000 mz| _-10.00 _cen

This warning is displayed

before you can license it.

|| FREQUEHCY ANPLITUDE Add To 5-Pack

Backup Wavefarm when an attempt is made
7o Int Storage to license a waveform that

has not been saved to

; internal st usB
*4x Waveform Backup Required! | | #*x / 'rw'liéi’éa{ef’[ﬁ?ie‘f’é;ms,
llaveform backup required. The waveform can not be cannot be licensed unless
licensed until it is copied to non-volatile memoru.<— | R e e e 1o

non-volatile memory).
Press the Backup
Waveform To Int Storage

You must back up the waveform to non-volatile memory softkey.

when there is insufficient

K 6.000 000 000 0[1] |5H§RB -144.00 den This warning is displayed

memory or other problems
with the internal storage,

enough free memory.

935.200 000 00 = |

copied to non—volatile memory. There may not be

You must free enough non-volatile memory to copy
the uaveform before you can license it.

[ JFREQUEHCY ANPLITUDE Add To 5-Pack

or USB media (non-volatile
. / memory) and the
+++ WaveformBackup Failed! || 4%  _ — waveform could nor e
laveform backup failed. The waveform could not be memory.

This warning is displayed
= 1 0 00 dBm when the file being
0 licensed is not backed up
__—in internal storage or the

memory has the same name.

uaveform to the 5-Pack license list.

You must rename one of the files before adding the

USB media (non-volatile
memory), but there is a file
already in the internal

*xx Wavef orm Renaming Required! | | sk «—| storage or USB media,

The file you are truing to license is not backed up
in non—volatile memory, but & file in non-volatile

with the same name.

15:12
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9 Adding Real-Time Noise to a Signal (Option 403)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG ATE or via SCPI commands. Refer to the Installation Guide,
the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Chapter 3, “Basic Operation,” on page 39 and familiarize yourself with the information in that
chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431.
Option 431 requires Option 651, 652, or 654.

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform
generator, which is available only in vector signal generators with Option 403.

e Adding Real-Time Noise to a Dual ARB Waveform on page 211
* Using Real Time I/Q Baseband AWGN on page 214

Adding Real-Time Noise to a Dual ARB Waveform

NOTE The procedures in this section that pertain specifically to adding Real-Time Noise (AWGN) to
a waveform, are applicable to the Custom ARB, Multitone, and Two-Tone modulation
standards too.

A vector signal generator with option 403 enables you to apply additive white gaussian noise (AWGN)
to a carrier in real time while the modulating waveform plays in the dual ARB waveform player. This
feature appears in each of the arb formats and as a stand-alone menu (Refer to Figure 9-3 on
page 214).
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Adding Real-Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-1 Real Time 1/Q Baseband AWGN Softkeys
For details on each key, use key help
Mode as described on page 40.
Arb
SHB
0ff Q]
Todulation Hode frb Setu
Select ARE_Sample Clock
Oual AREM— aeform® 580, 000000KHz
Custom, oFE Setup—————— || FERlTTime AN
ARE

Trigger Tupe Real-Time
(Cont inuous , M Friase Moise Setup™

Free Run.
Haveform Bunt ime
THo-Tanek ggaé&ng
fore 1 of 2 Modulator Atten
Multitone Ell (6
Hanual
Hore 1 of 2 %

fore 1 of 2 E

Nodulat.i
This is the stand-alone Real-Time
L —AWGN and the 2nd page of the
Modulation Mode menu (see
page 214).

Feal-Time
AHGNY)

Feal-Time
Fhase Moises
Impairment

The state of the noise (on or off)
is shown on the display.

W NI

Figure 9-2 on page 213
provides additional
details on these settings.

Real-Time ALGN
Off

Carrier to Moise The amount of noise power relative to

_ Rat.io the carrier power.
ARE Real-Time ALGH 0.00_cB /\
AL n — ] . .
— i i For the selected carrier to noise ratio,
C/N: 0.00de Larrier B??gsédﬁg\_the bandwidth over which the noise is
Gar‘r‘ier‘ Banduidth (CBID: X 1000 He > — = — — — "F integrated. Typically, Carrier Bandwidth
: : . D) ] ] (CBW) is the occupied bandwidth of the
ELat Noise Banduidtn (L0002 D — | pise Banidth  canior
Total Power: -144.00 dBm ~— _1.000 Hz\
Carrier Power (C):  \ -147.52 dBm L ““Theactual flat noise bandwidth (NBW),
Noise Power In Channel \(H)7 -147.52 dEm (c D_utth _r1u>)<, g:r'ﬁgrsk?;#‘;‘;/ %th'(g';tl'cya‘n'y'dlefe‘:?nltshe
; o ¥ _ arrier+Noise -
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\ | (1.2 * the Flat Noise Bandwidth)
N
Static graphic representation of The relationship of the values are displayed in the i i
ARB Real-Noise AWGN (i.e. static graphic of ARB Real-Time AWGN. fioTse iz Eggi?il\?:r?é?ggossg%h%?rgﬁ)l,%e
\g/;?ﬁg;ccﬂgizgft update as The Total Noise Power is the Noise Power over the noise, only the carrier, or the
: occupied noise bandwidth (NBW * 1.2). - - sum of both the noise and the
P ( ) Carrier+Hoise carrier are output from the
internal baseband generator.
With the ALC off, this feature
Carrier enables direct measurement of
the carrier or the noise
contributions independently
Moi from the total power. The system
Eiss still behaves as if both the noise
and the carrier are present on
Vi . the output when it comes to
e determining the Auto Modulation

Attenuation and the RMS level
for RMS Power Search.
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Adding Real-Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform

Figure 9-2 Carrier to Noise Ration Components

Carrier Bandwidth (CBW) is typically the

occupied bandwidth of the carrier and the Noise

Bandwidth is the flat noise bandwidth (NBW). .
The carrier now appears
larger because of the

Noise BW added noise power.

(NBW) =

' Carrier BW ' <« flatnoise >
(CBW) bandwidth

RMS
(total carrier power)

'
'

'

! ' Carrier BW '
X (CBW)
'

'

Example

Use the following steps to modulate a 1 GHz, -10 dBm carrier with the factory-supplied waveform
SINE_TEST_WFM, and then apply noise with a 45 MHz bandwidth signal that has a 30 dB
carrier-to-noise ratio across a 40 MHz carrier bandwidth.

1.

Preset the signal generator and set the following:

* Frequency: 1 GHz
* Amplitude: —10 dBm
* RF output: on

Select the factory-supplied waveform SINE TEST WFM:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight SINE TEST WFM and press Select Waveform.

Turn on the dual ARB player: press ARB Off On to highlight On.
Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.
Press Real-time Noise Setup and set the following:

¢ Carrier to Noise Ratio: 30 dB
e Carrier Bandwidth: 40 MHz

¢ Noise Bandwidth: 45 MHz

¢ Real-time Noise: on

The signal generator’s displayed power level (-10 dBm) includes the noise power.
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Adding Real-Time Noise to a Signal (Option 403)
Using Real Time 1/Q Baseband AWGN

Using Real Time 1/Q Baseband AWGN

Figure 9-3 Real Time 1/Q Baseband AWGN Softkeys

Mode
lodulation lode —®[Todulation Mode

Dual AREP Real-lim,] o Heal=tine AUGH /|

Real-Time Real-LLIe RGN

- 0ff
Eusgagb Phase Moises Qe JEx
Impairment
Eandwidth
M\\_ 1.000000000MHz
For details on each key, use key help
Hodulatog.ggtgg as described on page 40.

Tho-TaneM Manual

sy S,
Multitonew
fore 1 of 2 —

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, -10 dBm carrier.

1.

Configure the noise:

a. Preset the signal generator.

b. Press Mode > Real Time I/Q Baseband AWGN
c. Press Bandwidth > 10 > MHz.

2. Generate the noise:
Press AWGN Off On until On highlights.
During generation, the AWGN and I/Q [Frcquency ATPLITODE
B et 6.000 000 000 00 s ~142.00_a»
modulate the RF carrier.
3. Configure the RF output:
*  Frequency: 500 MHz
* Amplitude: —10 dBm
* RF output: on
The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.
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10 Real-Time Phase Noise Impairments (Option 432)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG ATE or via SCPI commands. Refer to the Installation Guide,
the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 39 and familiarize yourself with the information in that
chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431.
Option 431 requires Option 651, 652, or 654.

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and
information on the use of this feature.

* Real-Time Phase Noise Impairment on page 216

* The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments on page 217
* Understanding the Phase Noise Adjustments on page 219

* DAC Over-Range Conditions and Scaling on page 220
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Real-Time Phase Noise Impairments (Option 432)
Real-Time Phase Noise Impairment

Real-Time Phase Noise Impairment

This feature lets you degrade the phase noise performance of the signal generator by controlling two
frequency points and an amplitude value. The signal generator adds this phase noise to the phase
noise normally produced by the Agilent MXG. This feature appears in each of the arb formats and as
a stand-alone menu. While the following figure shows how to access the controls using both the
stand-alone menu and the Dual ARB player, the location and softkeys within each arb format is the
same as for the Dual ARB player.

Figure 10-1 Stand-Alone and Dual ARB Player Real-Time Phase Noise Softkeys

Mode

| llodulation Hode

Ouzal AREM

Custom,|
ARE

Arb

ARE
on

Select

Have FDEP}’

THo-Tonew

7

Multitonew

Hore 1 of 2

Trigoer Tupe
(Cont inuous , M
Free Run.

lodulation lode

Real Time I/0
Easebande
AHGKN

Phase_Noise'
Impairment.

I\\M\_‘_

FREQUEHCY

2.000 000 000 00 s+

ERXTREF

Desired £2: 30000 000 kHZ

More 1 of 2

Stand-alone menu

Use to add phase noise to the
CW output without having to
play a waveform.

This softkey is
available in all arb
formats.

ARE_Sample Clock
930, 000000kHz

Arb_Setup A

ARE Setupsf—P

Feal-Time ALGN
Setup®

Feal-Time

=
Fhase Moise Setup

Haveform Bunt ime
Scaling
92.00 X

Modulator Atten
3.51 dB

The display updates even
when the feature is off.

AAPLITUDE

-10.00 den

Hore 1 of 2 %

\J

Phase Hoise

-u0

LCF)
dBc/Hz

0
100Hz

Fhaze Moise
TR o

Lm0

Desired

Start Fregifl)

1.000000kHz

For an explanation on these
settings see

“The Agilent MXG Phase Noise
Shape and Additive Phase Noise
Impairments” on page 217.

The start frequency for the flat
mid-frequency characteristics.

Flat Mid-Frequency Area
Denoted by f1 and f2

—————— Lmid

Desire
Stop Freq(f2) |
30. 000000kHz

d

The end frequency for the flat
mid-frequency characteristics.

Desired Flat
Amplitude(Lmid)
=70.00 dBc/Hz

The amplitude for the flat
T~ mid-frequency characteristics.

Frequency, Loo Scale

1hHz

(Lmid stands for the level
amplitude of the mid-frequency
characteristic.)

For details on each key, use key help
as described on page 40.

the signal generator.

NOTE: The phase noise impairment is added to the base phase noise of
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Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Plots Without Phase Noise Impairment

—50 dBc/Hz — -50 dBc/Hz

The Agilent MXG demonstrates a definitive
shape to its phase noise plot. The
mid-frequency offsets are characterized by a
leveling (flattening) of the phase noise
amplitude from approximately a 3 kHz offset

to approximately a 70 kHz offset.
Close in and far out offsets demonstrate
slopping characteristics (areas before and

<t after the mid-frequency offsets).

il

Frequency Offset

The signal generator degrades the phase noise by moving the mid-frequency characteristics and/or
changing its amplitude using the following settings:

e Start frequency (fl1) of the mid-frequency characteristics
* Stop frequency (f2) of the mid-frequency characteristics
e Amplitude (Lmid) of the mid-frequency characteristics

-50 dBc/Hz -50 dBc/Hz

This is a plot of the unmodified phase noise
shape that shows the location that each
value alters.

Amplitude
(Lmid)

/

ha

Mid-frequency characteristicq K

Frequency Offset
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Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

Phase Noise Plots With Phase Noise Impairments

Flat mid-frequency offset

50 dBc/hz characteristics (Lmid)

-50 dBc/Hz

When turned on, this phase noise is added
to the base phase noise of the signal
noise plot

generator.

Even though it is only the mid-frequency
characteristics placement that are modified,
these changes affect the entire phase noise
shape. The close in and far out offset

. - characteristics change by exhibiting
approximately a 20 dBc/Hz slope for each

™ octave of frequency offset
phase noise Flat mid-frequency offset T — I '
characteristics (Lmid) =R

g

I

14 Hz Frequency Offset 16

—50 dBc/Hz -50 dBc/Hz

100 Hz 1/kHz

The resultant phase noise plot shown on
the left has the following settings:

e f1=100Hz
e f2=1KkHz
¢ Amplitude (Lmid) =-70 dBc

Ensure that the f1 value is less than or
—20 dBc/Hz equal to f2. If not, f2 changes its value to
match f1. Conversely if f2 is set to a value
that is less than f1, f1 changes its value to
match f2.

Frequency Offset

The frequency values entered for the impairments may not be the exact values when viewed on the
RF output. The entered values are guidelines that the signal generator uses to calculate the real
values. See “Understanding the Phase Noise Adjustments” on page 219 for more information.

To view the results of the settings (fl, f2, and Lmid), use the front panel graph (below and on

page 216) or view the phase noise plot on a measurement instrument (shown above—Agilent E4440A
PSA with Option 226).

ARB Additive Phase Noise Impairment )
T £1 £2 Signal generator front panel plot:
i + f1=100Hz

LCF) ; ] e f2=1kHz

———————————— —== - —————————— I mid
TR : ™ *  Lmid =-70 dBc

-90 K

10Hz Frequency, Loo Scale 10kHz
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Real-Time Phase Noise Impairments (Option 432)
Understanding the Phase Noise Adjustments

Understanding the Phase Noise Adjustments

The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), f1
(start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as f2 increases in value, Lmid’s upper boundary decreases. If
the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid
value and generates an error to alert you to the change. In addition, the actual Lmid value can vary
by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate the
real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop
frequency values are an approximation and may not be the values seen on a measurement
instrument, however they will be close.

The effects of the f1 and f2 parameters are based on a varying logarithmic scale. This scale is
determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior
more noticeable at higher frequency settings. This becomes apparent when a change in the fl or f2
value causes little to no change in the fl1 or f2 position. This is easy to view using the signal
generator’s front panel phase noise graph and demonstrated in Figure 10-2. This behavior makes the
frequency adjustments coarser as the f2 frequency value increases.

Figure 10-2 f1 and f2 Frequency Setting Behavior

iti i i Desired
ARB Additive PhESEF{ilJl se Inpal r;rgent 1?255055335%; f1 and f2 softkey settings for the front
=60 i = panel phase noise graph.
H Desired
Stop Freqifz)
30.000000000HHz
LCF) Desired Flat
dBc/Hz ﬂ!TDl?ELlJESELmlSJ
Lmid -80.50 dBc/Hz
a0 ; W
1MHz Frequency, Loo Scale ! 100MHz
Ll LS. 509 e
' [
ARB Additive Phase Noise Inpairment Dosired | O ot change ey e ot
k Start Freg(fl) 12.1 MHz was set. This means that it
-60 'Fl r 2 12. 100000000MH2 took an increase of 1.6 MHz to change
' ! Desired its frequency offset.
' H Stop Freq(f2)
! Ll v 4. 000000000NHZ
CLE) : : : Desired Flat 2 did not change frequency until 40
dBc/Hz \ ﬁrﬂléétggeélémla) MHz was set. This means that it took an
—————————————————— | il B2 increase of 10 MHz to change its
/ A \ N frequency offset.
-9

0 » e
1% Frequengl, Loo Scale 1ﬂﬂﬂz

f1—original 10.5 MHz f2—40 MHz setting that
setting - moved the offset position
f2—original 30 MHz

f1—12.1 MHz setting that setting
moved the offset position

For details on each key, use key help
as described on page 40.

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing
the front panel graph or making a measurement. You can view the front panel graph remotely by
using the LXI interface. For more information on the LXI interface, see the Programming Guide.
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Real-Time Phase Noise Impairments (Option 432)
DAC Over-Range Conditions and Scaling

DAC Over-Range Conditions and Scaling

When using phase noise impairment, it is possible to create a DAC over-range condition, which
causes the Agilent MXG to generate an error. To minimize this condition with the phase noise
impairment feature, the Agilent MXG incorporates an automatic DAC over-range protection feature
that scales down the I/Q data. Because it can scale the data by more than what is actually need, it
typically decreases the dynamic range of the waveform. This is especially noticeable when using a
constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over-range protection can be turned off (on is the factory
default). The control for the Dual ARB DAC over-range protection feature is located in the key path
as shown in Figure 10-3.

Figure 10-3 Dual ARB DAC Over-Range Protection Softkey Location

Mode -
Nodulation Hode Arb
Dual ARB»—P ARE Arb Setup A
an
AP B B bRoba e
Custom o =
e 2 Select
Modulat ion Vavaform®
Real-Time_ALGN |
Setup
AFE Setupsf—
Real-Time |
THo—Tones IEig%er Tupe Fhase Moise Setup
0Nt INuousS b - When the DAC over-range protection is off,
ARSS) (VY TSR Egg'ﬂﬁg 4 eliminate over-range conditions by
Multitonew 92.00 « decreasing the scaling value (see “Setting
Modulator Atten Waveform Runtime Scaling” on page 177).
More 1 of 2 % i T oF 2 3.51 dB
L fore 1 of £ Manual
More 1 of 2
Arb Setu
Baseband
Frequency Offset
0.000 Hz
Mult i-BBG Sunc L
Setupy Default setting is On.
/ Turn off to manually control scaling while
using the phase noise impairment option.
Manually adjust the scaling using the
For details on each key, use key help Waveform Runtime Scaling softkey
as described on page 40. \w shown above.

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the
over-range protection off and use the Waveform Runtime Scaling softkey to eliminate DAC over-range
conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over-range condition
are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself.
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11 Custom Digital Modulation (Option 431)

NOTE For the N5162A, the softkey menus and features mentioned in this guide are only available
through the Web-Enabled MXG or via SCPI commands. Refer to the Installation Guide, the
Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Chapter 3, “Basic Operation,” on page 39 and familiarize yourself with the information in that
chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 431.
Option 431 requires Option 651, 652, or 654.

¢ Custom Modulation on page 222

¢ Using the Arbitrary Waveform Generator on page 227

¢ Using Finite Impulse Response (FIR) Filters on page 237

* Modifying a FIR Filter Using the FIR Table Editor on page 241
¢ Differential Encoding on page 244
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Custom Digital Modulation (Option 431)
Custom Modulation

Custom Modulation

Custom Modulation has built-in modulation standards such as TETRA and DECT; and pre-defined
modulation types such as BPSK and 16QAM that can be used to create a signal in addition, it
provides the flexibility to modify the digital format’s attributes.

ARB Custom Modulation Waveform Generator

The signal generator’s ARB Waveform Generator mode is designed for out-of-channel test
applications. This mode can be used to generate data formats that simulate random communication
traffic and can be used as a stimulus for component testing. Other capabilities of the ARB Waveform
Generator mode include:

¢ configuring single or multicarrier signals. Up to 100 carriers can be configured.
* creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing
where device performance such as adjacent channel power (ACP) can be measured. The

AUTOGEN WAVEFORM file, that is automatically created when you turn the ARB Waveform Generator
on, can be renamed and stored in the signal generator’s non-volatile memory. This file can later be
loaded into volatile memory and played using the dual ARB waveform player.

For more information, refer to “Waveform File Basics” on page 128 and “Modes of Operation” on
page 4.
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Figure 11-1 ARB Custom Modulation Softkeys

Mode

Nodulation Hode 7

Oual AREK

ARE Custom

—page 128

Modulat ion”]

THo-Tone

—p-page 253

Mult itonem

—page 258

__lore 1 of 2 %

ARB Custom 7

Custom Digital Modulation (Option 431)

Available only when

Custom Modulation

Digital Enables the current ARB | > on
Modulat. ion [ custom modulation settings. Multicarrier is Off.
on
rulbleagrier Ly page 234 nisita] Med,k o page 224
etup
This softkey changes, depending
" on the selected mode of modulation.
Multicarrier
Ler | page 234
AFE Setups— Page 180 e
Available on(when
Multicarrier is On.
_Hore 1 of 2 - Custom ARE
Trigoer Tupe
(EDEtinuausib
ree Run page 158
Marker
Utilities® page 129
For details on each key, use key help as described on page 40.
Hore 2 of 2 ™
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Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-2 Quick Setup Softkeys

Mode > ARB Custom Modulation > Digital Mod Setup

This softkey label shows
the currently selected

Setup Hod & modulation standard.
DEMW — -
(DeFault)l o Quick Setup ~#
Custom Digital
Modulation Tupes—me-page 225 Hod State*]—®-Page 233
/ BsH
FilterH——m-page 237 . N\
|
Sumbol Rate EDGE > .
GDDDDD Msps | _ Ouick Setup /
— — —
| APCO 25 W/CUFT
NADC /
D35 Med- He e Page 226 ) i \
I POC APCO 25 W/COPSK |
\ /| | |
Hore-1-6f 31 | TETRA |
| DECT |
Press Symbol'Rate | .
softkey and use | Quick S/eﬂtup 7
numeric keypad to —
change value as )< PHS / Elluetooth\
required.
The default (initial) [Hore=Zor s T
Symbol Rate COPD
g%ﬁ;neunn;erg{lggo\ﬂﬁ: When one of these pre-defined |
modulation standard modulation standards is selected,
selected with the default values for components of the ) ‘I PUT
Quick Setup softkey. setup (including filter, symbol rate, and Default: This softkey selects the
’ modulation type) are automatically following default settings: ~ ————— T
specified. Modulation Type = QPSK, Default
Symbol Rate = 1 Msps, ——
Filter = Root Nyquist, and
. . Filter Alpha=0.5
For details on each key, use key help as described on page 40. flore T oF 3
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Figure 11-3 Mod Type Softkeys

Mode > ARB Custom Modulation > Digital Mod

Setup

Setup Hod &
Quick Setup)

Modulation Tupek

Defaulto ™ Page 224

Sumbol Rate
1.000000 Msps

Store Custom,|

Filters——page 237

Dig Hod State > page 226

lod Tupe i
Select

Custom Digital Modulation (Option 431)

(OPSK)T]

Oefine,
User I/0

- page 229

Oefine,
User FSK

L page 229

'

Mod Tupe &

Y

ASK
ASK Depth
f0d.000°%

Sets the modulation depth for the
Amplitude Shift Keying (ASK).

Custom Modulation

PSK age 229
sy P9
M5k
FSkp
QAMK
FSK
ASk 2-Lwl FSK
fore 1 of 2 3
L-Lwl FSK
* 8-Lwl FSK
0an
LOEH 16-Lwl F5k
16GAM iR
fore 1 of 2
320AM
BLOAM TSE
Freq Dev
1280AM L Hz
fore 1 of 2
[T
Sets the symmetric Frequency Shift
2560AM Keying (FSK) frequency deviation value

For details on each key, use key help as described on page 40.
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Custom Digital Modulation (Option 431)
Custom Modulation

Figure 11-4 Store Custom Dig Mod State Softkeys
Mode > ARB Custom Modulation > Digital Mod Setup > Store Custom Dig Mod State

page 232
FREQUEHCY ANPLITUDE Store State
6.000 000 000 00 &z | -144.00 den S -
1/0|DIGHOD Confirm Delete
Catalog of DNOD Files in Int Storage 29.6MB used LBSME free

File Hame Tupe Size Nodified w
i [RHA] ]

Delete FileW

Goto Rour—— Goto Rou

Enter

0172472007 16:56 Goto Top Rouw

Catalog displays digital Goto Middle Row

modulation (DMOD) files that
have been previously saved.

Goto Bottom Row

For details on each key, use key help as described on page 40. M
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Using the Arbitrary Waveform Generator

This section teaches you how to build dual arbitrary (ARB) waveform files containing custom TDMA,
digital modulation for testing component designs.

Figure 11-5 Adding Custom Modulation to a Waveform

Mode > ARB Custom Modulation > Digital Mod Setup

) _ Quick Setup 7
This softkey label updates to reflect uick Set.u -
the current modulation type. CUStDﬁDglg%gﬁé, ~ »page 233
GSH
Quick Setup, >
(Oefault)® > EOGE
Modulation TupeM—page 225 MR
Filters—m-page 237 POC
Surbol Fate | Tore 1 of 3
1.000000 Hsps
Store Custom,
Dio Hod State'] > Page 226

For details on each key, use key help as described on page 40.

Using Predefined Custom TDMA Digital Modulation

This section teaches you how to perform the following tasks:
e Selecting a Predefined EDGE Setup on page 227

* Generating the Waveform on page 227

¢ Configuring the RF Output on page 228

Selecting a Predefined EDGE Setup
1. Press Preset.
2. In the ARB Custom Modulation menu (page 227), press Digital Mod Setup > Quick Setup > EDGE.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the pre-defined EDGE state selected in the step. The display changes
to Dig Mod Setup: EDGE. During waveform generation, the DIGMOD and I/Q annunciators appear and
the pre-defined digital modulation state is stored in volatile memory (BBG). The waveform is now
modulating the RF carrier.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Configuring the RF Qutput

1. Set the RF output frequency to 891 MHz.

2. Set the output amplitude to -5 dBm.
3. Press RF On/O0ff.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.

228
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Creating a Custom TDMA Digital Modulation State

In this procedure, you learn how to set up a single-carrier NADC digital modulation with customized
modulation type, symbol rate, and filtering.

Figure 11-6 Setting a Digital Modulation Filter

Mode > ARB Custom Modulation > Digital Mod Setup

Quick Setup
(Default)’)

Modulation Tupew

Filtermr—

Sumbol Rate
1.000000 Msps

This softkey label updates to reflect
the current modulation standard.

Quick Setup ~#

Custom Digital
Mo Stace*f—Page 233

GSH

EDGE

This softkey sets
the filter shape.

This softkey
sets the filter
bandwidth
parameter,
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default Alpha
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standard (see
page 237) and
modulation
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(see
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Dig Mod State

\i
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Hore 1 of 3 %
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Yy
Filters Filter Select
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Define .
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Filter Alpha) ]
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/
Festore Default
Filter User FIRM

Hore 1 of 2 %

TGpERSP—Page 230

Opens a menu where the
user-defined 1/1Q
constellations or user-defined
Define FSK frequency mappings can

User 1,0" be inserted into a table and
then applied to the current
Define modulation type. Also, for
User FseM both 1/Q and FSK, differential
state mapping can be
specified.

e

For details on each key, use key help as described on page 40.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Figure 11-7 Modifying a Digital Modulation Type

Mode > ARB Custom Modulation > Digital Mod Setup > For details on each key, use key help as described on page 40.
Modulation Type > Select

Mod Tupe 7 PSK
PSK PSK and 00PSK
- > » -
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or user FSK file <€——PSK menu. Unbalanced Qrsk [ QPSK menu.
Usar FSkM that can be
selected and EDGE
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. - modulation type.
R

This section teaches you how to perform the following tasks:
¢ Selecting a Digital Modulation Setup on page 230

¢ Configuring the RF Output on page 228

¢ Selecting the Filter on page 231

¢ Configuring the RF Output on page 228

Selecting a Digital Modulation Setup
1. Press Preset.
2. In the ARB Custom Modulation menu (page 229), press Digital Mod Setup > Quick Setup > NADC.

Modifying the Modulation Type and Symbol Rate

1. In the ARB Custom Modulation menu (page 229), press Digital Mod Setup > Modulation Type > Select
> PSK > QPSK and 0QPSK > QPSK.

2. Press Return > Symbol Rate > 56 > ksps.

230 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Selecting the Filter
1. In the Setup Mod menu (page 229), press Filter > Select > Nyquist.

2. Press Return > Return.

Generating the Waveform
Press Digital Modulation Off On.

This generates a waveform with the custom, single-carrier NADC, digital modulation state created in
the previous sections. The display changes to Dig Mod Setup: NADC (Modified). During waveform
generation, the DIGMOD and I/Q annunciators appear and the custom single-carrier digital modulation
state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, single-carrier NADC, digital modulation state to the
non-volatile memory catalog, see Storing a Custom TDMA Digital Modulation State on page 231.

Configuring the RF Qutput

1. Set the RF output frequency to 835 MHz.

2. Set the output amplitude to 0 dBm.

3. Press RF On/0ff.

The user-defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom TDMA Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom
multicarrier digital modulation state to non-volatile memory.

If you have not created a custom, single-carrier, digital modulation state, complete the steps in the
previous section, Creating a Custom TDMA Digital Modulation State on page 229.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Figure 11-8 Storing a Custom Digital Modulation State

4.

Mode > ARB Custom Modulation > Digital —— __Setup lod __Text Entru
Mod Setup Ouick Setup, Enter
(Default)
Modulation Tupek Clear Text
Editing Mode page 41
Filtersy =M Feplace
Show Alpha Table
Sumbol Rate ]

1.000000 Msps OFf
[BCDEFGHIJKLN
D36 Hod SEatar HOPORSTUUIXYZ

u-t88+L]

FREQUEHCY ANPLITUDE Store State

6.000 000 000 00 &z | ~144.00 den storg,Io
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MNADCLPSE, [[[u[N]

Delete Files
These keys manage the table
of DMOD files in internal

Goto Rode storage.
0270772007 12136
Catalog displays DMOD files that
have been previously saved by For details on each key, use key help as described on page 40.

the user.

Return to the top-level ARB Custom Modulation menu, where Digital Modulation Off On is the first
softkey.

In the ARB Custom Modulation menu (page 232), press Digital Mod Setup > Store Custom Dig Mod State
> Store To File.

If there is already a file name from the Catalog of DMOD Files occupying the active entry
area, press the following key: Clear Text

Enter a file name (for example, NADCQPSK) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

Press Enter.

The user-defined, single-carrier, digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a

user-defined, digital modulation state file.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Recalling a Custom TDMA Digital Modulation State

Using this procedure, you will learn how to recall a custom digital modulation state from signal
non-volatile memory.

If you have not created and stored a user-defined, single-carrier, digital modulation state, complete
the steps in the previous sections, Creating a Custom TDMA Digital Modulation State on page 229
and Storing a Custom TDMA Digital Modulation State on page 231, then preset the signal generator
to clear the stored user-defined, digital modulation waveform from volatile ARB memory.

Figure 11-9 Recalling a Custom TDMA Digital Modulation State
Mode > ARB Custom Modulation > Digital Mod Setup >__,

__Quick Setup 7~ For details on each key, use key
Custom Digital help as described on page 40.

ate®
G5H

EDGE

MAOC
POC

Hore 1 of 3 % Loads the highlighted file
into the instrument
memory.

FREQUEHCY ANPLITUDE 5e,

6.000 000 000 00 &z | -144.00 den —

Catalog of DNOD Files in Int Storage 30MB used LGSME free
File Hame Tupe Size Hodified

00

Delete Filem
These keys manage the table
of DMOD files in internal
storage.

Goto Fowe

02/07/2007 16:04

1. In the Quick Setup menu, press Custom Digital Mod State.
2. Highlight the desired file (for example, NADCQPSK).

3. Press SelectFile > Return.

4. Press Digital Modulation 0ff On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After
waveform generation, the custom, digital modulation waveform is available to be modulated on the
RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 228.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Creating a Custom Multicarrier TDMA Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup by
creating a custom, 3-carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:

¢ Creating a Multicarrier Digital Modulation Setup on page 235
¢ Modifying Carrier Frequency Offset on page 235

* Modifying Carrier Power on page 235

* Generating the Waveform on page 235

¢ Configuring the RF Output on page 235

Figure 11-10 Creating a Multicarrier Digital Modulation Setup
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arrier Fhases e Carrier Freq Offset Pouer
1 -500.000 kHz 0.00 dB Delete Row
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- Carriers, Freq Spacing, or to the
Loigs M 2 Carrier Phases).

For details on each key, use key help as described on page 40.
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Creating a Multicarrier Digital Modulation Setup
1. Press Preset.

2. Press Mode > ARB Custom Modulation > Multicarrier 0ff On to On.

3. Press Multicarrier Define > Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset
1. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2.
2. Press -625 > kHz.

Modifying Carrier Power
1. Highlight the Power value (0.00 dB) for the carrier in row 2.
2. Press -10 > dB.

You now have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of
—625 kHz and a power level of —10.00 dBm, as shown in the following figure.

TREQUENCY 6.000 000 000 00 st n“p—LTuanEZIUU den

NCarrier Define

For details on each key, use key
Initialize
Table®

help as described on page 40.
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NMulticarrier Setup: EDGE Carriers (fodified)
farrier Prases: Fixed Carrier Freq Offset Pouer
1 EOGE ~500.000 kHz 0.00 dB Oelete Rou
2 EOGE —B25.000 kHz —10.00 dB
3 | ——————— |
Goto Rodw If Digital Modulation is already on, you

must press Apply Multicarrier to apply

the changes and generate a new
__Aepply B custom multicarrier digital modulation

Multicarrier waveform based on the updated

0777177007 1600 | Nore 1 of 2 values.
e ——

Generating the Waveform
Press Return > Digital Modulation Off On.

This generates a waveform with the custom, multicarrier, EDGE state created in the previous
sections. The display changes to Dig Mod Setup: Multicarrier (Modified). During waveform
generation, the DIGMOD and I/Q annunciators appear and the new custom, multicarrier, EDGE state
is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non-volatile memory, see “Storing
a Custom Multicarrier TDMA Digital Modulation State” on page 236.

Configuring the RF Qutput

1. Set the RF output frequency to 890.01 MHz.

2. Set the output amplitude to —10 dBm.

3. Press RF On/0ff.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide 235



Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator

Storing a Custom Multicarrier TDMA Digital Modulation State

Using this procedure, you learn how to store a custom, multicarrier, TDMA, digital modulation state
to non-volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the
previous section, “Creating a Custom Multicarrier TDMA Digital Modulation State” on page 234.

Figure 11-11 Storing a Custom Multicarrier Softkeys
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For details on each key, use key help as
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1. Return to the top-level Digital Modulation menu, where Digital Modulation Off On is the first softkey.
2. Press Multicarrier Define > More > Load/ Store > Store To File.

If there is already a file name from the Catalog of MDMOD Files occupying the active entry
area, press the following key: Clear Text

3. Enter a file name (for example, EDGEM1) using the alpha keys and the numeric keypad with a
maximum length of 23 characters.

4. Press Enter.

The user-defined, multicarrier, digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
user-defined, digital modulation state file.

Applying Changes to an Active Multicarrier TDMA Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while changes
are made in the Multicarrier Setup table editor, you must apply the changes before the updated
waveform will be generated.

From the Multicarrier Setup table editor, press Apply Multicarrier to apply the changes and generate
a new custom multicarrier digital modulation waveform based on the updated values.
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Using Finite Impulse Response (FIR) Filters

Custom Digital Modulation (Option 431)
Using Finite Impulse Response (FIR) Filters

Finite Impulse Response filters can be used to refine the symbol of the generated waveforms.

Figure 11-12  Filter Menu
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For details on each key, use key help as described on page 40.
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Creating a User-Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8-symbol, windowed
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1.
2.
3.
4.

Press Preset.

Press Mode > ARB Custom Modulation > Digital Mod Setup > Quick Setup > NADC.

Press Filter > Define User FIR.

Press More 1 0of 2 > Delete All Rows > Confirm Delete of All Rows.

This will initialize the table editor as shown in Figure 11-13.

Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide

237



Custom Digital Modulation (Option 431)
Using Finite Impulse Response (FIR) Filters

Figure 11-13 Creating a User-Defined FIR Filter Using the FIR Filter Table Editor

Mode > ARB Custom Modulation> Digital Mod Setup > Filter > Define
User FIR > More 1 of 2 > Delete All Rows > Confirm Delete of All

'

For details on each key, use key help as described on page 40.
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Entering the Coefficient Values
1. Press the Return softkey to get to the first page of the table editor.
2. Use the cursor to highlight the value field for coefficient 0.

3. Use the numeric keypad to type the first value (—0.000076) from Table 11-1. As you press the
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can
correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been

entered.
Table 11-1

Coefficient Value Coefficient Value

0 —0.000076 8 —0.035667
1 —-0.001747 9 —0.116753
2 —0.005144 10 —0.157348
3 —0.004424 11 —0.088484
4 0.007745 12 0.123414
5 0.029610 13 0.442748
6 0.043940 14 0.767329
7 0.025852 15 0.972149
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Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in
reverse order. The signal generator provides a mirror table function that automatically duplicates the
existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the
first of these coefficients (number 16) highlights, as shown in Figure 11-14 on page 239.

Figure 11-14
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\ 18 o.LLa7a versamkie Fatin
19 0. 123014
02/20/2007 £2:20 | Hore 1 of 2

Use the Goto Row
menu to move around
and make changes to
the FIR Values

For details on each key, use key help as described on page 40. coefficient table.

Setting the Oversample Ratio

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the table
editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an oversample
ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or 512
coefficients, the instrument is unable to use the filter. If the oversample ratio is different from the
internal, optimally selected one, then the filter is automatically resampled to an optimal oversample
ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency
dimensions.

1. Press More 10f2 > Display FFT (fast Fourier transform).
Refer to Figure 11-15 on page 240.
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Figure 11-15
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2. Press Return.
3. Press Display Impulse Response.
Refer to Figure 11-16.
Figure 11-16
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4. Press Returnto return to the menu keys.

Storing the Filter to Memory
Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of memory
available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 130, name and store
this file as FIR 1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional
file names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The
amount of memory used is also displayed. The number of files that can be saved depends on the size
of the files and the amount of memory used. Refer to Figure 11-17.

240 Agilent N5161A/62A/81A/82A/83A MXG Signal Generators User’s Guide



Figure 11-17
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Custom Digital Modulation (Option 431)
Modifying a FIR Filter Using the FIR Table Editor
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For details on each key, use key help as described on page 40.

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new

filter design.

Modifying a FIR Filter Using the FIR Table Editor

FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You
can load the FIR table editor with coefficient values from user-defined FIR files stored in

non-volatile memory or from one of the default FIR filters.
the new files.

Then you can modify the values and store
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Loading the Default Gaussian FIR File

Figure 11-18 Loading the Default Gaussian FIR File
Mode > ARB Custom Modulation > Digital Mod

Setup For details on each key, use key help as described on page 40.
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Press Preset.
Press Mode > ARB Custom Modulation > Digital Mod Setup > Quick Setup > NADC.
Press Filter > Define User FIR > More 1 of 2 > Load Default FIR > Gaussian.

Press Filter BbT > 0.300 > Enter.

L
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5. Press Filter Symbols > 8 > Enter.

6. Press Generate.

Custom Digital Modulation (Option 431)
Modifying a FIR Filter Using the FIR Table Editor

NOTE The actual oversample ratio during modulation is automatically selected by the instrument. A
value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per
symbol of the modulation type, and the number of symbols.

7. Press Display Impulse Response (refer to Figure 11-19).

Figure 11-19

For details on each key, use key
help as described on page 40.

8. Press Return.

Modifying the Coefficients
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1. Using the front-panel arrow keys, highlight coefficient 15.

2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 11-20

For details on each key, use key
help as described on page 40.
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Refer to Figure 11-20 on page 243. The graphic display can provide a useful troubleshooting tool
(in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian
response).

4. Press Return.
Highlight coefficient 15.

6. Press 1 > Enter.

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).
1. Press Load/Store > Store To File.

2. Name the file NEWFIR2.

3. Press Enter.

The contents of the current FIR table editor are stored to a file in non-volatile memory and the
catalog of FIR files is updated to show the new file.

Differential Encoding

Differential encoding is a digital-encoding technique whereby a binary value is denoted by a signal
change rather than a particular signal state. Using differential encoding, binary data in any
user-defined I/Q or FSK modulation can be encoded during the modulation process via symbol table
offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user-defined
modulation based on the default 4QAM template, the I/Q Values table editor contains data that
represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values,
1.000000 and —1.000000. The following illustration shows the 4QAM modulation in the I/Q Values
table editor.
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Lomd Default,
I/0 Ualues 1/0 Map
Data I Value 0 Value
00000000 1.000000
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oooooi00 0 -———— 2l oot 1oL
0n
Configure
Differentiale
Encoding
zxz [EMO COOE = More 2 of 2
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The following illustration shows a 4QAM modulation I/Q State Map.

2nd Symbol 1st Symbol
Data = 00000001 Data = 00000000
Distinct values: -1, +1 Distinct values: +1, +1
I/Q0 State Nap
I/0 States: L
+1 10 o}
]
u
i |
1
u
e
° o,
k =1 I Ualue M

3rd Symbol
Data = 00000010
Distinct values: -1, -1

4th Symbol
Data = 00000011
Distinct values: +1, -1

Differential encoding employs relative offsets between the states in the symbol table to encode
user- defined modulation schemes. The Differential State Map table editor is used to introduce
symbol table offset values which in turn cause transitions through the I/Q State Map based on their
associated data value. Whenever a data value is modulated, the offset value stored in the Differential
State Map is used to encode the data by transitioning through the I/Q State Map in a direction and
distance defined by the symbol table offset value.

Entering a value of +1 will cause a 1-state forward transition through the 1/Q State Map, as shown
in the following illustration.

NOTE The following I/Q State Map illustrations show all of the possible state transitions using a
particular symbol table offset value. The actual state-to-state transition would depend upon
the state in which the modulation had started.

As an example, consider the following data/symbol table offset values.

Table 11-2
Data Offset Value
00000000 +1
00000001 -1
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Table 11-2
Data Offset Value
00000010 +2
00000011 0

NOTE

The number of bits per symbol can be expressed using the following formula. Because the

equation is a ceiling function, if the value of x contains a fraction, x is rounded up to the
next whole number.

x= Logzor)

Where x = bits per symbol, and y = the number of differential states.
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These symbol table offsets will result in one of the transitions, as shown.

Data Value 00000000 Data Value 00000001
with Symbol Table Offset +1 with Symbol Table Offset -1
transition 1 state forward transition 1 state backward
I/0 State Map I/0 State Map
. 1/0 states: L . 1/0 states: L
+1 [ 1 +1 [ 1

..Q/\\ Il

-1 T Ualue +1 -1 T Ualue

1
= mERas o

1

= mERas o
+1@

%]

Data Value 00000010 Data Value 00000011
with Symbol Table Offset +2 with Symbol Table Offset 0
transition 2 states forward no transition
I/0 State Map I/0 State fap
. I/0 States: L , I/0 States: L
+1 g 1 +1 [ g al
0 0 : ) ( ;
) )
i | i |
1 1
u u
‘*‘ V2
-1 18 o 119 ),
=1 I Ualue +1 -1 I Value +1

When applied to the user-defined default 4QAM I/Q map, starting from the 1st symbol (data 00), the
differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in the
following illustration.
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1st Symbol 5th Symbol
+1 y 3rd Symbol y
0 Data = 0011100001
u 2nd Symbol 4th Symbol
d
]. Data Value Symbol Table Offset
u 00 +1
01 -1
e 10 +2
11 +0
-1 19 .
-1 I Ualue +1

As you can see from the previous illustration, the 1st and 4th symbols, having the same data value
(00), produce the same state transition (forward 1 state). In differential encoding, symbol values do
not define location; they define the direction and distance of a transition through the 1/Q State Map.

Using Differential Encoding

The signal generator’s Differential State Map table editor enables you to modify the differential
state map associated with user-defined I/Q and user-defined FSK modulations. In this procedure, you
create a user-defined I/Q modulation and then configure, activate, and apply differential encoding to
the user-defined modulation. For more information, see “Differential Encoding” on page 244.

Configuring User-Defined 1/Q Modulation
1. Press Preset.

2. Perform the following keypress sequence required for your format type.

For Custom Format

Press Mode > ARB Custom Modulation > Digital Mod Setup > Modulation Type > Define User1/Q >
More 1 of 2 > Load Default1/Q Map > QAM > 4Q0AM
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For TMDA Formats

Press Mode > ARB Custom Modulation > Digital Mod Setup > Quick Setup (desired format) >
Modulation Type > Define User1/Q > More 10f2 > Load Default1/Q Map > QAM > 4QAM

This loads a default 4QAM I/Q modulation and displays it in the I/Q table editor.

The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11)

Custom Digital Modulation (Option 431)
Differential Encoding

mapped into the I/Q plane using 2 distinct values (1.000000 and —1.000000). These 4 symbols will be

traversed during the modulation process by the symbol table offset values associated with each

symbol of data. Refer to Figure 11-21.

Figure 11-21

Accessing the Differential State Map Table Editor

Press Configure Differential Encoding.

FREQUEHCY

6.000 000 000 00 &z

RF_OFF

User Mod Type

Load/Storew

I/0 Ualues
Data
00000000
00000001
00000010

00000011
00000100

I Ualue

Lomd Default,
I/0 Map

—1.000000
—1.000000
1.000000

Oelete ALl Rowsk

Differential
Encoding
| Off iyl

Configure
Differentiale
Encoding

fore 2 of 2

This opens the Differential State Map table editor, as shown. At this point, you see the data for
the 1st symbol (00000000) and the cursor prepared to accept an offset value.You are now prepared to

create a custom differential encoding for the user-defined default 4QAM I/Q modulation. Refer to
Figure 11-22 on page 249.

Figure 11-22
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Editing the Differential State Map

1.

Press 1 > Enter.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward
through the state map by 1 value when a data value of 0 is modulated.

Press +/- > 1 > Enter.

This encodes the second symbol by adding a symbol table offset of —1. The symbol rotates
backward through the state map by 1 value when a data value of 1 is modulated.

NOTE At this point, the modulation has one bit per symbol. For the first two data values (00000000

and 00000001) only the last bits (the 0 and the 1, respectively) are significant.

Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates forward
through the state map by 2 values when a data value of 10 is modulated.

Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate
through the state map when a data value of 11 is modulated.

NOTE At this point, the modulation has two bits per symbol. For the data values 00000000,

00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.

Applying Custom Differential Encoding

Press Return > Differential Encoding Off On.

This applies the custom differential encoding to a user-defined modulation.

NOTE Notice that (UNSTORED) appears next to Differential State Map on the signal generator’s

display. Differential state maps are associated with the user-defined modulation for which
they were created.

In order to save a custom differential state map, you must store the user-defined modulation
for which it was designed. Otherwise the symbol table offset data is purged when you press
the Confirm Exit From Table Without Saving softkey when exiting from the I/Q or FSK table editor.
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12 Multitone and Two-Tone Waveform Generator
(Option 430)

NOTE For the N5162A the softkey menus and features mentioned in this guide are only available
through the Web- Enabled MXG ATE or via SCPI commands. Refer to the Installation Guide,
the Programming Guide, and to the SCPI Command Reference.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to
Basic Operation on page 39 and familiarize yourself with the information in that chapter.

This feature is available only in N5162A/82A Agilent MXG Vector Signal Generators with Option 430.
Option 430 requires Option 651, 652, or 654.

Creating a Custom Two-Tone Waveform

Using the Two-Tone menu, you can define, and modify user-defined Two-Tone waveforms. Two-Tone
waveforms are generated by the dual arbitrary waveform generator.

The section Using Two-Tone Modulation on page 252 teaches you how to perform the following tasks:
¢ Creating a Two-Tone Waveform on page 253

¢ Viewing a Two-Tone Waveform on page 254

¢ Minimizing Carrier Feedthrough on page 255

¢ Changing the Alignment of a Two-Tone Waveform on page 256

Creating a Custom Multitone Waveform

Using the Multitone Setup table editor, you can define, modify and store user-defined multitone
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 258 teaches you how to perform the following tasks:
e Initializing the Multitone Setup Table Editor on page 258

¢ Configuring Tone Powers and Tone Phases on page 259

* Removing a Tone on page 259

* Generating the Waveform on page 259

¢ Configuring the RF Output on page 260
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Using Two-Tone Modulation

In the following sections, this chapter describes the two-tone mode, which is available only in
N5162A/82A Agilent MXG Vector signal generators with Option 430:

¢ Creating a Two-Tone Waveform on page 253

¢ Viewing a Two-Tone Waveform on page 254

¢ Minimizing Carrier Feedthrough on page 255

¢ Changing the Alignment of a Two-Tone Waveform on page 256

See also: Saving a Waveform’s Settings & Parameters on page 136

NOTE For more information about two-tone waveform characteristics, and the two-tone standard,
download Application Note 1410 from our website by going to htip://www.agilent.com and
searching for “AN 1410” in Test & Measurement.
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Two Tone Modulation Softkeys

Mode

Multitone and Two-Tone Waveform Generator (Option 430)
Using Two-Tone Modulation

Becomes active when a change is made to
the Freq Separation or Alignment Softkeys

are changed.

Becomes active when Two Tone is

turned On.
Nodulation Mode Tuo Tone 7| 7_Arb Setup Y _
Hoise Setup ~
Two Tone
Dual AREs an Fieal-time hoise
- an
Freq Separation Real-time AWGH g i
Lot it S [Torrier to poiss
Ratio
0.00 dB page 211
Feal-time

flionment
Lo+t NRERIAN Aio

Right
THo-Tonew ( j

ARE SetupM

Phase Moise Setup® Carrier Bandwidth
1.000 Hz

Moize Bandwidth
1.000 Hz

I NV

Modulator Atten
11.16 dB
HManual

Multitonesr—page 258

More 1 of 2 %

fore 1 of 2

Tuo Tone page 216
v Easeband
Freguency Of fset
Aot A 0.000 Hz
ctive when
Two-Tone enabled. utiTaiﬁgg’

N

\ml

see page 129

For softkey usage,  (Two-Tone’s Arb Setup is similar to the Dual Arb Setup.)

see page 129

Exceptions:
> No Waveform Runtime Scaling softkey,
> No Multi-BBG Sync Setup softkey, and

For details on each key, use key help as described on page 40. > No DAC Over-Range Protection softkey

Creating a Two-Tone Waveform

This procedure describes how to create a basic, centered, two-tone waveform.
Preset the signal generator.

Set the signal generator RF output frequency to 6 GHz.

Set the signal generator RF output amplitude to -10 dBm.

Press Mode > Two-Tone > Freq Separation > 10 > MHz.

Press Two Tone Off On to On.

S o o

Turn on the RF output.

The two-tone signal is now available at the signal generator RF OUTPUT connector. Figure 12-1 on
page 254 shows what the signal generator display should look like after all steps have been
completed. Notice that the T-TONE, I/Q, annunciators are displayed; the RF ON, MOD ON LEDs are on;
and the parameter settings for the signal are shown in the status area of the signal generator display.
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Figure 12-1

Mode > Two-Tone

FREQUEHCY AAPLITUDE Tuo Tone
6.000 000 000 00 &= 0.00 den Lo
I/0|T-TOHE
Freq separation: 1(0.000 000 MHz Freq Separation
HRBTTONE Freq Separgtion: 10.000000MHz -
on Alignment: Center . ﬂllggr{gg%
For details on
each key, use
key help as
described on IRFlS) BEVED
page 40. 0272772007 11:33| Tore 1 of 2

Viewing a Two-Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two-tone waveform and
its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are
using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 6 GHz.

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a -10 dBm reference.
5

Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products.
A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.
7. Set the attenuation to 4 dB, so you're not overdriving the input mixer on the spectrum analyzer.

You should now see a two-tone waveform with a 6 GHz center carrier frequency that is similar to the
one shown in Figure 12-2 on page 255. You will also see IMD products at 10 MHz intervals above and
below the generated tones, and a carrier feedthrough spike at the center frequency with carrier
feedthrough distortion products at 10 MHz intervals above and below the center carrier frequency.
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Figure 12-2
Channels
Intermodulation Carrier
Distortion Feedthrqugh
For details on each key, use key help as described on page 40. Carrier Feedthrough

Distortion

Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power
between the tones and their intermodulation distortion products. Before beginning this procedure, it
is important that a recent I/Q calibration has been performed on the instrument. The procedure for
performing an I/Q calibration (refer to “I/Q Calibration” on page 187).

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100-200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make
adjustments.

2. On the signal generator, press 1/Q> 1/Q Adjustments > 1/Q Adjustments Off On to On.

w®

Press Internal Baseband Adjustments > | Offset and turn the rotary knob while observing the carrier
feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce
the feedthrough level. Adjust the level as low as possible.

Press Q@ Offset and turn the rotary knob to further reduce the carrier feedthrough level.
Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

On the spectrum analyzer, return the resolution bandwidth to its previous setting.

NS o e

Turn on waveform averaging.
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8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which
should be spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product.

You should now see a display that is similar to the one shown in Figure 12-3 on page 256. Your
optimized two-tone signal can now be used to measure the IMD products generated by a
device- under- test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to
periodically readjust your I and Q offsets to keep your signal optimized.

Figure 12-3
Main Marker

Minimized
Carrier
Feedthrough

Marker a
10.200000 MHz
-68.939 dB Delta Marker

| |
'w"n'rh'?v’ bty k""*‘.‘ﬁ" et I |"'-’-ﬁ1,"'|,I'i,"r'q«'}fi.\"l‘r-,l"f»ih'*ﬁlf'

)
A f.'.-'n’ﬁ.-.«‘ i

For details on each
key, use key help as
described on page 40.

1 kHz

Changing the Alignment of a Two-Tone Waveform

This procedure describes how to align a two-tone waveform left or right, relative to the center carrier
frequency. Because the frequency of one of the tones is the same as the carrier frequency, this
alignment typically hides any carrier feedthrough. However, image frequency interference caused by
left or right alignment may cause minor distortion of the two-tone signal. This procedure builds upon
the previous procedure.

1. On the signal generator, press Mode > Two Tone > Alignment Left Cent Right to Left.
2. Press Apply Settings to regenerate the waveform.
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NOTE Whenever a change is made to a setting while the two-tone generator is operating
(Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey
before the updated waveform will be generated. When you apply a change, the baseband
generator creates a two-tone waveform using the new settings and replaces the existing
waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more
quickly. You should now see a left-aligned two-tone waveform that is similar to the one shown in
Figure 12-4.

Figure 12-4
Upper Tone
Aligned with
Two-Tone Carrier
Channels Fregliency
Intermodulation
Distortion
For details on each key, use key help as described on page 40. Carrier

Frequency
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Using Multitone Modulation

Multitone Modulation Softkeys

This softkey is active if changes have been
made to the current Multitone waveform in
the table editor. The softkey must be
pressed to apply those changes.

Mode
\
1 Nultitone A
¢ Mult itone
| on
Nodulation Hode \
Initialize
Dual ARB» \ Table page 258
Edit.
Custom M age 259
Maodu Iat. ion® Table pag
E page 260 / Arb Setu > Arb Setup 7 \
ARE Sample Clock Easeband
1.0000000 HHz FrequencH ngsﬁt
. z
TE=TerEn Load/Storew page 260
RN Feal-time AWGN
Tore 1 of 2 Setup® W
Multitones
Real-time
More 1 of 2 > Fhase Moise Setup
NMultitone
ARE Setupk !
Modulator Atten
8.98 dB
; Marual
Active when v e iy
Multitone enabledA/ More 1 of 2 %) |
Marker
For softkey usage, Utilities page 128
see page 128 see page 129
A (Multitone’s ARB Setup is similar to Dual Arb Setup.)

Exceptions:
> No Waveform Runtime Scaling softkey,

> No Multi-BBG Sync Setup softkey, and
> No DAC Over-Range Protection softkey
For details on each key, use key help as
described on page 40.

Initializing the Multitone Setup Table Editor

1. Press Preset.

2. Press Mode > Multitone

3. Press Initialize Table > Number of Tones > 5 > Enter.
4

Press Freq Spacing > 20 > kHz.
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Figure 12-5
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Tnit Tones The Random Seed
softkey--that affects the
__Random Seed Multitone’s phase

PERE Random values--is not used in the
following examples and is
shown for reference, only.

For details on each key, use key help as described on page 40. W

5. Press Done.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at
the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center
tone.

Configuring Tone Powers and Tone Phases

1. Highlight the value (0 dB) in the Power column for the tone in row 2.
2. Press Edit Table > Edit ltem > -4.5 > dB.

3. Highlight the value (0) in the Phase column for the tone in row 2.

4. Press Editltem > 123 > deg.

Removing a Tone
1. Highlight the value (On) in the State column for the tone in row 4.
2. Press Toggle State.

Generating the Waveform

Press Return > Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. During
waveform generation, the M-TONE and I/Q annunciators activate and the multitone waveform is
stored in volatile ARB memory. The waveform is now modulating the RF carrier.
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Configuring the RF Output

1. Set the RF output frequency to 100 MHz.
2. Set the output amplitude to 0 dBm.

3. Press RF On/0ff.

The multitone waveform is now available at the signal generator’s RF OUTPUT connector.

Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made in
the Multitone Setup table editor, you must apply the changes before the updated waveform will be
generated.

From the Multitone Setup table editor, press the following key to apply the changes and generate a
multitone waveform based on the updated values: Apply Multitone

Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone
waveform, complete the steps in the previous section, Creating a Custom Multitone Waveform on page
251.

1. Press Load/Store > Store To File.

If there is already a file name from the Catalog of MTONE Files occupying the active entry
area, press the following keys (see page 41):

Edit Keys > Clear Text

2. Enter a file name (for example, STONE) using the alpha keys and the numeric keypad with a
maximum length of 23 characters (see page 41).

3. Press Enter.

The multitone waveform is now stored in the Catalog of MTONE Files.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a
multitone waveform file. Similarly, the multitone settings are not stored as part of the
instrument state. Therefore, in most cases you should save both the instrument states and
the multitone settings to be able to restore all of your settings later.
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Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s
memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous
sections, Creating a Custom Multitone Waveform on page 251 and Storing a Multitone Waveform on
page 260, then preset the signal generator to clear the stored multitone waveform from volatile ARB
memory.

1.

2
3.
4.
5

Press Mode > Multitone.

Press Load/Store.

Highlight the desired file (for example, STONE).
Press Load From Selected File > Confirm Load From File.
Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the
multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 260.
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13 Working in a Secure Environment

NOTE

For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

* Understanding Memory Types on page 263

* Removing Data from Memory (Option 006 Only) on page 266

* Using the Secure Display (Option 006 Only) on page 269

Understanding Memory Types

The signal generator has several memory types, and each is used to store a specific type of data.
Before removing sensitive data, you should to understand how each memory type is used. The
following tables describe each memory type used in the base instrument, and optional baseband

generator.

Table 13-1 Base Instrument Memory

includes flatness calibration,
instrument states, and sweep
lists

| E

0. ©

SR (=T
Memory g g g &
Type and a g = “; Purpose/Contents Data Input Method | Location in Instrument and Remarks
Size 9 S8

23| &

S g « =

= 13

ES| 8BS

BZ|Aas
Main Yes No firmware operating memory operating system CPU board, not battery backed.
Memory
(RAM) no user data
32 MB
Main Yes Yes factory firmware upgrades CPU board (same chip as firmware memory,
Memory calibration/configuration data | and user-saved but managed separately)
(Flash) data? . . .

ayser file system, which Because this memory chip contains 8 MB of

8 MB user data (described here) and 8 MB of

firmware memory, a full-chip erase is not

desirable. User data areas are selectively and

completely sanitized when you perform the
Erase and Sanitize function.
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Table 13-1 Base Instrument Memory (Continued)

=| &
=) =]
= =
Memory El g TE
Type and a g 5 dg" Purpose/Contents Data Input Method | Location in Instrument and Remarks
Size ) ol
23|~
EE| =%
28| 8&
BEzZ|AB
Firmware No Yes main firmware image factory installed or | CPU board (same chip as main flash memory,
Memory firmware upgrade but managed separately)
(Flash)

During normal operation, this memory cannot
8 MB be overwritten. It is only overwritten during
the firmware installation or upgrade process.

Because this memory chip contains 8 MB of
user data and 8 MB of firmware memory
(described here), a full-chip erase is not
desirable. User data areas are selectively and
completely sanitized when you perform the
Erase and Sanitize function.

Bootrom No Yes CPU bootup parameters factory programmed | CPU board
Memor;
(EEPRgM) no user data During normal operation, this memory cannot
Yes Yes LAN configuration Front panel entry or be overwritten or erased except for LAN
8 kB g bane Y configuration. This read-only data is
remotely
programmed at the factory.
Calibration | No Yes factory factory or service RF Board
Data calibration/configuration data | only
(Flash) backup
256 kB no user data
LCD No No display buffer operating system RF board, not battery backed.
Display
Memory
(RAM)
160 kB
Front Panel | No No front panel keyboard operating system Front Panel board
Memory controller firmware
(Flash)
no user data
32 kB

@Analog instruments only
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Table 13-2 Baseband Generator Memory (Options 651,652, 654)

| E
.S ©
=

23 |=7F
Memory 55 g g
Type and a 81 = g Purpose/Contents Data Input Method |Remarks
Size 3 S8

2% | &

EE| =%

R

EZ|Aas
Waveform Yes No waveforms (including normal user Not battery backed.
Memory header and marker data) operation
(RAM)
<320 MB
Persistent Yes Yes all user data normal user User data is completely sanitized when you
Memory operation perform the Erase and Sanitize function.
(Flash)®
4 GB
Calibration No Yes no user data factory or service
Data Memory only
(Flash)
128 kB

For serial numbers <MY4818xxxx, US4818xxxx, and SG4818xxxx, the persistent memory value = 512 MB.
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Removing Data from Memory (Option 006 Only)

When moving the signal generator from a secure development environment, there are several security
functions you can use to remove classified proprietary information from the instrument. Security
functions also have equivalent SCPI commands for remote operation (“System Subsystem (:SYSTem)”
commands; refer to the SCPI Command Reference)

CAUTION The signal generator has several memory types (described in Table 13-1 on page 263,
and Table 13-2 on page 265), and each is used to store a specific type of data. Before
removing sensitive data, understand how each memory type is used.

[Fﬂe

v

Catalog &
Catalog Tupe S
(L1 Page 62 Confirm Delete __ Security
—® |Confirm Delete Of Erase ALLM Below
Oelete Filew All Files Security Level
W Erase and Hone
3 M
Copu File Overwrite AlL
Catalo
Erase and
PO Sanitize ALLY page 267 SrEss See
Gota Rokqe Secure Mode on
X age 268
_ Erter Secure Modew Querdrite pag
Oelete ALl Filesk Securitum] >
Tore 1 of 2S¢ Security Level > Sanitize
X (Mone ) ® Ll
USE File Managerw
For details on each key, \\'\\A‘\‘
use key help as described on T L/USE
nLerna
page 40. Storage Selectionm
USE if present)
More 2 of 2
Erase All
Removes: All user files, user flatness calibrations, user I/Q calibrations
Resets: All table editors with original factory values, ensuring that user data and
configurations are not accessible or viewable
Does Not: Sanitize memory
Time to Erase: typically < 1 minute, depending on the number of files.
To Start: Press File > More > Security > Erase All > Confirm Erase

NOTE This is not File > Delete All Files, which deletes all user files but does not reset table editors.
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Erase and Overwrite All

This performs the same actions as Erase All, plus it clears and overwrites the various memory types
in compliance with the National Industry Security Program Operating Manual (NISPOM) DOD
5220.22M.

CPU Flash Overwrites all addressable locations with random characters and then erases the
flash blocks. This accomplishes the same purpose as a chip erase. System files are
restored after erase.

To Start: Press File > More > Security > Erase and Overwrite All > Confirm Erase

Erase and Sanitize All

This performs the same actions as Erase and Overwrite All and then adds more overwriting actions.
After executing this function, you must manually perform the additional steps described below for the
sanitization to comply with the National Industry Security Program Operating Manual (NISPOM) DOD
5220.22M.

CPU Flash Overwrites all addressable locations with random characters and then erases the
flash blocks. This accomplishes the same purpose as a chip erase. System files
are restored after erase.

BBG Persistent (Vector instruments only) Overwrites all addressable locations with random
Memory (Flash) characters and then erases the flash blocks. This accomplishes the same purpose
as a chip erase. System files are restored after erase.

To Start: Press File > More > Security > Erase and Sanitize All > Confirm Sanitize
Removing Persistent State Information Not Removed During Erase

Persistent State

The persistent state settings contain instrument setup information that can be toggled within
predefined limits such as display intensity, contrast and the GPIB address. In vector models, the user
1Q cal is also saved in this area.

The following key presses or SCPI commands can be used to clear the IQ cal file and to set the
operating states that are not affected by a signal generator power-on, preset, or *RST command to
their factory default:

Instrument Setup

¢ On the Agilent MXG front panel, press: Utility > Power On/Preset > Restore System Settings to Default
Values > Confirm Restore Sys Settings to Default Values

* Or send this command to the Agilent MXG: :SYSTem:PRESet:PERSistent
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LAN Setup

The LAN setup (hostname, IP address, subnet mask, and default gateway) information is not
defaulted with a signal generator power-on or *RST command. This information can only be changed
or cleared by entering new data.

User 1Q Cal File (Vector Models Only)

When a user-defined IQ calibration has been performed, the cal file data is removed by setting the
cal file to default, as follows:

¢ On the front panel, press: 1/Q > 1/Q Calibration > Revert to Default Cal Settings
* Or send this command to the Agilent MXG: :CAL:IQ:DEF

Secure Mode

CAUTION Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease
the security level; the erasure actions for that security level execute at the next power
cycle. Once you activate secure mode, you can only increase the security level until you
cycle power. For example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but secure mode is
not activated.

Secure mode automatically applies the selected Security Level action the next time the instrument’s
power cycles.

To Set the Level: Press File > More > Security > Security Level and choose from the following:

— None = factory preset, no user information is lost
— Erase =Erase All

— Overwrite =Erase and Overwrite All

— Sanitize = Erase and Sanitize All

To Activate: Press File > More > Security > Enter Secure Mode > Confirm

The softkey changes to Secure Mode Activated.

Securing a Nonfunctioning Instrument

If the instrument is not functioning and you are unable to use the security functions, you must
physically remove the processor board and, for vector instruments, the A4 Memory Chip from the
instrument. Once these assemblies are removed, choose one of the following options:

¢ Discard the board (or boards) and send the instrument to a repair facility. A new board (or
boards) will be installed and the instrument will be repaired and calibrated. If the instrument is
still under warranty, you will not be charged for new boards.

¢ If you have another working instrument, install the board (or boards) into that instrument and
erase the memory. Then reinstall the board (or boards) back into the nonworking instrument and
send it to a repair facility for repair and calibration. If you discover that one or both of the
boards do not function in the working instrument, discard the nonfunctioning board and note on
the repair order that it caused the instrument failure. If the instrument is still under warranty,
you will not be charged for new boards.
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For instructions on how to remove and replace boards, refer to the Service Guide.

Using the Secure Display (Option 006 Only)

This function prevents unauthorized personnel from reading the instrument display and tampering
with the current configuration through the front panel. The display blanks, except for the message
shown in the following figure, and the front panel keys are disabled.

To re-enable the display and front panel keys, cycle the power.

Figure 13-1 Secure Display Softkeys
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For details on each key, use key help
as described on page 40.
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14 Troubleshooting

NOTE For the N5161A/62A the softkey menus and features mentioned in this guide are only
available through the Web-Enabled MXG ATE or via SCPI commands. Refer to the
Installation Guide, the Programming Guide, and to the SCPI Command Reference.

* Display on page 272
* Signal Generator Lock-Up on page 272
* RF Output on page 272

— No RF Output

— Power Supply Shuts Down

— No Modulation at the RF Output

— RF Output Power too Low

— Distortion

— Signal Loss While Working with a Spectrum Analyzer
— Signal Loss While Working with a Mixer

* Sweep on page 275

— Cannot Turn Off Sweep

— Sweep Appears Stalled

— Incorrect List Sweep Dwell Time

— List Sweep Information is Missing from a Recalled Register
— Amplitude Does Not Change in List or Step Sweep

* Internal Media Data Storage on page 276

— Instrument State Saved but the Register is Empty or Contains the Wrong State
* USB Media Data Storage on page 276

— Instrument Recognizes USB Media Connection, but Does Not Display Files
* Preset on page 276

— The Signal Generator Does Not Respond
— Pressing Preset Performs a User Preset

* Error Messages on page 277

* Front Panel Tests on page 278

* Self Test on page 278

* Licenses on page 279

* Contacting Agilent Technologies on page 279

— Returning a Signal Generator to Agilent
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Troubleshooting
Display

Display

The Display is Too Dark to Read

Both brightness and contrast may be set to minimum. Use the figure in “Display Settings” on page 26
to locate the brightness and contrast softkeys and adjust their values so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black.
Cycle instrument power.

Signal Generator Lock-Up

* Ensure that the signal generator is not in remote mode (the R annunciator shows on the display).
To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

¢ Ensure that the signal generator is not in local lockout, which prevents front panel operation. For
information on local lockout, refer to the Programming Guide.

e If a progress bar appears on the signal generator display, an operation is in progress.
* Preset the signal generator.

¢ Cycle power on the signal generator.

RF Output

No RF Qutput
¢ Check the RF ON/OFF LED (shown on page 5). If it is off, press RF On/Off to turn the output on.
¢ Ensure that the amplitude is set within the signal generator’s range.

e If the instrument is playing a waveform, ensure that marker polarity and routing settings are
correct (see “Saving Marker Polarity and Routing Settings” on page 143).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the
instrument, send the signal generator to an Agilent service center for repair (see page 279).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are on.
See also, page 58.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on (the
I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating
within the signal generator’s specified limits.
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Troubleshooting
RF Output

RF OQutput Power too Low
¢ If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:
Press Amptd > More 10f 2 > Amptd Offset > 0 > dB. See also, “Setting an Output Offset” on page 104.
¢ If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:
1. Press Amptd > More > Amptd Ref Off On until Off highlights.
2. Reset the output power to the desired level.
See also, “Setting an Output Reference” on page 105.
e If you are using the signal generator with an external mixer, see page 273.
¢ If you are using the signal generator with a spectrum analyzer, see page 273.

e If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display
the sequence header information and recalculate the RMS value (see page 136).

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the RF output when you use the signal
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating mode
(described on page 103).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF output.
The rate of the undesired AM equals the difference in frequency between the spectrum analyzer’s LO
feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes.
See:
e “ALC Off Mode” on page 103

and

¢ “Power Search Mode” on page 104

Signal Loss While Working with a Mixer

To fix signal loss at the signal generator’s RF output during low-amplitude coupled operation with a
mixer, add attenuation and increase the RF output amplitude.
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Troubleshooting
RF Output

The figure at right shows a
configuration in which the Effects of Reverse Power on ALC
signal generator provides a
low amplitude signal to a
mixer.

Signal Generator
Output Control

The internally leveled signal
generator RF output (and ALC ALC Level RF Output Mixer
level) is —8 dBm. The mixer is =-8dBm =-8dBm
driven with an LO of +10 dBm A Lovel -
and has an LO-to-RF isolation Control -
of 15 dB. The resulting
-5 dBm LO feedthrough
enters the signal generator’s Detector Detector LO Feedthru LO Level

RF output connector and measures G measures =-5dBm =+10dBm

. . ~5dBm
arrives at the internal —8dBm

ALC level reverse
detector. power

Depending on frequency, it is
possible for most of this LO
feedthrough energy to enter the detector. Because the detector responds to its total input power
regardless of frequency, this excess energy causes the ALC to reduce the RF output. In this example,
the reverse power across the detector is actually greater than the ALC level, which can result in loss
of signal at the RF output.

The solution at right shows a
similar configuration with the
addition of a 10 dB

attenuator connected between

Reverse Power Solution

the RF output of the signal Signal Generator
generator and the input of Output Control
the mixer. The signal ALC Level/ .
generator’s ALC level RF Output RF Output  Mixer
increases to +2 dBm and =+2dBm =-8dBm
transmits through a 10 dB RF Level > 1048 >
i > ———» L0
attenuator to achieve the Control ATTEN

required —8 dBm amplitude
at the mixer input.

.

L. Detector Detector LO Feedthru LO Level
Compared to the original measures measures =_5dBm =+10dBm
configuration, the ALC level +2 dBm ~15dBm
is 10 dB higher while the ALC level ;‘(;;sre F

attenuator reduces the LO
feedthrough (and the signal
generator’s RF output) by 10
dB. Using the attenuated
configuration, the detector is exposed to a +2 dBm desired signal versus the —15 dBm undesired LO
feedthrough. This 17 dB difference between desired and undesired energy results in a maximum

0.1 dB shift in the signal generator’s RF output level.
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Troubleshooting
Sweep

Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see
“Configuring a Swept Output” on page 46). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq
Sweep > Sweep > Amptd
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey.

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to Free
Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time
1. Press Sweep > More > Configure List Sweep.
2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them.
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step
sweep rather than list sweep.

See also, “Configuring a Swept Output” on page 46.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register.
Only the current list sweep is available to the signal generator. You can store list sweep data in the
instrument catalog (see “Loading (Recalling) a Stored File” on page 65).

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep
type is set to frequency (Freq) or waveform.
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Troubleshooting
Internal Media Data Storage

Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State

If the register number you intended to use is empty or contains the wrong instrument state, recall
register 99. If you selected a register number greater than 99, the signal generator automatically saves
the instrument state in register 99.

See also, “Working with Instrument State Files” on page 67.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the
signal generator; try a different USB media. Refer to http://www.agilent.com/find/mxg for details on
compatible USB media.

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which
locks the keypad.

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward-compatible SCPI command. To return the signal
generator to normal use, send the command :SYST:PRESet:TYPE NORM.

For information on SCPI commands, refer to the SCPI Command Reference.
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Troubleshooting
Error Messages

Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query
error does not generate a device-specific, execution, or command error.

Query Errors (-499 to -400) indicate that the instrument’s output queue control has detected a
problem with the message exchange protocol described in IEEE 488.2) Chapter 6. Errors in this class
set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors
correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

¢ Either an attempt is being made to read data from the output queue when no output is either
present or pending, or

¢ data in the output queue has been lost.

Device Specific Errors (-399 to -300, 201 to 703, and 800 to 810) indicate that a device operation
did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes
are also used for self-test response errors. Errors in this class set the device-specific error bit (bit 3)
in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that
the instrument detected an error within the GPIB system, within the instrument’s firmware or
hardware, during the transfer of block data, or during calibration.

Execution Errors (-299 to -200) indicate that an error has been detected by the instrument’s
execution control block. Errors in this class set the execution error bit (bit 4) in the event status
register (IEEE 488.2, section 11.5.1). In this case:

¢ Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of
its legal input range or is otherwise inconsistent with the device’s capabilities, or

¢ a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed.
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (-199 to -100) indicate that the instrument’s parser detected an IEEE 488.2
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE
488.2, section 11.5.1). In this case:

¢ Either an IEEE 488.2 syntax error has been detected by the parser (a control-to-device message
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data
element that violates device listening formats or whose type is unacceptable to the device.), or

* an unrecognized header was received. These include incorrect device-specific headers and
incorrect or unimplemented IEEE 488.2 common commands.

Error Message File

A complete list of error messages is provided on the CDROM supplied with the instrument. In the
error message file, an explanation is generally included with each error to further clarify its meaning.
The error messages are listed numerically. In cases where there are multiple listings for the same
error number, the messages are in alphabetical order.
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Front Panel Tests

Front Panel Tests

Utility Instrument. Tnfo
1/0 Confighk Dimgrostic Infoe Front Panel Test Set all display pixels to thg selected color.
] ?iXElv / To return to normal operation, press any key.

Creen Tests

gégﬁggﬁgﬁggb Options Infow
LED Blink Testw Blink RF On/0ff, Mod on/0ff, and More LEDs
Displau Self Teste
Keu Test Displays a keyboard map. o )
Paower On/, Installed As you press a key, the map indicates the key location.

Praset Board Info®

FPG Test

Instrument InfoM—® [Front Panel Testsy—— \ Correct operation:

M‘\ Full CCW =~10
Tore 1 oF 2 Full CW =10

For details on each key, use key help
as described on page 40.

Self Test

The self test is a series of internal tests that checks different signal generator functions.

NOTE MXG N5183A with non 1E1 Option (no attentuator), a warning message will be displayed on
the Self Test Summary window as shown below.

Self Test Summary

The current status of self test is: Success
All =self tests have passed.

5 HARMIMG =% HARMIMNG i HARMING ==
## TO prevent damage to uour device, disconnect it ==
#= from the RF Output before running self tests. =%
== Poler levels generated during the self tests can ==
## damage sensitive devices. i

The attenuator will auto
set to maximum value
before self test executes
and resets to nominal at
conclusion.
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Troubleshooting
Licenses

Licenses

A Time-Based License Quits Working

¢ The instrument’s time or date may have been reset forward causing the time-based license to
expire.

* The instrument’s time or date may have been reset backward more than approximately 25 hours,
causing the instrument to ignore time-based licenses.

See page 28 for details and cautions on setting time and date.

Cannot Load a Time-Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours,
causing the instrument to ignore time-based licenses.

See page 28 for details and cautions on setting time and date.

Contacting Agilent Technologies

* assistance with test and measurements needs, and information on finding a local Agilent office:
hitp://www.agilent.com/find/assist

e accessories or documentation: http://www.agilent.com/find/mxg
* new firmware releases: hitp:/www.agilent.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model
number and full serial number. With this information, the Agilent representative can
determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent

Use the following steps to return a signal generator to Agilent Technologies for servicing:
1. Gather as much information as possible regarding the signal generator’s problem.

2. Call the phone number listed on the Internet (http:/www.agilent.com/find/assist) that is specific
to your geographic location. If you do not have access to the Internet, contact your Agilent field
engineer.

After sharing information regarding the signal generator and its condition, you will receive
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar
packaging to properly protect the signal generator.
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Contacting Agilent Technologies
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Glossary

A

Active Entry The currently selected, and
therefore editable, entry or parameter

ARB Arbitrary waveform generator

AWG Arbitrary waveform generator. Additive
white Gaussian noise

B
BBG Media Baseband generator media. Volatile

memory, where waveform files are played or
edited.

BNC Connector Bayonet Neill- Concelman
connector. A type of RF connector used to
terminate coaxial cable.

c

CCW Counterclockwise
C/N Carrier-to-noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 49), the
time that the signal is settled and you can make
a measurement before the sweep moves to the
next point.

E

EVM Error vector magnitude; the magnitude of
the vector difference at a given instant between
the ideal reference signal and the measured
signal.

F

Filter factor Alpha The filter’s alpha coefficient.
It is only valid for root nyquist and nyquist
filters.

Filter Factor BbT The filter’s

bandwidth-bit- time (BbT). It is only valid for a
Gaussian filter (similar to alpha). BbT is defined
by the GSM standard as 0.3 and by the DECT
standard as 0.5.

G

Gaussian filter The Gaussian filter does not
have a zero Inter-Symbol Interference (ISI).
Wireless system architects must decide just how
much of the ISI can be tolerated in a system and
combine that with noise and interference. The
Gaussian filter is gaussian shaped in both the
time and frequency domains, and it does not
ring like the root nyquist filters do. The effects
of this filter in the time domain are relatively
short and each symbol interacts significantly (or
causes ISI) with only the preceding and
succeeding symbols. This reduces the tendency
for particular sequences of symbols to interact,
which makes amplifiers easier to build and more
efficient.

GPIB General purpose interface bus. An 8-bit
parallel bus common on test equipment.

H

Hardkey A labeled button on the instrument.
|

IF Intermediate frequency

Int Media Internal media. Non—volatile signal

generator memory, where waveform files are
stored.
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IP Internet protocol. The network layer for the
TCP/IP protocol suite widely used on Ethernet
networks.

L

LAN Local area network
LO Local oscillator

LXI LAN extension for instrumentation. An
instrumentation platform based on industry
standard Ethernet technology designed to
provide modularity, flexibility, and performance
to small- and medium-sized systems. See also,
hitp://www.lxistandard.org

Modulation Format Custom modulation, Two
Tone, or Multitone.

Modulation Mode Dual ARB, Custom
modulation, Two Tone, or Multitone.

Modulation Standard Refers to a Cellular
standard format (i.e. NADC, PDC, PHS, etc.).

Modulation Type Refers to the various 1/Q
constellation types (i.e. PSK, MSK, FSK, C4FM,
etc.)

N

Non-—volatile That which survives a power cycle
(such as files stored in USB media).

Nyquist filter Also referred to as a cosine filter.
These filters have the property that their
impulse response rings at the symbol rate.
Adjacent symbols do not interfere with each
other at the symbol times because the response
equals zero at all symbol times except the center
(desired) one.

P

Persistent That which is unaffected by preset,
user preset, or power cycle.

Point- to- point Time In a step sweep (page 49),
the sum of the dwell time, processing time,
switching time, and settling time.

Rectangular filter Also referred to as a ideal
low pass filter. These filters have very steep
cut- off characteristics. The pass band is set to
equal the symbol rate of the signal. Due to a
finite number of coefficients, the filter has a
predefined length and is not truly “ideal”. The
resulting ripple in the cut-off band is effectively
minimized with a Hamming window. This filter
is recommended for achieving optimal ACP. A
symbol length of 32 or greater is recommended
for this filter.

Root Nyquist filter Also referred to as a Root
cosine filter. These filters have the property that
their impulse response rings at the symbol rate.
Adjacent symbols do not interfere with each
other at the symbol times because the response
equals zero at all symbol times except the center
(desired) one. Root nyquist filters heavily filter
the signal without blurring the symbols together
at the symbol times. This is important for
transmitting information without errors caused
by ISI. Note that ISI does exist at all times
except the symbol (decision) times. A cascade of
two of these filters has the transfer function of
a Nyquist filter. One is in the transmitter, the
other in the receiver, so that the system taken
as a whole has the zero-ISI properties of an ISI
filter.

RMS Root mean square. A time-varying signal’s
effective value (the equivalent DC voltage
required to generate the equivalent heat across
a given resistor). For a sinewave, RMS = 0.707 x
peak value.

S

Softkey A button located along the instrument’s
display that performs whatever function is
shown next to it on that display.
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T

TCP Transmission control protocol. The most
common transport layer protocol used on
Ethernet and the Internet.

Terminator A unit indicator (such as Hz or
dBm) that completes an entry. For example, for
the entry 100 Hz, Hz is the terminator.

Type-N Connector Threaded RF connector used
to join coaxial cables.

U

USB Universal serial bus. See also,
hitp://www.usb.org

User FIR Selects a user-defined set of
coefficient values. Each line in the FIR values
table contains one coefficient value. The number
of coefficient values listed must be a multiple of
the selected oversampling ratio. Each coefficient
applies to both I and Q@ components.

vV

Volatile That which does not survive a power
cycle (such as files stored in BBG media).
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Symbols

OM
annunciator, 11, 13
dc offset, removing, 75
hardkey, 73
softkeys, 73, 75
# points softkey, 49
# Skipped Points softkey, 147

Numerics
10 MHz OUT connector, 17, 23
100Base-T LAN cable, 30
128 QAM softkey, 225
1410, application note, 252
16-Lvl FSK softkey, 225
16QAM softkey, 225
256 QAM softkey, 225
2-Lvl FSK softkey, 225
32QAM softkey, 225
430, option
multitone mode, 258
two- tone, 252
two-tone mode, 252
4-Lvl FSK softkey, 225
4QAM softkey, 225
5-Pack
history, waveform files, 206
licensing, 199
licensing, installing, 200
licensing, understanding, 199
licensing, waveform file, 200
status messages, 202
warning messages, 210
628, error, 180
64QAM softkey, 225
651/652/654, option
description, 4
multitone mode, 258
two-tone mode, 252
670/671/672, option
description, 4
8557D GPIB only softkey, 32, 34
8648A/B/C/D GPIB only softkey, 32, 34
8656B,8657A/B GPIB only softkey, 32, 34
8-Lvl FSK softkey, 225

A
AC power receptacle, 15, 21
ACP, 222
Activate Secure Display softkey, 26
active
entry, 281
entry area, 11
Active High softkey, 159
Active Low softkey, 159

Add Comment To softkey, 67
additive white Gaussian noise. See AWGN
address, GPIB, 29
Adjust Phase softkey, 43, 45
Adjustable doublet softkey, 118
adjustments

1/Q, 124,186

quadrature, 186

real-time phase noise, 219
advance, segment, 161
Advanced Settings softkey, 30
Aeroflex softkey, 32, 34
Agilent MXG

modes of operation, 4
Agilent sales and service offices, 279
ALC

hold, 143, 144

OFF annunciator, 11,13

off mode, 103

softkeys, 43, 45, 147
alc

setting, 45
ALC Input

connector, 23
All softkey, 61
Alpha, 281
AM

annunciator, 11,13

connector, 15, 21

external source, 75

hardkey, 73

softkeys, 73
amplitude

display area, 12

hardkey, 43, 45

modulation, 73

offset, 104

reference, 105

setting, 43, 45

softkeys, 45-54

troubleshooting sweep, 275
AMPTD hardkey, 43, 45
Amptd softkeys, 45-54
analog modulation, 4, 73
angle, quadrature, 124
annunciators, 11, 13
APCO 25 w/C4FM softkey, 224
APCO 25 w/CQPSK softkey, 224
apodization settings, FIR filter, 242
application notes

1410, 252
Apply To Waveform softkey, 147
ARB

definition, 281

player, dual, 128

Index
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Index

softkeys, 128, 157, 212, 216 multitone mode, 4, 258
waveform clipping, 165 two-tone mode, 252
arb, 222 BB GEN, 185
Arb Segment softkey, 66 BBG
Arb Sequence softkey, 66 media, 128, 130
ARMED annunciator, 11,13 media (definition), 281
arrow keys, 41 Memory softkey, 66
ASK Depth softkey, 225 Memory to USB softkey, 66
ASK softkey, 225 routing, 185
ATTEN HOLD annunciator, 11,13 Segments softkey, 61, 136
Atten/ALC Control softkey, 43, 45 BBG sync, 188
Auto softkeys configure setup, 192
(DHCP/Auto-IP), 30 equipment setup, 192
Auto, 103 resynchronization, 194
Recall, 116 system, 191
AUTOGEN_WAVEFORM file, 222 system delay, 191
auto-IP, 30 trigger setup, 191
Auto-IP softkey, 30 BbT, 281
Automatically Use USB Media If Present softkey, 61 Binary softkey, 61
AUX I/0 connector, 20 bits per symbol, equation, 246
Auxiliary Software Options softkey, 36, 37 Bk Sp hardkey, 41
AWGN Bluetooth softkey, 224, 225
adding, 211 BNC, 281
annunciator, 12, 13 bootrom memory, 263
definition, 281 Bright Color softkey, 26
dual ARB player, 211 brightness adjustment, 26
softkeys, 214 Brightness softkey, 26
AWGN softkeys, 212 Buffered Trig softkey, 159
Build New Waveform Sequence softkey, 132, 155
B Burst Envelope softkey, 183

backspace hardkey, 41 Bus softkey, 47

Bandwidth softkey, 214

baseband, 20 c
aligning signals at, 143 C/N, 281
clipping, 165 C4FM softkey, 225
frequency offset cables
softkey location, 180 crossover, 30
frequency offset, setting, 180 multi- BBG sync, 191
I/Q output connectors, 18 cables, 100Base-T LAN, 30
memory, 128, 263 Calculate softkey, 136
noise, 211 calibration
noise annunciator, 12,13 data, 263
quadrature adjustment, 186 data memory, 265
real time I/Q AWGN, 212, 214 1/Q, 187
softkey, 180 softkey, 187
summing signals, 185 Calibration Type softkey, 187
waveforms convert to analog, 175 Cancel hardkey, 6
baseband frequency offset carrier
DAC over range & scaling, 181 bandwidth, 211
softkey, 180 configuring, 43
baseband generator, 222 feedthrough, 124
custom arb mode, 4 modulating, 58
dual arb mode, 5 softkeys, 212
multiple BBG synchronization, 188 to noise ratio, 211
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Carrier Bandwidth softkey, 212 Contrast softkey, 26
carrier feedthrough, minimizing, 255 Copy & softkeys
Carrier Softkey, 212 Play Sequence, 65
Carrier to Noise softkey, 212 Play Waveform, 65
Carrier+Noise softkey, 212 Select User Flatness, 65
Catalog Type softkey, 61, 62, 66, 136 Select User Flatness Corrections, 65
catalog, state files, 70 Copy softkeys
ccew, 281 All Files, 66
CDPD softkey, 224, 225 File, 61
ceiling function, bits per symbol, 246 File to Instrument, 61, 66
Channel Band softkey, 43, 45 File to USB, 66
Channel Number softkey, 43, 45 correction array (user flatness), 92
circular clipping, 169, 172 viewing, 93
classified. See security See also user flatness correction
Clear softkeys cosine filter. See nyquist filter
Error Queue(s), 72 Create Directory softkey, 61, 66
Header, 136 crossover cable, 30
Text, 41 custom
clipping multicarrier TDMA waveforms
circular, 169, 172 creating, 234
rectangular, 170, 173 TDMA digital modulation, 227
softkeys, 165 Custom ARB softkeys, 223
clock, sample rate, 20 custom arb waveform generator, 4
coefficient values, entering, 238 custom mode, 222
color palette, display, 26 custom modulation
comments, adding & editing (instrument state), 68 adding to a waveform, 227
component test, 222 waveform, adding to, 227
Config Type softkey, 30 cw, 281
Configure softkeys CW (no modulation) softkey, 54
Cal Array, 87 CW mode
List Sweep, 47, 54 description, 4
Step Array, 87
Step Sweep, 47,49 D
Confirm Load From File softkey, 65 DO1, 199

Connection Monitoring softkey, 30

DAC over range error, 175, 180
Connection Type softkeys

DAC over range protection

Sockets, 90 baseband frequency offset, 181

USB, 90 phase noise, 220

VXI-11, 90 Dark Color softkey, 26
connectors data

external triggering source, 162, 164
front panel, b, 9
rear panel

calibration, 263
entry softkeys, 41

erasing, 266
n5161a, 15 files, 60-67

n5162a, 15 removing, 266
n5181a, 15 serial, synchronizing, 20
n5182a, 15 storage
n5183a, 21 comments, adding and editing, 68
routing signals, 48 troubleshooting, 276
Continuous softkey, 159 type, 71
continuous step sweep example, 57 using, 60

continuous wave date, setting, 28
, g

description, 4 de offset, 124

continuous wave output, 43 dc offset, removing, 75
\ ,

contrast adjustment, 26 DCFM®/DCIM Cal softkey, 73
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DECT softkey, 224
Default Gateway softkey, 30
default settings

restoring, 27, 30, 187

system, restoring, 40
Default softkey, 224
delay

1/Q, 186

multiple BBG sync, 191
Delete softkeys

All Regs in Seq, 67

All Segments On Int Media, 130

All Segments On USB Media, 130

All Sequence Files, 61

All Sequences, 67,116

All Waveforms, 132

All Waveforms softkey, 155

File, 61

File or Directory, 61, 63, 66, 71

Item, 54

Row, 54

Selected Waveform, 132, 155

Seq Reg, 67

Waveform Sequence, 155
description & plots, phase noise, 217
DETHTR annunciator, 12, 13
Device softkey, 43, 45
DHCP, 30, 281
DHCP softkey, 30
Diff Mode softkeys, 186
differential encoding, 244
differential encoding, bits per symbol, 246
differential state map, bits per symbol, 246
DIGBUS annunciator, 12,13
digital bus, 19
digital modulation

formats, 4

1Q map, QAM, 245

multitone, 258-261

TDMA, 227

two tone, 252-257
digital modulation type

modifying, 230
digital operation, 127, 199
digital signal to analog waveform, 175
display

blanking, 269

error message area, 12

memory, 263

overview, 5

front panel

display. 13
overview, N5161A/62A, 13
overview, N5181A/82A/83A, 11

secure, 269

settings, 26

softkey labels, 13

softkeys, 25, 41, 147

tests, 278

text area, 13

troubleshooting, 272
Display softkeys

Case, 41

display, 25

Waveform And Markers, 147
Displayed Case softkeys, 41
distortion, troubleshooting, 273
DNS Server Override softkey, 30
DNS Server softkey, 30
documentation, xiii
Domain Name softkey, 30
doublet

adjustable, 120

softkeys, 118

trigger, 120
dual ARB

multi- BBG sync, 188

player, 128

real-time noise, 211

softkeys, 129, 212, 216
dual arb, 222
dual ARB player, 5
dual arbitrary waveform generator, 5
dual display, power meter, 78
dwell time, 54, 281
Dwell Type softkey, 54
dwell, troubleshooting, 275
Dynamic DNS Naming softkey, 30
Dynamic Hostname Services softkey, 30

E

E4428C, E4438C softkey, 32, 34
E442xB, E443xB softkey, 32, 34
E8241A, E8244A, E8251A, E8254A softkey, 32, 34
E8247C, E8257C, E8267C softkey, 32, 34
E8257D, E8267D softkey, 32, 34
EDGE

custom digital modulation, predefined, 227
EDGE softkey, 224
Edit softkeys

Description, 136

Noise RMS Override, 136

Repetitions, 155

RMS, 136

Selected Waveform Sequence, 132, 155
Editing Keys softkey, 41
Editing Mode softkey, 41
EEPROM, 263
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Enable/Disable Markers softkey, 132, 155
Enter Directory softkey, 65
entry, active, 281
equipment setup, 192
equipment, user flatness correction, 88, 89
ERR annunciator, 12, 13
Error hardkey, 72
error messages, 72
DAC over range, 175, 180
display area, 12
file, 277
message format, 72
types, 277
Esc hardkey, 6
EVENT
connector, AUX 1/0, 20
connector, BNC, 19, 142
output jitter, 157
outputs, 142
EVM, 281
EVM error, 124
example
5-Pack License, adding, 203
5-Pack License, history, 208
Waveform 5-Pack License, adding, 203
Waveform 5-Pack License, history, 208
examples
FIR filters
creating, 237
modifying, 241
Execute Cal softkey, 187
EXT CLOCK connector, 18
EXT REF annunciator, 11,12, 13
Ext softkeys
Delay, 160
Delay Time, 160
Ext, 47
1/Q Output, 183, 184
Pulse, 118
Source, 160
extension, file, 65
external
I and Q signals, 185
media, 71, 276
modulation source, 75
reference oscillator, using, 44
trigger source, 162, 164
triggering, 164
external leveling, 95-102
softkeys, 95
external leveling, configuring, 99
External softkeys
External, 183
Input, 186
Input I Offset, 124

Index

Input Q Offset, 124
Output, 186

F

factory defaults, restoring, 27, 30, 187
features, 2
feedthrough, 124
feedthrough, carrier, minimizing, 255
File hardkey, 61,70
file headers
creating, 136
editing, 138
example, 139
viewing a different file, 140
files
catalog. See data storage
extensions, 65
working with, 60
filter, interpolator, 175
filters
finite impulse response, 237
FIR, 237
gaussian, loading default, 242
nyquist, selecting, 231
finite impulse response filters
using, 237
FIR filter
apodization settings, 242
Hamming, 242
Hann, 242
Kaiser, 242
window settings, 242
FIR filters
creating, 237
modifying, 241
storing, 240
using, 237
FIR table editor
accessing, 237
coefficients, duplicating, 239
coefficients, entering values, 238
coefficients, modifying, 243
files, loading, 242
filters
creating, 237
modifying, 241
storing, 240, 244
oversample ratio, setting, 239
firmware
memory, 263
upgrading, 28, 279
First Mkr Point softkey, 147
First Sample Point softkey, 147
Fixed softkey, 103
flash memory, 263

Agilent N5181A/82A MXG Signal Generators User’s Guide

289



Index

flatness correction. See user flatness correction
Flatness softkey, 87
FM
annunciator, 12, 14
connector, 16, 22
dc offset, removing, 75
external source, 75
hardkey, 73
softkeys, 73
Free Run softkey, 47, 108, 159
Free-Run softkey, 118
Freq Dev softkey, 225
FREQ hardkey, 43, 45
Freq softkeys, 45-54, 87
frequency
display area, 11
hardkey, 7, 8, 43, 45
modulation, 73
multiplier, 106
offset, 104
offset, baseband, 180
offset, softkeys, 180
reference, 105
setting, 43, 45
softkeys, 43, 45, 45-54
step sweep, b0
front panel
disabling keys, 269
display, N5161A, 13
display, N5181A, 11
display, N5182A, 11
display, N5183A, 11
1/Q inputs, using, 125
knob resolution, 27
overview, b, 9
tests, 278
FSK softkey, 225
FTP Server softkey, 31
fundamental operation See basic operation

G

Gated softkey, 118, 159
gated triggering, 159, 162
Gaussian
definition, 281
gaussian filter, loading default, 242
Gaussian. See AWGN
glossary, 281
Go To Default Path softkey, 61, 63, 71
Goto Row softkey, 54, 61
GPIB
connector, 17, 23
definition, 281

Address, 29
Setup, 29
green LED, 8,10
GSM softkey, 224
guides, content of, xiii

hardkeys

definition, 281

help on, 40

overview, 5, 9

See also specific key
header utilities softkeys, 136
Help hardkey, 7, 40
Hostname softkey, 30
hostname, setting, 30
HP 3300A, emulating, 116

I connector, 7
I Offset softkey, 186
I OUT connector, 18
I/0 Config softkey, 25
/Q
adjustments, 124, 186
front panel inputs, using, 125, 185
modulation, 124, 183
optimizing, 184
rear panel outputs, 18
rear panel outputs, using, 184
signal path, optimizing, 184
signal, aligning, 143
softkeys, 124, 183-188
waveform, clipping, 165
ideal low-pass filter. See rectangular filter
IF, 281
images, 124
impairments
I/Q adjustments, 124
impairments, real-time
phase noise, 215
Import Waveform softkey, 155
Incr Set hardkey, 8
information, removing from memory, 266
Insert softkeys
Insert, 132
Item, 54
Row, 54
Waveform, 132
Waveform Sequence Contents, 132
Install Assembly softkey, 38
Install licenses softkey, 65
installation guide content, xiii

setup, 29 instrument
softkeys 8757D Scalar Network Analyzer, 52
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firmware, upgrading, 28
scalar network analyzer, 52
softkeys
Adjustments, 25
Info, 25
Options, 36, 37
state
associating with waveform, 68
files, 67, 70
register. See data storage
softkey, 66
int media, 281
Int Phase Polarity softkey, 183
interface
GPIB, 29
LAN, 30
Internal Baseband Adjustments softkey, 186
internal media, 71
Internal Storage to USB softkey, 66
Internal/USB Storage Selection softkey, 61
interpolator filter, 175
1P
Address softkey, 30
address, setting, 30
auto, 30
definition, 281
1IQ map, QAM modulation, 245

J
jitter on EVENT output, 157

K

keyboard, using, 116
keys

disabling, 269

front panel, b, 9

help on, 40

numeric, 6

test, 278

See also specific key
knob, 8, 27, 41

L
L annunciator, 12, 14
LAN
connector, 17, 23
definition, 282
Services Setup softkey, 29
setup, 30
Setup softkey, 29
Last Mkr Point softkey, 147
Last softkey, 27
LCD display memory, 263
LEDs, 8,10
blink test, 278

front panel, 8, 10
modulation, 59
leveling
external, 95-102
turn off ALC, 103
licenses
manager, 36, 37
service software, 36, 37
signal studio, 36, 37
time- based, 28
troubleshooting, 279
viewing, 36, 37
waveform, 36, 37
line power (green) LED, 8, 10
linear sweep, 49
list mode values, 55
List softkey, 61
list sweep
parameters, 55
status information, 55
troubleshooting, 275
using, 54
waveform, 56
listener mode annunciator, 12, 14
LO, 282
Load From Selected File softkey, 63, 65
Load List softkey, 65
Load softkeys
All From Int Media, 130
All From USB Media, 130
Cal Array From Step Array, 87
From Selected File, 64, 65
Load/Store, 54, 64, 65
Segment From Int Media, 130
Segment From USB Media, 130
Store, 130
Sweep List, 65
Load/Store softkey, 54, 63, 65
Local hardkey, 6
lock up, troubleshooting, 272
logarithmic sweep, 49
LXI, 282
configure
output event softkeys, 113, 114
LXI configure
input
output event setting, 111
input event softkeys, 112

M

main memory, 263
manual control, sweep, 58
Manual softkey, 103
Manual softkeys

Config Settings, 30

Index
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Manual, 30

Mode, 47

Point, 47
manuals, content of, xiii
Marker softkeys, 147
markers

frequency

N5183A, b2
step sweep, 52

markers, aligning signal, 143
markers, waveform, 142-157
media

BBG, 281

erasing, 266

int, 281

memory stick, 71

storage, 71

types, 128, 263

USB, 71, 276
memory

erasing data from, 266

types, 263

See also media
menu keys, 6
messages, error, 277
messages, warning

5-Pack Licensing, 210

Waveform 5-Pack Licensing, 210
mirror table, duplicating coefficients, 239
mixer, troubleshooting signal loss, 273
Mod On/Off hardkey, 7, 58, 59
Mod On/Off, Option UNT, 73
Mod Type Softkeys, 225
Mode hardkey, 129, 212, 214, 216
mode, modulation, 282
modes of operation, 4
Modulated softkey, 103
modulation

AM, 73

analog, 4

annunciators, 12, 14

carrier signal, 58

digital, 4

external source, using, 75

FM, 73

generating, b8

1/Q, 124,183

phase, 73

pulse, 4,117

simultaneous, 60

troubleshooting, 272
Modulator Atten softkey, 214
monochrome display, setting, 26
Monochrome softkey, 26
MSK softkey, 225

MULT annunciator, 12, 14
multi-BBG sync, 188

configure setup, 192

equipment setup, 192

resynchronize, 194

system delay, 191

system sync, 191

trigger setup, 191
multicarrier setup

APCO 25 w/C4FM, 234

APCO 25 w/CQPSK, 234

Bluetooth, 234

CDPD, 234

DECT, 234

Default, 234

EDGE, 234

GSM, 234

NADC, 234

PDC, 234

PHS, 234

PWT, 234

TETRA, 234
multicarrier setup softkeys, 234
multicarrier TDMA waveforms

creating, 234

multicarrier, Default softkey. See quick setup, Default

softkey, settings

multiplier, using, 106
multitone, 222, 258-261
multitone mode, 4

Multitone softkeys, 258
multitone waveform, setup, 251

MXG ATE N5161A/82A Front Panel Functions, 9, 10

N
N7699A-DO01, 199
NADC softkey, 224
Name And Store softkey, 155
Next REG softkey, 116
Next SEQ softkey, 116
No action softkey, 65
No Retrigger softkey, 159
noise, 211
noise bandwidth factor, 211
Noise Mux softkeys, 212
Noise softkey, 212
non-volatile memory, 128
non-volatile, definition, 282
number keys, 41
numeric keypad, 6
nyquist filter

definition
nyquist filter, selecting, 231
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0

OFFS annunciator, 12, 14
offset, 124
offsets
baseband frequency, 180
1/Q. 186
output, using, 104
on/off switch, 8,10
operation
modes of, 4
operation, basic, 39
operation, remote, 29
optimization, 1/Q, 124, 183
option
430
multitone mode, 258
two tone mode, 252
two-tone mode, 252
Option 22x, 199
Option UNT
Mod On/Off hardkey, 73
options
651/652/654
description, 4
multitone mode, 258
two-tone mode, 252
670/671/672, description, 4
enabling, 25, 36, 37
resource, 3
UNT, 4
UNU, 4
UNW, 4
Options 221-229, 199
Options Info softkey, 36, 37
oscillator, external reference, 44
Output Blanking softkey, 43, 45
output, swept, 46
over range error, DAC, 175, 181, 220
overshoot, 175
overview, signal generator, 1

P

Page Up hardkey, 6
parameters, saving a waveform’s, 136
path delay, 124
PATT TRIG IN connector, 19
Patt Trig In softkeys, 160
PDC softkey, 224
peak-to-average power, reducing, 169
performance, optimizing, 77
persistent
memory, 265
persistent settings
definition, 282
resetting, 40

Index

restoring defaults, 27
phase noise
adjustments, 219
DAC over range & scaling, 220
description & plots, 217
impairments, 215
softkeys, 216
Phase Ref Set softkey, 43, 45
phase skew, 124
PHS softkey, 224
pixel test, 278
Plot CDDF softkey, 174
PM Config
Calibrate Sensor, 90
Zero Sensor, 90
PM Config softkeys
Connection Type, 90
PM VXI-11 Device Name, 90
Power Meter IP Address, 90
Power Meter IP Port, 90
Point Trigger softkey, 47
point- to- point time, 282
polarity, external trigger, 160
polarity, marker, setting, 154
power
meter, 86, 91
on, settings, 27
peak- to- average, reducing, 169
receptacle, 15, 21
search, 104
sensor, models, 88, 89
setting, 43, 45
softkeys, 25, 27, 45-54, 103
supply, troubleshooting, 272
switch, 8, 10
troubleshooting, 273
user settable, maximum, 45
power meter
configuration, 91
U2000 Series, 91
U2000A/01A/02A/04A, 91
dual display, 78
power meter configuration sofkeys. See PM Config soft-
keys
power meter sofkeys. See PM Config softkeys
Power Search Reference softkey, 103
Power softkeys
On, 27
On/Preset, 25
Search, 103
preferences, setting, 25
preset
hardkey location, 7
settings, 27
troubleshooting, 276
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using, 40
Preset softkeys
Language, 27
List, 54, 87
Preset, 27
Prev REG softkey, 116
Prev SEQ softkey, 116
Proceed With Reconfiguration softkey, 30, 31
programming guide content, xiii
protection, DAC over range
baseband offset frequency, 181
phase noise impairment, 220
PSK softkey, 225
pulse
annunciator, 12, 14
characteristics, 119
connector, 16, 22
marker, viewing, 151
modulation, 117
narrow, 103
sync signal, 48
video signal, 48
Pulse hardkey, 118
pulse modulation, 4
Pulse softkeys, 48,118
Pulse/RF Blank softkey, 147
PWT softkey, 224

Q
Q connector, 8
Q Offset softkey, 186
QAM modulation IQ map, 245
QAM softkey, 225
quadrature adjustment, 186
quadrature angle, 124
Quadrature Angle Adjustment softkey, 124, 186
queue, error, 72
quick setup

Default softkey

settings, 224

Quick Setup Softkeys, 224

R annunciator, 12, 14
raised cosine filter. See nyquist filter
RAM, 263, 265
real-time
AWGN
softkeys, 212
I/Q Baseband AWGN softkeys, 214
noise, 211
phase noise, 215
adjustments, 219
DAC over range & scaling, 220
description & plots, 217

impairments, 215
softkeys, 216
rear panel
1/Q outputs, 184
overview
n5161a, 15
n5162a, 15
n5181a, 15
n5182a, 15
n5183a, 21
Recall hardkey, 67
Recall keys
hardkey, 116
Instrument State, 61, 65
Reg, 116
State, 65
recall register, troubleshooting, 275
receiver test, 222
rectangular clipping, 170, 173
rectangular filter
definition, 282
REF annunciator, 12, 14
REF IN connector, 16, 22
Ref Oscillator Ext Bandwidth key, 44
Ref Oscillator Ext Freq key, 44
Ref Oscillator Source softkey, 43, 45
reference oscillator, external, 44
reference, using, 105
references, content of, xiii
regrowth, spectral, 168
remote interface, emulate HP 3300A, 116
Remote Language softkey, 29, 32, 34
remote operation annunciator, 12, 14
remote operation preferences, 29
Remove Assembly softkey, 38
Rename File softkey, 61
Rename Segment softkey, 130
Reset & Run softkey, 159
Restart on Trig softkey, 159
Restore softkeys
LAN Settings to Default Values, 30
System Settings to Default Values, 27
resynchronize, multi- BBGs, 194
Return hardkey, 8
Reverse Power Protection softkey, 27
Revert to Default Cal Settings softkey, 187
RF
blanking
marker function, 152
settings, saving, 143
hardkey, 7, 10
output
configuring, 43
connector, 7
leveling, external, 95-102
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troubleshooting, 272
RF During Power Search softkey, 103
RF Output softkey, 183, 184
RFC NETBIOS Naming softkey, 30
ringing, 175
ripple, 175
RMS, 282
RMS softkey, 103
Rohde & Schwarz softkey, 32, 34
roort, 282
root cosine filter. See root nyquist filter
root mean square, 282
Root Nyquist Filter
definition, 282
root nyquist filter
definition, 282
rotary knob, 41
Route Connectors softkey, 47,118
Route To softkeys, 48,118
routing
1/Q, 124,183
marker
ALC hold, 144
RF blanking, 152
saving settings, 143
RPG test, 278
runtime scaling, 177

S

S annunciator, 12, 14
sales, Agilent offices, 279
sample rate clock, 20
sample rate softkey, 157
Save hardkey, 67
SAVE Seq Reg softkey, 67
Save Setup To Header softkey, 136
Scale Waveform Data softkey, 174
scaling softkeys, 174
SCPI

enabling, 31

reference content, xiii

softkey, 32, 34
screen saver settings, 26
Screen Saver softkey, 26
search, power, 104
secure

display, 269

mode, 268
security, 263
Security softkey, 61
Segment Advance softkey, 159
segment advance triggering, 159
segments

advance triggering, 161

file headers, 136

loading, 130

softkeys, 130

storing, loading, & playing, 130
Select hardkey, 41
Select Seq softkey, 116
Select softkeys

Color Palette, 26

Different Header, 136, 140

Header, 136

Internal File(s) to Copy to USB, 66

Reg, 67

Seq, 67

Waveform, 54
self test, 278
Sequence softkey, 61, 136
sequences

editing, 134

file headers, 136

marker control, 154

playing, 135

waveform, 132
serial data, synchronizing, 20
server, enabling, 31
service

Agilent offices, 279

guide content, xiii

request annunciator, 12, 14
Set Marker softkeys, 147
settings, persistent, 282
settings, phase noise, 219
Show softkeys

Alpha Table, 41

Waveform Sequence, 132

Waveform Sequence Contents, 132, 155
signal generator

modes, 4
Signal Studio, 3
signal studio licenses, 36, 37
sinewave, 282
Single softkey, 159
Single Sweep softkey, 47
skew, 1/Q, 186
Sockets SCPI softkey, 31
sockets, enabling, 31
softkeys

definition of, 282

help on, 40

label area, 13

location, 5

See also specific key
source settled signal, 48
Source Settled softkey, 48, 118
Span softkey, 103

Index

Specify Default Storage Path for User Media softkey, 61

spectral regrowth, 168
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spectrum analyzer, troubleshooting signal loss, 273 TCP Keep Alive softkeys, 30
square root raised cosine filter. See root nyquist filter TDMA
Square softkey, 118 custom digital modulation, predefined, 227

standard, modulation, 282
standby (yellow) LED, 8, 10
State softkey, 61

states, persistent, 282

step array (user flatness), 92

See also user flatness correction

Step Dwell softkey, 49, 108
Step Spacing softkey, 49
step sweep
spacing, 49
troubleshooting, 275
using, 49
Step/Knob Ratio softkey, 27
Storage Type softkey, 63, 71

Store Custom Dig Mod State softkey, 226

Store To File softkey, 63, 64, 65
Stored Segments softkey, 61, 136
Subnet Mask softkey, 30
Sum softkey, 183
sweep
annunciator, 12, 14
hardkey, 47
linear, 49
list parameters, b5
list status information, 55
logarithmic, 49
manual control, 58
mode, 4
out connector, 15, 21, 48
out signal, 48
softkeys, 47-58, 118
step, 49
troubleshooting, 275
waveform, including, 56
SWEEP hardkey, 47
Sweep softkeys, 47-58, 66, 118
swept output, 46
switch, power, 8, 10
SWMAN annunciator, 12, 14
synchronize multi- BBGs, 188
configure setup, 192
equipment setup, 192
resynchronize, 194
system delay, 191
system sync, 191
trigger setup, 191
system defaults, restoring, 27

T

T annunciator, 12, 14
talker mode annunciator, 12, 14
TCP, 283

TDMA digital modulation, 227
terminator, 283
test, self, 278
tests, front panel, 278
TETRA softkey, 224
text area (on display), 13
text entry softkeys, 130
time, dwell, 281
time, setting, 28
time/date reference point, 28
Time/Date softkey, 28
time-based license, 28, 279
Timer Trigger softkey, 47, 108
Toggle softkeys, 155
Trig

in connector, 16, 22

out connector, 16, 22, 48

out signal, 48
trigger

connectors, 16, 22

hardkey, 6

initiating, 6

multiple BBG sync, 191
Trigger setup softkeys, 109
Trigger softkeys

& Run, 159

Doublet, 118

Key, 47

Out Polarity, 47

Source, 158

Triggered, 118

Type, 158
Triggered softkey, 118
triggering

gated, 159, 162

multiple BBG sync, 191

equipment setup, 192

segment advance, 159

softkeys, 158

waveforms, 158
troubleshooting, 271
two tone, 222, 252-257
two tone softkeys, 253
two-tone softkeys, 253
two-tone waveform, setup, 251
type, modulation, 282

U

UNLEVEL annunciator, 12, 14
unleveled operation, 103
UNLOCK annunciator, 12, 14
Unspecified softkey, 136
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UNT, option, 4
UNU, option, 4
UNW, option, 4
Up Directory softkey, 61, 63, 66
Update in Remote softkey, 26
urls, 3, 28, 36, 37, 279
USB
connecting media, 71
definition, 283
device connector, 17,23
host connector, 5, 10
keyboard, using, 116
softkeys
File Manager, 61, 62
Keyboard Control, 116
to BBG Memory softkey, 66
to Internal Storage softkey, 66
troubleshooting, 276
Use softkeys
As, 65
Current Directory As Default Path, 61,71
Only Internal Storage, 61
Only USB Media, 61
user
documentation content, xiii
files, backup and restore, 60
flatness correction, 86
preset, 40
preset, troubleshooting, 276
user FIR
definition, 283
User softkeys
Configure Power Meter, 87
Current Directory As Default Path, 63
Do Cal, 87
Flatness, 43, 45, 61
Flatness Correction, 87
Flatness Corrections, 66
Span, 103
User, 27
Utility hardkey, 25
Utillity softkey, 38

v

vector operation, 127, 199

View Next Error Page softkey, 72
View Previous Error Page softkey, 72
volatile memory, 128, 130

volatile, definition, 283

VXI- 11, enabling, 31

VXT-11 SCPI softkey, 31

W

waveform
adding custom modulation, 227

Index

Waveform 5-Pack
history, using, 206
history, waveform files, 206
licensing, 199
licensing, installing, 200
licensing, understanding, 199
licensing, warning messages, 210
licensing, waveform file, 200
status messages, 202
using, 199
Waveform softkeys
Licenses, 36, 37
Runtime Scaling, 174
Segments, 130
Sequences, 132, 155
Utilities, 174
Waveform, 47, 54
waveforms
clipping, 165
file headers, 136
from digital baseband waveform, 175
in a sweep, 56
license, 36, 37
markers, 142, 143
memory, 265
multiple BBG synchronization, 188
multitone, 258-261
overview, 128
saving instrument state, 68
scaling, 174
segment softkeys, 130
sequence, 132
storing, loading, & playing, 130
triggering, 158
two- tone, 252-257
Waveform 5- Pack, 206
Web Server softkey, 31
window settings, FIR filter, 242
WINIT annunciator, 12, 14

Y
yellow LED, 8, 10

Z

Z- axis output
connector, 23

Zoom softkeys, 147

Agilent N5181A/82A MXG Signal Generators User’s Guide

297



Index

298

Agilent N5181A/82A MXG Signal Generators User’s Guide



	Title Page

	Table of Contents
	Documentation Overview
	1 Signal Generator Overview
	Signal Generator Features
	Modes of Operation
	Continuous Wave
	Swept Signal
	Analog Modulation
	Digital Modulation (N5162A/82A with Options 651, 652, or 654 Only)

	Front Panel Overview - MXG N5181A/82A
	1. Host USB
	2. Display
	3. Softkeys
	4. Numeric Keypad
	5. Arrows and Select
	6. Page Up
	7. MENUS
	8. Trigger
	9. Local Cancel/(Esc)
	10. Help
	11. Preset and User Preset
	12. RF Output
	13. RF On/Off and LED
	14. Mod On/Off and LED
	15. Page Down
	16. I Input (vector models only)
	17. Q Input (vector models only)
	18. Knob
	19. Incr Set 
	20. Return 
	21. More and LED
	22. Power Switch and LEDs

	Front Panel Overview - MXG ATE N5161A/62A
	MXG ATE N5161A/62A Front Panel Functions
	3. LAN LED 
	4. 1588 LED
	5. ERROR LED
	6. LAN Reset Hardkey 
	7. Host USB
	8. RF On/Off and LED
	22. Power Switch and LEDs

	Front Panel Display - MXG N5181A/82A/83A
	1. Active Function Area
	2. Frequency Area
	3. Annunciators
	4. Amplitude Area
	5. Error Message Area
	6. Text Area
	7. Softkey Label Area

	Blank Front Panel Display - MXG ATE N5161A/62A
	MXG ATE N5161A/62A - Web Enabled Display
	Annunciators

	Rear Panel Overview - MXG N5161A
	1. AC Power Receptacle
	2. SWEEP OUT
	3. AM
	4. FM
	5. PULSE
	6. TRIG IN
	7. TRIG OUT
	8. REF IN
	9. 10 MHz OUT
	10. GPIB
	11. LAN
	12. Device USB
	Digital Modulation Connectors (Vector Models Only)
	I OUT, Q OUT, 
	EXT CLK
	EVENT 1
	PAT TRIG
	DIGITAL BUS I/O
	AUX I/O

	Rear Panel Overview - MXG N5183A
	1. AC Power Receptacle
	2. SWEEP OUT
	3. AM
	4. FM
	5. PULSE
	6. TRIG IN
	7. TRIG OUT
	8. REF IN
	9. 10 MHz OUT
	10. GPIB
	11. LAN
	12. Device USB
	13. Z AXIS OUTPUT
	14. ALC INPUT


	2 Setting Preferences & Enabling Options
	User Preferences
	Display Settings
	Power On and Preset
	Front Panel Knob Resolution
	Setting Time and Date

	Upgrading Firmware
	Remote Operation Preferences
	GPIB Address and Remote Language
	Configuring the LAN Interface
	Enabling LAN Services: “Browser,” “Sockets,” “VXI-11” and “LXI-B”
	Configuring the Remote Languages
	Configuring the Preset Languages

	Enabling an Option
	Viewing Options and Licenses

	Service Menu
	Viewing Options and Licenses
	Hardware Assembly Installation and Removal Softkeys


	3 Basic Operation
	Presetting the Signal Generator
	Viewing Key Descriptions
	Entering and Editing Numbers and Text
	Entering Numbers and Moving the Cursor
	Entering Alpha Characters
	Example: Using a Table Editor

	Setting Frequency and Power (Amplitude)
	Example: Configuring a 700 MHz, -20 dBm Continuous Wave Output
	Using an External Reference Oscillator

	Setting ALC Bandwidth Control
	Configuring a Swept Output
	Routing Signals
	Step Sweep
	List Sweep
	Example: Using a Single Sweep
	Example: Manual Control of Sweep

	Modulating the Carrier Signal
	Example
	Simultaneous Modulation

	Working with Files
	File Softkeys
	Viewing a List of Stored Files
	Storing a File
	Loading (Recalling) a Stored File
	Moving a File from One Media to Another
	Working with Instrument State Files
	Selecting the Default Storage Media

	Reading Error Messages
	Error Message Format


	4 Using Analog Modulation (Option UNT Only)
	The Basic Procedure
	Using an External Modulation Source
	Removing a DC Offset


	5 Optimizing Performance
	Using the Dual Power Meter Display
	Example: Dual Power Meter Calibration

	Using Flatness Correction
	Creating a User Flatness Correction Array
	Recalling and Applying a User Flatness Correction Array

	Using External Leveling (N5183A Only)
	Option 1E1 Output Attenuator Behavior and Use
	Configure External Leveling

	Using Unleveled Operating Modes
	ALC Off Mode
	Power Search Mode

	Using an Output Offset, Reference, or Multiplier
	Setting an Output Offset
	Setting an Output Reference
	Setting a Frequency Multiplier

	Using Free Run, Step Dwell, and Timer Trigger
	Understanding Free Run, Step Dwell, and Timer Trigger Setup

	Using LXI
	Understanding LXI Clocks
	Getting Started With LXI
	For More Information

	Using a USB Keyboard

	6 Using Pulse Modulation (Option UNU or UNW)
	Pulse Characteristics
	The Basic Procedure
	Example

	7 Basic Digital Operation—No BBG Option Installed
	I/Q Modulation
	Configuring the Front Panel Inputs


	8 Basic Digital Operation (Option 651/652/654)
	Waveform File Basics
	Signal Generator Memory
	Dual ARB Player

	Storing, Loading, and Playing a Waveform Segment
	Loading a Waveform Segment into BBG Media
	Storing/Renaming a Waveform Segment to Internal or USB Media
	Playing a Waveform Segment

	Waveform Sequences
	Creating a Sequence
	Viewing the Contents of a Sequence
	Editing a Sequence
	Playing a Sequence

	Saving a Waveform’s Settings & Parameters
	Viewing and Modifying Header Information 
	Viewing & Editing a Header without Selecting the Waveform

	Using Waveform Markers
	Waveform Marker Concepts
	Accessing Marker Utilities
	Viewing Waveform Segment Markers
	Clearing Marker Points from a Waveform Segment
	Setting Marker Points in a Waveform Segment
	Viewing a Marker Pulse
	Using the RF Blanking Marker Function
	Setting Marker Polarity
	Controlling Markers in a Waveform Sequence
	Using the EVENT Output Signal as an Instrument Trigger

	Triggering a Waveform
	Trigger Type
	Trigger Source
	Example: Segment Advance Triggering
	Example: Gated Triggering
	Example: External Triggering

	Clipping a Waveform
	How Power Peaks Develop
	How Peaks Cause Spectral Regrowth
	How Clipping Reduces Peak-to-Average Power
	Configuring Circular Clipping
	Configuring Rectangular Clipping

	Scaling a Waveform
	How DAC Over-Range Errors Occur
	How Scaling Eliminates DAC Over-Range Errors
	Setting Waveform Runtime Scaling
	Setting Waveform Scaling

	Setting the Baseband Frequency Offset
	DAC Over-Range Conditions and Scaling

	I/Q Modulation
	Using the Rear Panel I and Q Outputs
	Configuring the Front Panel Inputs

	I/Q Adjustments
	I/Q Calibration
	Multiple Baseband Generator Synchronization
	Understanding the Master/Slave System
	Equipment Setup
	Configuring the Setup
	Making Changes to the Multiple Sync Setup and Resynchronizing the Master/Slave System

	Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization
	Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

	Waveform 5-Pack Licensing (Options 221-229)
	Understanding Waveform 5-Pack Licensing
	Installing an Option N5182A-22x Waveform 5-Pack Licensing
	Licensing a Signal Generator Waveform File
	Waveform 5-Pack Licensing Softkeys Overview
	Using Waveform 5-Pack History
	Waveform 5-Pack Warning Messages


	9 Adding Real-Time Noise to a Signal (Option 403)
	Adding Real-Time Noise to a Dual ARB Waveform
	Example

	Using Real Time I/Q Baseband AWGN

	10 Real-Time Phase Noise Impairments (Option 432)
	Real-Time Phase Noise Impairment
	The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments
	Understanding the Phase Noise Adjustments
	DAC Over-Range Conditions and Scaling

	11 Custom Digital Modulation (Option 431)
	Custom Modulation 
	ARB Custom Modulation Waveform Generator

	Using the Arbitrary Waveform Generator
	Using Predefined Custom TDMA Digital Modulation
	Creating a Custom TDMA Digital Modulation State
	Storing a Custom TDMA Digital Modulation State
	Recalling a Custom TDMA Digital Modulation State
	Creating a Custom Multicarrier TDMA Digital Modulation State
	Storing a Custom Multicarrier TDMA Digital Modulation State
	Applying Changes to an Active Multicarrier TDMA Digital Modulation State

	Using Finite Impulse Response (FIR) Filters
	Creating a User-Defined FIR Filter Using the FIR Table Editor

	Modifying a FIR Filter Using the FIR Table Editor
	Loading the Default Gaussian FIR File
	Modifying the Coefficients
	Storing the Filter to Memory

	Differential Encoding
	Using Differential Encoding


	12 Multitone and Two-Tone Waveform Generator (Option 430)
	Creating a Custom Two-Tone Waveform
	Creating a Custom Multitone Waveform
	Using Two-Tone Modulation
	Two Tone Modulation Softkeys
	Creating a Two-Tone Waveform
	Viewing a Two-Tone Waveform
	Minimizing Carrier Feedthrough
	Changing the Alignment of a Two-Tone Waveform

	Using Multitone Modulation
	Multitone Modulation Softkeys
	Initializing the Multitone Setup Table Editor
	Configuring Tone Powers and Tone Phases
	Removing a Tone
	Generating the Waveform
	Configuring the RF Output
	Applying Changes to an Active Multitone Signal


	13 Working in a Secure Environment
	Understanding Memory Types
	Removing Data from Memory (Option 006 Only)
	Erase All
	Erase and Overwrite All
	Erase and Sanitize All
	Removing Persistent State Information Not Removed During Erase
	Secure Mode
	Securing a Nonfunctioning Instrument

	Using the Secure Display (Option 006 Only)

	14 Troubleshooting
	Display
	The Display is Too Dark to Read
	The Display Turns Black when Using USB Media

	Signal Generator Lock-Up
	RF Output
	No RF Output
	Power Supply Shuts Down
	No Modulation at the RF Output
	RF Output Power too Low
	Distortion
	Signal Loss While Working with a Spectrum Analyzer
	Signal Loss While Working with a Mixer

	Sweep
	Cannot Turn Off Sweep
	Sweep Appears Stalled
	Incorrect List Sweep Dwell Time
	List Sweep Information is Missing from a Recalled Register
	Amplitude Does Not Change in List or Step Sweep

	Internal Media Data Storage
	Instrument State Saved but the Register is Empty or Contains the Wrong State

	USB Media Data Storage
	Instrument Recognizes USB Media Connection, but Does Not Display Files

	Preset
	The Signal Generator Does Not Respond
	Pressing Preset Performs a User Preset

	Error Messages
	Error Message Types
	Error Message File

	Front Panel Tests
	Self Test
	Licenses
	A Time-Based License Quits Working
	Cannot Load a Time-Based License

	Contacting Agilent Technologies
	Returning a Signal Generator to Agilent


	Glossary

	Index




